Announcement

Collapse
No announcement yet.

Entourage/Evolution/DavMail authentication problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Entourage/Evolution/DavMail authentication problem

    Hello everybody,

    I'm running Exchange 2007 on Win Server 2003.
    Mailboxes, Client access and AD roles are on a single server, and a second one is working as Edge server.

    After "something" i still have to investigate messed up the IIS Virtual directories settings, i had to set them up again, authentication settings and application pools.
    Everything is working fine now (OWA, Outlook anywhere, Activesync) apart for some users who are connecting with Entourage 2010, Evolution with Exchange setup, and some Thunderbird clients on Windows with the DavMail plugin installed.

    What they have in common should be the use of WebDav, i believe.
    I've searched around the web but found nothing to solve my problem.

    To narrow down the troubleshooting i can say Test-OutlookWebServices output gives no error, and...
    from the Exchange server, if i try to open [https:] //localhost/owa i get the correct page, while if i try [https:] //localhost/exchange i get a "The page cannot be found" error . I guess redirection does not work...

    Any help will be greatly appreciated,

    GiBit

  • #2
    Re: Entourage/Evolution/DavMail authentication problem

    Exchange 2007 doesnt support WebDav. You need Exchange 2003 for that.
    And the virtual directory for OWA in Exchange 2007 is /OWA. Exchange 2003 OWA was /Exchange.

    If your going to use Open Source clients and/or Entourage you'll need a client that supports Exchange 2007 web services. Im still using Entourage 2008 which supports Webdav. Im also using an ancient version of Evolution that supports Webdav as one of my exchanges runs 2003 for WebDav support. To my knowledge the newer versions of Davmail now support Exchange 2007 but you'll need to check on their website. Likewise the same for Evolution and Entourage.
    Shame MS deprecated the support for these open protocols as Webdav is in my opinion more superior to MS proprietary RPC over HTTP. Just my 2 cents of course...
    Last edited by scurlaruntings; 16th September 2010, 21:54.

    Comment


    • #3
      Re: Entourage/Evolution/DavMail authentication problem

      Thanks for your answer,
      maybe i'm confused about webdav, and it's just a matter of webservices,
      the fact is until the day before the problem with authentication settings all those clients were working fine...

      Comment


      • #4
        Re: Entourage/Evolution/DavMail authentication problem

        Exchange 2007 does support WebDAV, with Exchange 2010 this interface is gone.

        Look at the properties under Server Configuration --> Mailbox.

        Check with this technet article, might help somewhat:
        http://support.microsoft.com/?scid=k...47802&x=7&y=11.

        Comment


        • #5
          Re: Entourage/Evolution/DavMail authentication problem

          Originally posted by Gibit View Post
          Thanks for your answer,
          maybe i'm confused about webdav, and it's just a matter of webservices,
          the fact is until the day before the problem with authentication settings all those clients were working fine...
          Webservices is what replaced the support for Webdav in Exchange 2007. As long as your Entourage/Evolution/Davmail clients support 2007 and are pointing to the URL for your Exchange server it should still work. Just ensure you drop the http/https from the URL. Older Evolution clients required this. But the newer ones have a tick box (As does Entourage) to specify the protocol being used to connect to the server.

          Comment

          Working...
          X