Announcement

Collapse
No announcement yet.

Exchange ActiveSync

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange ActiveSync

    Hi,

    I have checked through quite a few ActiveSync posts but can't find the answer I'm after so hopefully this is not a duplicate!

    I am trying to set up ActiveSync with Exchange 2007. The problem I have is that we host our website with an ISP so our Exchange Server has no external domain name that I can use for autodiscovery.

    Apologies if this is a very simple question but please could someone point me in the right direction so that I can resolve this.

    Many thanks,

    Marcus

  • #2
    Re: Exchange ActiveSync

    Presumably you own your domain name though, and your ISP hosts www.domain.com or similar for you?

    If so, just ask them to add an A record to DNS for mail.domain.com and whatever else you need pointing to the external IP address of your server. If you have a DNS control panel you may well be able to do this yourself.
    BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
    sigpic
    Cruachan's Blog

    Comment


    • #3
      Re: Exchange ActiveSync

      Hi,

      Many thanks for your reply.

      I am using Zonedit to manage the DNS. Email currently gets pushed through Google/Postini Message Security prior to being received so the MX records point to them.

      If I change the A Record presumably delivery of email to the above and website traffic will work as normal?

      Many thanks again,

      Marcus

      Comment


      • #4
        Re: Exchange ActiveSync

        If you simply add autodiscover and whatever your want your host name to be for the server (owa.example.com) then email and web traffic should not be affected.

        I would wager that most domains operate in the way that you have outlined - with the web site hosted by an ISP. You don't have to host everything yourself to use Exchange with OWA etc.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Exchange ActiveSync

          Ok, many thanks to you both. I'll set it up and will let you know how I get on.

          Comment


          • #6
            Re: Exchange ActiveSync

            I am embarrassed to say that I am still struggling to get ActiveSync to work properly!

            I have:

            Set up a Starfield SAN / UCC SSL cert
            Run the necessary SBS wizards to add the trusted certificate
            Run the necessary Exchange Shell commandlets
            Checked Virtual Directories and permissions IIS
            Set port 443 in bindings and opened the port on the Draytek security appliance

            When I run the activesync connectivity tests at https://www.testexchangeconnectivity.com/ I get the following error:

            Attempting to test potential Autodiscover URL https://domainname/AutoDiscover/AutoDiscover.xml
            Testing of this potential Autodiscover URL failed.
            Test Steps
            Attempting to resolve the host name domainname in DNS.
            The host name resolved successfully.
            Additional Details
            IP addresses returned: xxx.xxx.xxx.xxx

            Testing TCP port 443 on host autodiscover.domainname to ensure it's listening and open.
            The specified port is either blocked, not listening, or not producing the expected response.
            Tell me more about this issue and how to resolve it
            Additional Details
            A network error occurred while communicating with the remote host.
            Exception details:
            Message: No connection could be made because the target machine actively refused it xxx.xxx.xxx.xxx:443

            Also i get the following RPC errors when running test-outlookwebservices | fl

            Id1013 Error when contacting https://autodiscover.domainname/RPC received the error the server committed a protocol violation. section=responsestatusline

            Id 1017 Error when contacting the RPC/HTTP service at https://autodiscover.domainname

            When I run get-outlookanywhere | fl I get

            Warning://IIS/server/W3SVC/1/Root/RPC was not found and in Exchange Version name I get RPC (Default Website) instead of the (SBS Web Applications) that I should be getting.

            The RPC directories are correctly located under SBS Web Applications in IIS so I don't know why exchange has the wrong metabase path. I have run the uninstall RPC over HTTP proxy - add registry entry - install RPC over HTTP proxy and TS Gateway but no joy.

            I have spent ages checking through posts on the Internet, many of which mentioned problems similar to mine but I haven't been able to find a solution that works for me. I assume that the problem lies with the RPC error and hope that if I can fix this ActiveSync will work.


            Any help would be hugely appreciated.

            Many thanks,

            Marcus

            Comment


            • #7
              Re: Exchange ActiveSync

              Update after sorting out the port problem on the router - the testexchangeconnectivity.com error is now:

              The Exchange ActiveSync test failed.
              Test Steps
              Attempting to resolve the host name autodiscover.domainname in DNS.
              The host name resolved successfully.
              Additional Details
              IP addresses returned: x.x.x.x

              Testing TCP port 443 on host autodiscover.domainname to ensure it's listening and open.
              The port was opened successfully.
              Testing the SSL certificate to make sure it's valid.
              The SSL certificate failed one or more certificate validation checks
              A network error occurred while communicating with the remote host.
              Exception details:
              Message: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

              Comment


              • #8
                Re: Exchange ActiveSync

                I have got this working at long last!

                The problem was caused by the router using port 443 for SSL VPN's (which we don't use or need).

                Comment

                Working...
                X