Announcement

Collapse
No announcement yet.

OWA - Login twice needed? And domain necessity?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA - Login twice needed? And domain necessity?

    Hi all,

    I just rolled out OWA from Exchange 2010 through FireFront TMG. Works perfectly, but I have two questions...

    1. For some reason, when logging in, I have to login twice. What I mean is this... I type in my username and password. Upon clicking "Sign In", the screen flashes, but does nothing more than clear the password field and make me do it again. Yet when I type the password again, it lets me in normally. HUH??!!

    2. In order to log in, it is requiring domain\username. Is there any way to NOT require the domain? So that a user could simply type in their username? I guess what I'm asking is if it's possible for the OWA system to "imply" domain...

    THANKS!

    Chris

  • #2
    Re: OWA - Login twice needed? And domain necessity?

    You haven't setup OWA correctly on the server for use with TMG. You are being authenticated once by TMG and then again by Exchange itself. By default Exchange 2010 comes with forms based authentication enabled. You will have to change that - it should be documented on Technet on how to configure OWA for use with TMG.

    The domain should be a matter of changing the publishing settings in TMG, but I haven't got a TMG site to look at the moment (don't use TMG in most of my deployments).

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: OWA - Login twice needed? And domain necessity?

      This article covers most of what you need. As Sembee says you need to disable FBA on Exchange and configure it for Basic and Integrated Windows Authentication.

      I'm pretty sure TMG doesn't require the domain name by default, ours doesn't and I don't remember doing any extra configuration to allow that. I'd fix the FBA issue first and try it again before making any other changes.

      Make sure with TMG you use the Exchange publishing wizards for each protocol you are publishing. ISA 200x allowed a single rule for OWA, ActiveSync and Outlook Anywhere. TMG best practice is a seperate rule for each.
      BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
      sigpic
      Cruachan's Blog

      Comment


      • #4
        Re: OWA - Login twice needed? And domain necessity?

        Thanks, fellas! My OWA/FF guru and I will get right on this stuff and I will post back with any questions or troubles.

        You guys rock.

        Chris

        Comment


        • #5
          Re: OWA - Login twice needed? And domain necessity?

          I had the same problem

          did the following and now it just logs in once.

          Exchange Management Console > Server Config > Client Access > OWA > Properties > Authentication

          Under Forms-based Auth, select Username only, add in your domain... press ok out and viola...

          Comment


          • #6
            Re: OWA - Login twice needed? And domain necessity?

            Originally posted by ranjb View Post
            I had the same problem

            did the following and now it just logs in once.

            Exchange Management Console > Server Config > Client Access > OWA > Properties > Authentication

            Under Forms-based Auth, select Username only, add in your domain... press ok out and viola...
            Not relevant in this case, as FBA needs to be turned off on Exchange when you have it published via TMG.
            BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
            sigpic
            Cruachan's Blog

            Comment

            Working...
            X