No announcement yet.

Exchange Database Recovery Errors

  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange Database Recovery Errors

    Hello, I have an Exchange 2007 setup. Just yesterday two mailbox databases failed to mount. I suspect some of the log files are missing. I have checked possible causes of that, but it wasn't an antivirus program. I get this error when trying to mount the database: MapiCallException failed. Exchange Database unable to mount. Event ID 9518. I researched and tried the following eseutil command switches on the database.

    I tried out the eseutil /P switch. It run for about 15hrs and nothing showed up. I also run the eseutil /R E01 on the log file path to replay lost log files; and it returned this output:

    D:\Second_StorageGroup\Logs_Second>eseutil /R E01

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.01
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating RECOVERY mode...
    Logfile base name: E01
    Log files: <current directory>
    System files: <current directory>

    Performing soft recovery...
    Restore Status (% complete)

    0 10 20 30 40 50 60 70 80 90 100

    Operation terminated with error -1216 (JET_errAttachedDatabaseMismatch, An outst
    anding database attachment has been detected at the start or end of recovery, bu
    t database is missing or does not match attachment info) after 0.110 seconds.

    I also run this command:

    eseutil /d"D:\Second_StorageGroup\Database_Second\Database_ Second.edb" /t"<G:\temp.edb>"

    This also gave me an error that I need to run recovery first before defragmenting, which I had already done earlier.

    I also run eseutil /mh switch on the database and found that it was a Dirty Shutdown" of the database

    I would want to know what additional commands or steps I am missing. Thank you.

  • #2
    Re: Exchange Database Recovery Errors


    once you've ran the eseutil /p , there's basically no way back.
    that's hard recovery.

    Exchange 2007 would allow you to do soft recovery with logs missing if you append the /a to /r, eg; eseutil /r02 /a

    are you still stuck in recovery ?


    • #3
      Re: Exchange Database Recovery Errors

      any resolution to this issue?