No announcement yet.

Broken Exchange 2013 Installation

  • Filter
  • Time
  • Show
Clear All
new posts

  • Broken Exchange 2013 Installation

    I have a new Exchange 2013 Standard that was working perfectly until this morning. One of the last things I needed to do was make sure people could connect to it with their iPhones. I did a Google search to make sure all my settings were ready to go. One of the search results stated that a "this is a very important task that must be done" so I did it. I'm not saying it wasn't the right thing to do but apparently it wasn't right for my configuration. It's still possible that it was a coincidence that the mail server broke right about the time I made these changes but I doubt it.
    Here is the link to the article I got my information from:
    Basically, what I did was change every virtual directory (except Powershell) from only having information in the InternalURL field to having the same URL in the InternalURL and ExternalURL field. I changed in the InternalURL field to and copied that into the ExternalURL field.
    In another article someone mentioned changing the Outlook Anywhere settings thusly:
    "For each Exchange server, complete the following steps:
    1. Open the Exchange 2013 web interface.
    2. From the left hand panel of the Exchange admin center page, go to servers and select servers from the main menu.
    3. Double click the Exchange Server that you want to configure.
    4. From the left hand panel of the server configuration window, select Outlook Anywhere.
    5. Enter the external host name for your Exchange Server, for example:
    6. Set the authentication type to Basic. By default, authentication is set to NTLM, which does not work for clients that are connecting from a different domain than the Exchange Server.
    Set the authentication type to Basic. By default, authentication is set to NTLM, which does not work for clients that are connecting from a different domain than the Exchange Server."
    Yep, I'm an idiot.
    It seemed pretty innocuous and easily reversible so I did it.
    Now, even after changing everything back to the orginal values, users running Outlook cannot connect to the Exchange server. Sending and receiving is working fine for OWA. In Outlook 2007, 2010 and 2013 it keeps asking for a password. Most of the time it doesn't accept the password but sometimes it seems to accept the password. Either way though, it'll either say "Need Password" or "Disconnected" in the lower right corner of Outlook. I've tried uninstalling and reinstalling Outlook. I've also tried logging into a workstation with a user who's never been logged into that particular workstation and created a new profile with the same results. Using "myserver" or the Exchange servers IP address when setting up the mail profile manually I get the following message:
    "The action cannot be completed. The Connection to Microsoft Exchange is unavailable. outlook must be online or connected to complete this action."
    Any idea what might be going on?
    Sorry so long winded.
    Any help would be greatly appreciated.

  • #2
    Does the host name that you changed everything to
    a. Resolve internally to the Exchange server?
    b. Exist on your trusted SSL certificate?

    If you don't have a trusted SSL certificate, then that is the first problem.
    You will also need to get your DNS settings corrected.

    Outlook Anywhere authentication should be left alone. Basic will always throw an authentication prompt. Negotiate is the usual setting to use.

    After making the changes, run IISRESET in an elevated command prompt.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.