Announcement

Collapse
No announcement yet.

Exchange 2007 Out of Office Does not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2007 Out of Office Does not working

    Hi guys,

    I would like to ask for help about Exchange 2007 SP3 (fully updated) OOF problem.

    Exchange is installed on Windows 2003 R2 Server SP2 x64 (fully updated)
    A colleague of mine was configuring OWA with client certificate authentication, unfortunatelly I cannot tell exactlywhat was configured at that time, but now I noticed that OOF is not working, and says: your out of office settings cannot be displayed, because the server is currently unavailable. try again later.

    On the client side (Office 2007) in debug mode logging I see this error:

    Errorlog: http://www.textdump.com/v/?k=NzI3OA==
    Searching the web I've found out, that certain dot Net Framework related bugs could also cause this problem, so I've uninstalled
    .Net Framework 3.5 SP1
    .Net Framework 2.0 SP1
    and installed .Net Framework 3.0 SP2 but no luck with that.

    Testing the autodiscover on Outlook 2007 client, the built in test service gave some error messages above:

    Errorlog: http://www.textdump.com/v/?k=NzI3Nw==
    I've checked autodiscover settings, and as I can tell everything seems to be fine.

    Could someone help?

    Regards,

    Xel
    Last edited by xelemorf; 15th November 2010, 10:08.

  • #2
    Re: Exchange 2007 Out of Office Does not working

    Client certificates rarely work correctly.
    Your best option is to reset the certificate services on the web site. Remove the certificate through IIS manager and then run IISRESET.
    Then through EMS, use enable-exchangecertificate to enable the server certificate for IIS. Again run IISRESET after doing so.

    Test again.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Exchange 2007 Out of Office Does not working

      Originally posted by Sembee View Post
      Client certificates rarely work correctly.
      Your best option is to reset the certificate services on the web site. Remove the certificate through IIS manager and then run IISRESET.
      Then through EMS, use enable-exchangecertificate to enable the server certificate for IIS. Again run IISRESET after doing so.

      Test again.

      Simon.
      Hi Simon,

      Thanks for the quick answer!

      I've exported the server certificate to a pfx, removed it from IIS manager, done the IISRESET. Done importing certificate from PFX. In EMS I've used Enable-ExchangeCertificate -Thumbprint "<fingerprintdata>" -services "IIS,IMAP,POP" command to enable the certificate, and after IISRESET and restarting the POP3 and IMAP4 services.

      Outlook 2007 Log:
      http://www.textdump.com/v/?k=NzI4OA==

      Outlook 2007 auto email testing service log:
      http://www.textdump.com/v/?k=NzI5MA==

      No change, the problem still persists.
      Any idea?

      Regards,
      Xel
      Last edited by xelemorf; 15th November 2010, 10:11.

      Comment


      • #4
        Re: Exchange 2007 Out of Office Does not working

        You shouldn't have needed to export the certificate completely, as certificates are stored at the server level. Simply removing it from IIS manager and then put things back should have reset the bindings.

        I would go through the virtual directories manually and ensure that require client certificate is not enabled on any of them. If it is, remove it, then run iisreset to get the change to take.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Exchange 2007 Out of Office Does not working

          Originally posted by Sembee View Post
          You shouldn't have needed to export the certificate completely, as certificates are stored at the server level. Simply removing it from IIS manager and then put things back should have reset the bindings.

          I would go through the virtual directories manually and ensure that require client certificate is not enabled on any of them. If it is, remove it, then run iisreset to get the change to take.

          Simon.

          Hi,

          I've removed the certificate, IISRESET, assigned it as you mentioned.
          The Require client certificate option was active, so I've modified to Ignore client certificates, and IISRESET, but no lock with that.
          Log: http://www.textdump.com/v/?k=NzI5Mg==

          I've also tried Accept client certificate option but doesn't solved the problem.
          Log: http://www.textdump.com/v/?k=NzI5Mw==

          Client certificate mapping is off, and no mappings inside.

          Checking the virtual directories I've find out those are using the Default Web Site settings, so when I modify global settings, all virtual directories follows.

          Any more idea?

          Regards,
          Xel
          Last edited by xelemorf; 15th November 2010, 10:10.

          Comment


          • #6
            Re: Exchange 2007 Out of Office Does not working

            Hi,

            Also tested with UseLegacyFB client tweak
            1. Click Start, click Run, type regedit, and then click OK.
            2. Locate and then click the following registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\O utlook\Options\Calendar
            3. On the Edit menu, point to New, and then click DWORD Value.
            4. Type UseLegacyFB, and then press ENTER.
            5. Right-click UseLegacyFB, and then click Modify.
            6. In the Value data box, type 1, and then click OK.
            7. Exit Registry Editor.

            Still no luck finding solution..

            "your out of office settings cannot be displayed, because the server is currently unavailable. try again later."
            Last edited by xelemorf; 9th August 2010, 12:59.

            Comment


            • #7
              Re: Exchange 2007 Out of Office Does not working

              The arcticle above has a working soultion for the problem:

              http://knol.google.com/k/viktor-varg...3p8r5q3cmw/14#

              Introduction
              When Out of Office drops the message "Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later." it cames from autodiscover problem.
              Try to access the https://yourdomain/Autodiscover/Autodiscover.xml and if you get
              "The remote server returned an error: (405) Method Not Allowed." error message that the problem is with the autodiscovery.

              Before repairing
              Don't forget to backup before doing these steps, I am not responsible for your damages.

              Steps
              The following steps needed:

              1.
              Open an Exchange management console
              2.
              Remove-AutodiscoverVirtualDirectory -Identity "yourservername\Autodiscover (Default Web Site)"
              3.
              New-AutodiscoverVirtualDirectory
              4.
              Try to access https://yourdomain/Autodiscover/Autodiscover.xml
              You should get 404 message, this means you need to start ASP.NET
              5.
              Open the "Internet Information Services (IIS) Manager" under "Administrative Tools".
              6.
              Navigate to the "Web Service Extensions"
              7.
              Select "ASP.NET *"" and click "Allow".
              8.
              Try to access https://yourdomain/Autodiscover/Autodiscover.xml
              You should get an XML file.
              9.
              Now try the Outlook with Out-of-Office. It should work.


              System Description
              Successfully solved on:

              * Windows 2003 Standard
              * Exchange 2007

              -
              Xel
              Last edited by xelemorf; 15th November 2010, 11:23.

              Comment

              Working...
              X