Announcement

Collapse
No announcement yet.

Here's a Interesting one about Out of Office

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Here's a Interesting one about Out of Office

    Hey,

    So here's the basics:

    Server 2008 x64
    Exchange 2007
    Outlook 2007

    Remote Domain : Default "*" configured for "Allow External Out of office...ect"

    SAN Certificate that's working correctly with all the aliases that are needed and correctly installed.

    Can connect to Outlook anywhere without problems everything resolves that needs to resolve. All tests pass 100% in EMS.
    No certificate errors that I can find, No event logs that state any warnings.


    Problem:

    While Out of office is switched on and I send a email from any external mail boxes there is no auto reply being generated.

    I receive no errors I can work with to get any sort of basic start point. From a configuration point of view everything should work properly.

    Configuring out of office via the web interface has the same effect, it's like the feature is there and working properly, but at the same time is just not.

    Anyone have any Idea where I can start to look to get the Out of Office assistant working properly?

    Regards
    TheITNoob
    Last edited by TheITNoob; 31st May 2010, 11:13.

  • #2
    Re: Here's a Interesting one about Out of Office

    I would start by looking at message tracking to see whether the OOTO message is being generated. I have seen more than once that the message has been generated but blocked at some point further on.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Here's a Interesting one about Out of Office

      Thanks,

      Seems that Exchange is not generating a message at all.

      Just find it strange that there is no errors or events anywhere that can help me pin it down. I'll look a the configuration again, maybe I made a mistake there.

      Regards,

      Comment


      • #4
        Re: Here's a Interesting one about Out of Office

        Ok,

        So after another good look at everything, I'm noticing that even though I'm turning OOF on (either Outlook Client of Web Client), the exchange server is not picking up that it's been turned on. Let me explain.

        Using a tool called "MFCMapi" you can look at the current configuration of a mailbox with a bit more depth.

        There is a line reading " PR_OOF_STATE " in the list that tells you whether OOF is turned on for the mail box or not using a "True/False" indicator.

        This remains at "False" whether I turn the OOF on or not.

        Anyone around that can give me a little more insight into why this would remain "false" when it has been turned on?

        Comment


        • #5
          Re: Here's a Interesting one about Out of Office

          If you set it through OWA, what happens then?

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: Here's a Interesting one about Out of Office

            Same thing happens, PR_OOF_STATE remains false for the mailbox.

            I've read a little more on the subject and it seems that this setting should be changed on the mailbox store itself, though you are using the outlook client it doesn't have an effect at all on the mailbox store. This I gathered from reading about people trying to enable OOF using VBscripts.

            So basically the reason, I gather, why the Outlook web client does indeed work 99% of the time is because that session is hosted directly on the exchange server with no "Client" software that was installed else where.

            This brings me back to my problem. Even though I'm setting it through the Outlook Web interface it still does not enable the OOF on the Mailbox. So I just happen to fall into the 1% of unlucky people.

            I would really like to get this sorted out, Can you just confirm that there is not anything else that I need to set in order for this to work? Below is the Setting i changed.

            I've configured it from the Exchange Management Console and I am not aware of any command that needs to be run from the Exchange Management Shell.

            Here's the setting that I have done:

            Organization Configuration -> Hub Transport -> Remote Domains -> Default "*" -> Properties on "Default *" -> Allow External Out-of-Office Messages Only.

            Other than this one setting I have not found anything else pointing to OOF Configuration.

            Comment


            • #7
              Re: Here's a Interesting one about Out of Office

              Out of Office is a core feature to Exchange. You don't have to do anything to enable it or disable it. It will work out of the box. The only controls you have over it are the setting that you have found.

              However it doesn't matter how those are set, the users can still set the OOTO message and it will still be generated by Exchange. Only then do those settings take effect.

              I also believe that you can disable access to OOTO in group policy, but of course that will not affect OWA.

              In most cases this is resolved by setting it through OWA, or at least toggling the state. The usual cause is where mixed client versions are used. If you are using a Blackberry, then this is considered in this content to be an older client as it is using the Outlook 2003/Exchange 2003 method to set the OOTO message - where the concept of dual OOTO messages doesn't exist.
              It is the dual messages that are the root cause of the problem.

              Simon.
              --
              Simon Butler
              Exchange MVP

              Blog: http://blog.sembee.co.uk/
              More Exchange Content: http://exchange.sembee.info/
              Exchange Resources List: http://exbpa.com/
              In the UK? Hire me: http://www.sembee.co.uk/

              Sembee is a registered trademark, used here with permission.

              Comment


              • #8
                Re: Here's a Interesting one about Out of Office

                Makes sense.

                Our setup is, Exchange 2007 on Server 2008 and the only clients we use to connect to the Exchange server (Using Outlook Anywhere or Local) is Outlook 2007. We don't use any other client software.

                I'm starting to lean towards the policies as the root of the problem. I will look through there later today to see if I can find anything wrong.

                Please yell at me if I'm not understanding it correctly, learning curve here for me.

                Comment


                • #9
                  Re: Here's a Interesting one about Out of Office

                  Brilliant =)

                  Thx for all the help - Managed to get it working using GPO's.

                  +Rep

                  Comment

                  Working...
                  X