Announcement

Collapse
No announcement yet.

Auomatic Replies (Out of Office) not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Auomatic Replies (Out of Office) not working

    I'm relatively new to being an admin for Exchange 2007. Here's a little history on our exchange server. We had an Exchange 2003 server that started crashing so we needed a replacement. We purchased a new server with 2007 and migrated our 2003 to the new exchange. That went well without any noticable problems. However, the exchange 2003 server finally died on us before I was unable to uninstall exchange off of it. Now to the problem at hand... In Outlook 2007 and 2010 beta clients, users are unable to set their Out of Office in Outlook. Users who are still using Outlook 2003 are able to set their Out of Office. Everyone can set the Out of Office using Outlook Web Access. I've done some research and everything I've found says it's a problem with our autodiscover settings. First thing I did was add a few names to our Standard UCC SSL cert from GoDaddy. I then created an A record in our DNS for autodiscover, pointing it to our exchange server. But I'm still having problems finishing this and getting it fixed. I'm not sure what my next step should be and would appreciate some assistance.

    Domain name - laserworks.net
    Certificate Common Name - exchsrvr.laserworks.net
    Newly Added Alternative Names - autodiscover.verity-group.com, exchsrvr, and exchsrvr.verity-group.com



    When I run test-outlookwebservices | format-list, I get the results below.

    Id : 1003
    Type : Information
    Message : About to test AutoDiscover with the e-mail address [email protected]
    ty-group.com.

    Id : 1007
    Type : Information
    Message : Testing server exchsrvr.laserworks.net with the published name https:
    //exchsrvr.laserworks.net/ews/eschange.asmx & .

    Id : 1019
    Type : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover
    URL on this object is https://exchsrvr.laserworks.net/autodiscover/a
    utodiscover.xml.

    Id : 1013
    Type : Error
    Message : When contacting https://exchsrvr.laserworks.net/autodiscover/autodisc
    over.xml received the error The remote server returned an error: (503
    ) Server Unavailable.

    Id : 1006
    Type : Error
    Message : The Autodiscover service could not be contacted.

    If someone can help me with this, it would be much appreciated. Let me know if you need any additional information. Thanks!
    Last edited by bjwood354; 15th April 2010, 22:24.

  • #2
    Re: Automatic Replies (Out of Office) not working

    Availability and autodiscover are connected. If one doesn't work then the other doesn't usually either.

    Does OWA work?

    Does the server have more than one web site? Are all of the sites running?
    This looks like it is either something wrong with the server, or the URLs do not resolve to the correct place. You should check DNS resolution is correct.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Automatic Replies (Out of Office) not working

      Originally posted by Sembee View Post
      Availability and autodiscover are connected. If one doesn't work then the other doesn't usually either.

      Does OWA work?

      Does the server have more than one web site? Are all of the sites running?
      This looks like it is either something wrong with the server, or the URLs do not resolve to the correct place. You should check DNS resolution is correct.

      Simon.
      OWA is working perfectly. There aren't any other websites on the server other than the ones for exchange. I just checked my DNS settings. We have 2 Forward Lookup Zones, and in each I have an Host (A) record for autodiscover pointing to the ip address of our exchanve server.
      Last edited by bjwood354; 16th April 2010, 14:25.

      Comment


      • #4
        Re: Auomatic Replies (Out of Office) not working

        I've done some more research on this and one person told me it may be a problem with my free/busy settings. I'm using Outlook 2010 and I checked the calendar and I'm unable to see other people's appointments in the scheduling assistant. I get an error message saying "No information. No free/busy information could be retrieved. Your server location could not be determined." It may be a problem with my free/busy, my autodiscover, something else, or all of the above.

        Comment


        • #5
          Re: Automatic Replies (Out of Office) not working

          Its all connected. Free/busy and Out of the Office are both connected to the availability service, which runs through autodiscover. In most cases if one fails then they all fail, which is what has happened here.

          You are getting a 503 error, which means the problem is with the server. Something about the web site isn't working correctly.
          Is the server fully patched? Exchange 2007 SP2?

          You could try removing and recreating the autodiscover virtual directories using Exchange Management Shell - instructions are on Technet.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: Automatic Replies (Out of Office) not working

            Originally posted by Sembee View Post
            Its all connected. Free/busy and Out of the Office are both connected to the availability service, which runs through autodiscover. In most cases if one fails then they all fail, which is what has happened here.

            You are getting a 503 error, which means the problem is with the server. Something about the web site isn't working correctly.
            Is the server fully patched? Exchange 2007 SP2?

            You could try removing and recreating the autodiscover virtual directories using Exchange Management Shell - instructions are on Technet.

            Simon.
            The server does have SP2 installed. However, there is an Update Rollup 10 for Exchange Server 2007 SP1 that I have not installed. But I do not think it's related to the problems I'm having. I will try removing and recreating the autodiscover virtual directories today and see if that helps. Thanks!

            Comment


            • #7
              Re: Auomatic Replies (Out of Office) not working

              I think I may have figured out what the culprit is. It definitely seems like it's a DNS issue. I have 2 forward lookup zones. One is laserworks.net, and the other is verity-group.com My certificate is using autodiscover.verity-group.com. When I do a nslookup on my exchange server, I get an error saying "***exchsrvr.laserworks.net can't find autodiscover: Non-existent domain" However, when I create a Host (A) record in the laserworks.net forward lookup zone, it finds it.

              So the certificate is using autodiscover.verity-group.com, but DNS doesn't see the Host (A) record for autodiscover in the verity-group.com forward lookup zone. It's there, I've double checked it. I'm not really sure how to fix this issue. It would be great if I can get DNS to look in the verity-group.com FLZ for that Host (A) record. But how do I do that? If I can't, then I need to change my certificate to autodiscover.laserworks.net, which I don't want to have to do if I can get around it. I hope someone can help me with this because I'm a bit of a noob with DNS and Exchsrvr and I'm pretty much learning as I'm going.

              Comment


              • #8
                Re: Automatic Replies (Out of Office) not working

                The way that Autodiscover works is by Outlook taking the domain after the @ sign and then attaching the autodiscover in front of it.

                Therefore you should ensure that autodiscover.example.com is in the DNS for each domain that the server is hosting email addresses for, and also in the SSL certificate.

                However for clients on the domain, the autodiscover URL isn't used - it uses the URL that is delivered to it from the domain.

                The URLs are configured in PowerShell - you can see in get-clientaccessserver. Ensure the autodiscverURI value resolves correctly.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment

                Working...
                X