Announcement

Collapse
No announcement yet.

Autoconfigure stops working.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autoconfigure stops working.

    I have just completed my first SBS2008 install. Clients are all internal. Users are rightly complaining about a username password dialog box always poping up when they have outlook open. I found that when I did a "Autoconfigure email test" that I was getting no replyies. Further investigationr and google searches led me to the Client access direcory which had lost its privaleges for authenticated users. I reapplied read execute, list and read permissions to
    C:\Program Files\Microsoft\Exchange Server\ClientAccess foldera and subs and issued a iisreset and all seemed OK. For a short period of time sometimes as small as 10 mins. If I issue IISreset again all is good. Permissions on the folders are holding.
    When it stops working I get back from the test a simple "autoconfiguration was unable to determine your settings"

    When it is working the XML log file looks like this

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchang...nseschema/2006">
    <Response xmlns="http://schemas.microsoft.com/exchang...seschema/2006a">
    <User>
    <DisplayName>Downs MicroSystems</DisplayName>
    <LegacyDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=USERNAME</LegacyDN>
    <DeploymentId>7f07632d-9cd2-41f8-be67-055bf3a10002</DeploymentId>
    </User>
    <Account>
    <AccountType>email</AccountType>
    <Action>settings</Action>
    <Protocol>
    <Type>EXCH</Type>
    <Server>sbs.domain.local</Server>
    <ServerDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=sbs</ServerDN>
    <ServerVersion>720180F0</ServerVersion>
    <MdbDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=sbs/cn=Microsoft Private MDB</MdbDN>
    <PublicFolderServer>sbs.domain.local</PublicFolderServer>
    <AD>sbs.domain.local</AD>
    <ASUrl>https://remote.domain.net.au/EWS/Exchange.asmx</ASUrl>
    <EwsUrl>https://remote.domain.net.au/EWS/Exchange.asmx</EwsUrl>
    <OOFUrl>https://remote.domain.net.au/EWS/Exchange.asmx</OOFUrl>
    <UMUrl>https://remote.domain.net.au/UnifiedMessaging/Service.asmx</UMUrl>
    <OABUrl>https://remote.domain.net.au/OAB/49eb9360-a95e-495d-b0be-86f479e209df/</OABUrl>
    </Protocol>
    <Protocol>
    <Type>EXPR</Type>
    <Server>remote.domain.net.au</Server>
    <SSL>On</SSL>
    <AuthPackage>Basic</AuthPackage>
    <ASUrl>https://remote.domain.net.au/EWS/Exchange.asmx</ASUrl>
    <EwsUrl>https://remote.domain.net.au/EWS/Exchange.asmx</EwsUrl>
    <OOFUrl>https://remote.domain.net.au/EWS/Exchange.asmx</OOFUrl>
    <UMUrl>https://remote.domain.net.au/UnifiedMessaging/Service.asmx</UMUrl>
    <OABUrl>https://remote.domain.net.au/OAB/49eb9360-a95e-495d-b0be-86f479e209df/</OABUrl>
    </Protocol>
    <Protocol>
    <Type>WEB</Type>
    <External>
    <OWAUrl AuthenticationMethod="Fba">https://remote.domain.net.au/owa/</OWAUrl>
    <Protocol>
    <Type>EXPR</Type>
    <ASUrl>https://remote.domain.net.au/EWS/Exchange.asmx</ASUrl>
    </Protocol>
    </External>
    <Internal>
    <OWAUrl AuthenticationMethod="Basic, Fba">https://remote.domain.net.au/owa/</OWAUrl>
    <Protocol>
    <Type>EXCH</Type>
    <ASUrl>https://remote.domain.net.au/EWS/Exchange.asmx</ASUrl>
    </Protocol>
    </Internal>
    </Protocol>
    </Account>
    </Response>
    </Autodiscover>

    Any ideas where I should be looking?

    Cheers

  • #2
    Re: Autoconfigure stops working.

    As this is SBS you shouldn't need to do anything.
    As long as SBS was configured using the wizards everything should work correctly.

    Was the server setup using the wizards?
    Has the machine been fully patched? SBS 2008 can take Exchange 2007 SP2 now, but you need to use the SBS installer tool.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Autoconfigure stops working.

      Yes I used the wizards and as we all know SBS should just work and Windows should never crash.

      As well as the permission issue on the Exchange Server\ClientAccess folders I have finally found a work around.

      One of my compatriots found the following post not sure where
      "I appear to have solved this problem on my SBS2008 server. In IIS go to SBS web applications (in Windows 2008 I think the following are just under the Default Web Site) - Autodiscover and open Authentication . Right click on Windows Authentication and choose Advanced Settings... . Make sure "Enable Kernel-mode authentication" is selected (It wasn't on my SBS server) and click on OK. Do the same for the RPC, EWS and OAB virtual directories."

      This seems to have stopped the pop up boxes but the email test does not work. At this stage this will do for this job but if anyone else finds a similar situation please let me know and post your findings.
      Cheers and thanks everyone.

      Comment


      • #4
        Re: Autoconfigure stops working.

        I didn't say it should just work and that Windows doesn't crash - what I said was that manual modifications shouldn't be required.

        SBS makes changes to the way that IIS works and if you attempt to change things manually then it breaks some of SBS.
        Running the Fix my Network wizard should correct many things. If you haven't already I would also suggest running the SBS Best Practises Analyser against the system, which will also flag where changes have been made that upset SBS operation.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Autoconfigure stops working.

          Hi Mackers,

          We have a similar issue with an SBS 2008 box where the autodiscover stops working but is fixed with iisreset. Did you ever find a resolution.

          Regards,


          Keith.

          Comment

          Working...
          X