No announcement yet.

Outlook Anywhere/RPC over HTTP quits working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Outlook Anywhere/RPC over HTTP quits working

    I am having trouble keeping RPC over HTTP working on my Exchange server. Here are the specifics:

    Exchange 2007 Version 8.2(build 176.2)
    1 CAS/HUB server and 1 Mailbox server
    Windows 2008 Ent SP 2 (64bit)

    My test client is on Windows 7
    Outlook 2007 w/ SP2

    Some background info (just incase it's useful)
    We are migrating from one domain to another. The Exchange server we are having issues with is on the new domain. We have a few accounts migrated to the new domain and we are in the process of migrating some more.

    I am trying to get Outlook Anywhere to work on the new Exchange server. Wednesday I got it to work but only with basic authentication. Thursday it would not work at all. I used the site to troubleshoot and came back with this errror: Missing EXPR Provider section in AutoDiscover Response. Outlook Anywhere may not be enabled

    I checked in the Exchange management to ensure that Outlook Anywhere was enabled, and it was. I tried disabling, waiting, then re-enabling. No luck.

    I ran the "Test Email Autoconfiguration" from the Outlook client and it returned some strange results:

    Protocol: Exchange RPC
    Server: mailboxserver.domain.internal
    Login Name: tracie.test-acct
    Availability Service URL: https//CAS.domain.internal/EWS/Exchange.asmx
    OOF URL: https//CAS.domain.internal/EWS/Exchange.asmx
    OAB URL: https//CAS.domain.internal/OAB/a-string-of-numbers-and-letters/
    Unified Message Service URL: https//CAS.domain.internal/UnifiedMessaging/Service.asmx
    Authentication Package: Unspecified

    That's it -- no HTTP info.

    After a few hours of searching and checking settings, I finally came across a post that suggested re-installing the RPC over HTTP proxy - the problem was a little different, but I decided to try it anyway. I disabled Outlook Anywhere, removed RPC over HTTP proxy, rebooted, reinstalled RPC over HTTP proxy, then renabled Outlook Anywhere. Also had to do an iisreset as OWA never came back up properly on the reboot. After a few minutes everything started working. Even my Outlook client connected from outside of our network - no VPN - with NTLM - no prompting for passwords! Yay - everything works!

    Today I come in and Outlook anywhere is not working again. I'm getting the exact same errors as before. I found in event viewer this error related to RPC:
    Source: MSExchange RPC over HTTP Autoconfig
    Event ID: 3001
    The Outlook Anywhere feature is disabled. The ValidPorts registry setting has been modified to reflect this state.

    This event is listed 3 times in the last 4 days. Outlook Anywhere is enabled according to the Exchange management console.

    I really can't reinstall RPC over HTTP proxy every day ...
    What else can I check? No one has made any configuration changes (at least no one will admit to them) on the server.

  • #2
    Re: Outlook Anywhere/RPC over HTTP quits working

    If autodiscover isn't handing out the information, then it is disabled.
    You can verify that by running

    get-outlookanywhere | fl

    Have you run the Exchange best practises tool from the toolbox?

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.


    • #3
      Re: Outlook Anywhere/RPC over HTTP quits working

      1. Uninstall RPC components & reinstall it again.

      2. Configure the valid ports key properly:
      Configure valid port key:
      - HKLM\Software\Microsoft\RPC\RPCProxy
      -- Type: REG_MULTI_SZ
      -- Name: ValidPorts
      -- Value:
      MailboxServer_Netbios:6001-6002;MailboxServer_FQDN:6001-6002; MailboxServer_Netbios:6004;MailboxServer_FQDN:6004 ;

      The value should be entered for each Exchange mailbox server using the above format.

      3. Check for this key on a GLobal Catalog server (if exchange is a GC then also put the key if its not there)

      - HKLM\System\CurrentControlSet\Services\NTDS\Parame ters
      -- Type: REG_MULTI_SZ
      -- Name: NSPI Interface protocol sequences
      -- Value: ncacn_http:6004

      Please let us know what happens after trying the above.

      - Also disable IPV6 as it causes issue for Outlook Anywhere :

      Technical Director
      Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified


      • #4
        Re: Outlook Anywhere/RPC over HTTP quits working

        Sorry it's taken a while to respond to this ... had some other fires to take care of.

        running "get-outlookanywhere | fl" returned no results.
        The Exchange best practices tool showed me an OAB problem on one of the mailstores, which I fixed -- but there was nothing else.

        I followed the instructions from Jedi001 ...
        After reinstalling RPC components, Outlook Anywhere began working again. I made the reg changes for valid ports and on the GC servers.

        get-outlookanywhere | fl

        [PS] C:\Windows\System32>get-outlookanywhere | fl

        ServerName : BDVEXCH1
        SSLOffloading : False
        ExternalHostname :
        ClientAuthenticationMethod : Ntlm
        IISAuthenticationMethods : {Ntlm}
        MetabasePath : IIS://BDVEXCH1.daystartv.internal/W3SVC/1/ROOT/Rpc
        Path : C:\Windows\System32\RpcProxy
        Server : BDVEXCH1
        AdminDisplayName :
        ExchangeVersion : 0.1 (8.0.535.0)
        Name : Rpc (Default Web Site)
        DistinguishedName : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=
        BDVEXCH1,CN=Servers,CN=Exchange Administrative Gro
        up (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=E
        xchange,CN=Microsoft Exchange,CN=Services,CN=Confi
        Identity : BDVEXCH1\Rpc (Default Web Site)
        Guid : d7f79eee-38be-4fcb-be10-95f7e386b4eb
        ObjectCategory : root.internal/Configuration/Schema/ms-Exch-Rpc-Htt
        ObjectClass : {top, msExchVirtualDirectory, msExchRpcHttpVirtual
        WhenChanged : 1/15/2010 11:30:00 AM
        WhenCreated : 1/15/2010 11:30:00 AM
        OriginatingServer : RootDC1.root.internal
        IsValid : True

        Followed the directions to disable IPv6 and rebooted.

        Now Outlook anywhere doesnt work again.
        get-outlookanywhere | fl returns no results
        The valid keys entry I edited before is now empty.

        I'm back where I started.

        Thanks for your help so far!


        • #5
          Re: Outlook Anywhere/RPC over HTTP quits working

          Could you please repeat the same steps however this time:

          Remove the RPC & RPCWITHCERT virtual directories from IIS.

          And then reinstall the RPC component which should put the virtual directories back in IIS 7.

          Then setup the registry keys n all, and let us know.

          Technical Director

          Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified


          • #6
            Re: Outlook Anywhere/RPC over HTTP quits working

            Ok, went through these instructions again including removing the RPC & RPCWITHCERT virtual directores ....

            After verifying that the Outlook client could connect using Outlook Anywhere, I rebooted the CAS server again and this time the client was able to reconnect when the exchange server came back up.

            On a side note: we noticed yesterday that AD replication wasn't working correctly on one of the DCs (the one listed in the output from the get-outlookanywhere command -- OriginatingServer : RootDC1.root.internal) and we were able to get that working correctly today. So, I'm not sure if that was contributing to the problem as well.

            I will monitor over the next couple of days and post back.



            • #7
              Re: Outlook Anywhere/RPC over HTTP quits working

              Everything is still working. I think the problem is fixed.

              Thanks for your help!