Announcement

Collapse
No announcement yet.

Cant Receive Emails with Exchange 2010

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant Receive Emails with Exchange 2010

    Hello All,

    I have Exchange 2010 running on Windows 2008 R2 Ent server and cannot receive emails externally, however, I can send emails externally and internally.

    The following is the configuration on the Server configuration Hub transport.

    Hub transport connects directly to the Internet, so external SMTP gateway is used.

    Hub transport:

    2 send connectors enabled, client and default with anti-spam enabled with default settings.

    Default Send Connector:

    Specify the FQDN this connector will provide = serv01.domain.com
    Network Local = All IPv6 and IPv4 with port 25
    Network receive mail from remote servers = 0.0.0.0 255.255.255.255
    Authentication = TLS only, enable Domain security unchecked
    Permission groups = All checked except partners

    Internal DNS lookups uses the network card and External DNS lookups uses 2 external DNS IP addresses.

    MX and A records are alread setup with my ISP and is working as previously i had Windows 2003 R2 and Echange 2003 running.

    Any help would be appreciated as I dont know where else to check.

    Brando

  • #2
    Re: Cant Receive Emails with Exchange 2010

    It is receive connectors you should be concerned with here.

    Exchange Management console --> Server config --> Hub --> Receive connectors.

    If you are using port forwarding from a router to your server, check that you have this forwarding to your new server.

    From outside network on a PC run the following from a command prompt:

    nslookup -q=mx example.com

    where example.com is your domain. Take a note of the MX record FQDN. ie mail.example.com

    Now type:

    telnet mail.example.com 25

    where mail.example.com is the MX record.

    Do you get a gretting or a connect failed?

    If connect failed, repeat the exercise from the server directly. You will have to enable telnet on the server to do this.


    Shaun

    Comment


    • #3
      Re: Cant Receive Emails with Exchange 2010

      Just uncheck TLS, this would set Authentication to nothing, but I would not do this on the default receive connector instead I would create a new one named something like Internet-In.

      For Authentication don't check anything for Permission Groups just check Anonymous users, this should do the trick.

      Comment


      • #4
        Re: Cant Receive Emails with Exchange 2010

        You do not need to untick TLS, this is there to allow servers to use TLS if available. It will not interfere with non-TLS anonymous connections.

        If you do not need POP\SMTP or IMAP\SMTP connections then you can remove the authentication options if you wish. It is a good security practice to do so if unneeded. However, this will also not affect anonymous connections.

        Shaun

        Comment


        • #5
          Re: Cant Receive Emails with Exchange 2010

          Shaun,

          When i tried telnet mail.example.com 25 from outside and inside the network and directly on the server, i am getting the following;

          nslookup -q=mx example.com is dislaying the expected results.


          421 4.3.2 service not available

          Brando

          Comment


          • #6
            Re: Cant Receive Emails with Exchange 2010

            This could be caused by a firewall. Are there any firewalls on the server at all?

            So you are running telnet from the server directly?

            Can you check the network tab of the receive connector and note if there are any unusual IP restrictions there. Does it allow all IP's to connect?

            Shaun

            Comment

            Working...
            X