No announcement yet.

Public Folder Hierarchy missing from management tools

  • Filter
  • Time
  • Show
Clear All
new posts

  • Public Folder Hierarchy missing from management tools


    I have an Exchange 2007 server in one location, with an Exchange 2003 server in second location - same shared AD domain, full time VPN link between.

    This setup has been running fine for about a year. Shared public folders between locations - no issues.

    Last week, we have an 'incident' & the Exchange 2007 server was powered down instantly without being correctly shutdown. It caused minor corruption to both the main EDB & the public folder EDB - both fixed quickly using eseutil /p...

    Since then, public folders look & work fine to the users, but the Public Folder Hierarchy (or tree) is missing from management tools on the Exchange 2007 server. I now have a need to add new folders & mail enable them.

    If I use PFADMIN from my desk - I can see all the folders.

    Some Internet searching says it can take 24 / 48 hours for folders to 'sync up' correctly - but it's been over a week, so I don't think that's the issue here.

    I did find one post that said to backup the public folder db, completely remove the entire public folder setup, reboot & recreate the public folders from scratch, then put your db back - but I'd like to avoid that if at all possiple...

    I would be grateful for some pointers if you know the answers...


    Paul Adams

  • #2
    Re: Public Folder Hierarchy missing from management tools

    You could try to resend the hierarchy from Exchange 2003 ESM. Then use message tracking to confirm it was sent. Depending on the number of public folders you have though, it can take a while for Exchange to sort itself out once the hierarchy has arrived.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.


    • #3
      Re: Public Folder Hierarchy missing from management tools

      It's just missing from the management tool correct ?
      Maybe reinstalling those wold help, this should not disrupt mailservices.

      Also as a temporary workaround you could start using powershell. With Exchange snapins it's actually not that hard to use.. takes a bit of practice though.
      Please give points where appropriate

      <I dont create ready scripts for you, but I'm willing to point you in the right direction>


      • #4
        Re: Public Folder Hierarchy missing from management tools

        Thanks Simon - can you give me a pointer on making this happen...

        (You are not the Simon Butler who used to work @ Itex, Jersey by any chance?)

        As for the management tools - i did read another post where installing them locally did the trick - so I tried that & it didn't work - exactly the same issue - hierarchy missing.

        There some folders there - but they are from the other Exchange 2003 server's public folders - not mine... It's odd...



        • #5
          Re: Public Folder Hierarchy missing from management tools

          Update for others with this issue.

          I tried every solution I could find - nothing seemed to cure this.

          I own 2 public folders (and sub-folders) out of about 6 in the entire Ex2003 / 2007 infrastructure. I copied my 2 folders & all contents to folders in my personal exchange account.

          Then dismounted my public folder db, backed up everything in my secondary storage group folder, then deleted everything from that folder.

          Then, using ADSI edit, I removed the public folder database from the secondary storage group FOR MY EX2007 SERVER ONLY. I also deleted the folder hierarchy folder for that server in AD.

          Then I deleted the secondary storage group using the normal management tools.

          Wait 15 mins for AD to catch up.

          Recreated the secondary storage group & the public fodler db. Copied my public folders back from my account to the public folders. All contents were in-tact, but all permissions & mail enabled settings were lost. Recreated them using PFAdmin & the managment tools.

          Within an hour - all the public fodlers from the other E2K3 server started appearing.

          Somehow - the folder hierarchy was corrupted in ad - I could not find the issue. A delete / recreate fixed it.


          Paul Adams