No announcement yet.

Emc and EMs on the Hub Server

  • Filter
  • Time
  • Show
Clear All
new posts

  • Emc and EMs on the Hub Server

    Hi Folks

    I am running exchange 2007 with hubserv and exchdbserv on 2 separate
    machines and all the support staff has EMC running on their

    Basically on the hubserv when starting the consol or shell cmdlets it
    comes will error 0x98622490; I didnít find anything on google or
    anywhere else. Clicking on any of the categories only comes with up
    error "Unexpected error (0x98622490) while executing command <'get-
    exchangeAdministrator' > or other cmdlet error

    I already rebooted still the same issue..

    Any help as always is appreciated


  • #2
    Re: Emc and EMs on the Hub Server

    If it is only happening on the physical server and you can manage the role from another machine then it is probably a corrupt Windows profile.
    Login to the server as another user with the required permissions and then see if the problem follows.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.


    • #3
      Re: Emc and EMs on the Hub Server

      have you tried re-installing powershell?

      what version of windows server are you using? 2008 you need to use the server manager tool to add/remote features.

      2003 is a manual uninstall and re-install. I would downlaod a fresh version.


      • #4
        Re: Emc and EMs on the Hub Server

        Hi Simon;
        Issue was first seen when the dept mgr logon and tried using the emc
        SO then I logged on and ran the emc - same error.
        Should try with some account with completely new profile?

        Mr Flash,
        No, I tried to go through the uninstal lfor emc - but I dont want to loose the hub server install.
        Windows 2003 64bit-

        ..any other idea before I proceed with uninstall/install of the powershell?

        Thanks Guys


        • #5
          Re: Emc and EMs on the Hub Server

          Solution from Xiu:

          Please ensure that all the exchange server has been in the same version.

          Besides,please check the value on the following registry,it should be Microsoft.Exchange.Management.PowerShell.AdminPSSn apIn
          HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1 \PowerShellSnapIns\Microsoft.Excha nge.Management.PowerShell.Admin\CustomPSSnapInType


          My hub server had the Edge snapin


          • #6
            Re: Emc and EMs on the Hub Server

            Other errors when opening the console:
            at Microsoft.Exchange.Configuration.MonadDataProvider .MonadCommand.ClosePipeline(MonadAsyncResult asyncResult)
            at Microsoft.Exchange.Configuration.MonadDataProvider .MonadCommand.EndExecute(MonadAsyncResult asyncResult)
            at Microsoft.Exchange.Configuration.MonadDataProvider .MonadCommand.Execute(WorkUnit[] workUnits)
            at Microsoft.Exchange.Management.SnapIn.Esm.MasterDat aSet.ExecuteWithWorkUnit(MonadCommand command, WorkUnitCollection workUnits)
            at Microsoft.Exchange.Management.SnapIn.Esm.MasterDat aSet.LoadServers(MonadConnection connection, String serverName, Boolean& needLoadUMServers, Boolean& isEdge, Boolean& isHubTransport, Boolean& isMailbox, Boolean& isClientAccess, WorkUnitCollection refreshWorkUnits)
            at Microsoft.Exchange.Management.SnapIn.Esm.MasterDat aSet.InternalLoad(IProgress progress, String serverName)
            at Microsoft.Exchange.Management.SnapIn.Esm.MasterDat aSet.loadWorker_DoWork(Object sender, DoWorkEventArgs e)
            at System.ComponentModel.BackgroundWorker.WorkerThrea dStart(Object argument)

            The term 'get-ClientAccessServer' is not recognized as a cmdlet, function, operable program, or script file. Verify the term and try again.
            at System.Management.Automation.CommandDiscovery.Look upCommandInfo(String commandName)
            at System.Management.Automation.CommandDiscovery.Look upCommandProcessor(String commandName, CommandOrigin commandOrigin)
            at System.Management.Automation.CommandFactory._Creat eCommand(String commandName, CommandOrigin commandOrigin)
            at System.Management.Automation.CommandFactory.Create Command(String commandName, CommandOrigin commandOrigin)
            at System.Management.Automation.Runspaces.Command.Cre ateCommandProcessor(ExecutionContext executionContext, CommandFactory commandFactory, Boolean addToHistory)
            at System.Management.Automation.Runspaces.LocalPipeli ne.CreatePipelineProcessor()
            at System.Management.Automation.Runspaces.LocalPipeli ne.InvokeHelper()
            at System.Management.Automation.Runspaces.LocalPipeli ne.InvokeThreadProc()

            [PS] o:\>get-clientaccessserver
            The term 'get-clientaccessserver' is not recognized as a cmdlet, function, oper
            able program, or script file. Verify the term and try again.
            At line:1 char:22
            + get-clientaccessserver <<<<
            I can run it anywhere else get vaild answer; but on the hub server itself I get it an invaild cmdlet.