Announcement

Collapse
No announcement yet.

Email address policy

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email address policy

    after installing and migrating to 2007 and demoting the old dc and server
    i cant create mailboxes - i get :-

    [PS] C:\Windows\System32>Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients
    The Exchange server address list service failed to respond. This could be because of an address list or email address policy configuration error.
    At line:1 char:1

    in the error logs i have

    LDAP Bind was unsuccessful on directory OLD DC for distinguished name ''. Directory returned error:[0x51] Server Down.

    any clues ?

  • #2
    Re: Email address policy

    It sounds to me like you may have some underlying AD or DNS issues there. What happens if you run Get-EmailAddressPolicy

    Any errors in the Event logs?

    Shaun

    Comment


    • #3
      Re: Email address policy

      Do you have both a DC and Global Catalog in the site this Exchange server is in. Does the site have a Mailbox, Hub and CAS server in it?

      Shaun

      Comment


      • #4
        Re: Email address policy

        [PS] C:\Windows\System32>get-emailaddresspolicy
        Name Priority RecipientFilter
        ---- -------- ---------------
        Default Policy Lowest

        results from that

        only errors are the ldap ones, ive no idea why its still pointing to the old server - adsiedit maybe ?


        the old domain had one server - it handled everything untill it crashed badly
        we have 3 servers now - DC,SQL and mail
        we managed to get the server on its feet to migrate exchange tho before dcpromo

        Log Name: Application
        Source: MSExchangeAL
        Date: 29/10/2009 13:19:14
        Event ID: 8026
        Task Category: LDAP Operations
        Level: Error
        Keywords: Classic
        User: N/A
        Computer: mailserver
        Description:
        LDAP Bind was unsuccessful on directory "oldserver" for distinguished name ''. Directory returned error:[0x51] Server Down.


        ive removed and checked the DNS records and everything looks ok there
        also removed the machine from sites and services too

        at the mo im unable to create any new mailboxes and i cant even create a new email poilcy

        Comment


        • #5
          Re: Email address policy

          I would check to see if you have any DC's that are in the Active Directory partitions that are not actually serving as DC's. Did the old DC get demoted gracefully?

          Check through this and take any action as appropriate: http://support.microsoft.com/kb/332199

          Shaun

          Comment


          • #6
            Re: Email address policy

            it demoted fine which was odd heh

            checked the link , and nothing seems relevent - theres no errors on the other servers just this email problem

            Comment


            • #7
              Re: Email address policy

              Have you set the Organization Configuration and Server Configuration to use the new domain controller? You can do this by right clicking the Organization Configuration and Server Configuration nodes in EMC and selecting "Modify Configuration domain Controller" from the context menu.

              Comment


              • #8
                Re: Email address policy

                i'm sure i did - maybe the services need a restart after ?
                I'll double check that tommorrow

                strange how the ldap is pointing to the old server tho - wheres the settings to look for when using adsiedit ?

                Comment


                • #9
                  Re: Email address policy

                  "Have you set the Organization Configuration and Server Configuration to use the new domain controller? You can do this by right clicking the Organization Configuration and Server Configuration nodes in EMC and selecting "Modify Configuration domain Controller" from the context menu."

                  i did this early on in the day

                  i also did a few more changes and nothing worked - came in this morning and rebooted - now the errors are cleared and i can now create mailboxes and lists

                  heh noone said anything about restarting the services!!

                  thanks for all the help

                  Comment

                  Working...
                  X