Announcement

Collapse
No announcement yet.

A unique Out Of Office Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • A unique Out Of Office Issue

    Error message: Your out of office settings cannot be diplayed, because the server is currently unavailable. Try again later.

    Our Environment: 3 sites, Windows 2003 Domain controller in each site, Domain functional level Windows server 2003. Client Operating systems: windows XP SP2, windows Vista Business SP1. Exchange 2007 is Installed on a Windows 2008 Server. We have a mixture of Outlook 2002 and Outlook 2007 ( were doing a gradual migration to Outlook 2007)

    Description of the problem:
    The problem is only with Outlook 2007 clients, when users try to use their Outlook client to set their out of office, they receive the message above, so at the moment were using Outlook Web Access as a work around, it works fine with OWA. Then recently I fired up my VPN connection from home and opened up Outlook, and lo and behold it works from home! I CAN ACCESS OUT OF OFFICE IN OUTLOOK 2007 USING A VPN CLIENT TO CONNECT TO THE SAME EXCHANGE SERVER!!! How bizarre!

    Mind you by the way, for those people still using the earlier versions of Outlook, its also fine.

    Ill be very grateful to anyone who can unravel the mystery that has baffled me for weeks!

  • #2
    Re: A unique Out Of Office Issue

    Hi,

    See if this helps in your case: http://support.microsoft.com/kb/958934/EN-US
    Caesar's cipher - 3

    ZKHQ BRX HYHQWXDOOB GHFLSKHU WKLV BRX ZLOO UHDOLVH LW ZDV D ZDVWH RI WLPH!

    SFX JNRS FC U6 MNGR

    Comment


    • #3
      Re: A unique Out Of Office Issue

      Thanks for your reply,

      I've already been through this link, it doesn't really apply to us. On ours, it actually works from an Outlook Client connected to the network via VPN (We use Watchguard Firebox)

      It's just Domain-joined computers that can't use Out of office from their outlook clients.

      But I will give it a go and go as far as confirming which version/combination of dotnet we have installed on our CAS.

      Comment


      • #4
        Re: A unique Out Of Office Issue

        I've checked, we don't have dotnet 3.5 SP1 installed. So it can't be that. Thanks.

        Comment


        • #5
          Re: A unique Out Of Office Issue

          It could be a problem with the Autodiscover service. This provides the location for OOF when Outlook 2007 clients connect.

          Can you check all your URL's are ok:

          http://exchangeshell.wordpress.com/2...p-pop3-oof-oab

          And also, if you right click the Outlook 2007 icon in system whilst holding down SHIFT, you can Test autoconfiguration - look for any errors reported here with autodiscovery service.

          Shaun

          Comment


          • #6
            Re: A unique Out Of Office Issue

            Thanks Shaun, I can provide good feedback on this but here's a summary:

            Since I've been able to test email autoconfiguration successfully using VPN from home, I know the out of office url, so I've typed this in my browser at work, the url is in this format https://serverfqdn/EWS/Exchange.asmx. it returns an error when I do this, but if I use the Server Netbios name, it's fine, that's from the browser.

            Now,all the urls supplied by the SCP have the serverfqdn and outlook doesn't seem to like this.

            Is there a reason why domain-joined PCs don't 'like' the serverfqdn?

            Comment


            • #7
              Re: A unique Out Of Office Issue

              What do you have in your certificate? Do you have the external URL and internal NETBIOS name etc as subject alternative names in your certificate.

              Run the powershell commands in my article and see if all the internal and external URL's are ok.

              Is port 443 properly forwarded to your server on your router? Do you get any certificate warning when using the external URL to OWA from outside?

              Shaun

              Comment


              • #8
                Re: A unique Out Of Office Issue

                Hi shaun,

                I ran 4 of the cmdlets in your article and got this out put:

                [PS] C:\Users\administrator.LGO\Desktop>Get-WebServicesVirtualDirectory | fl id* , *url*


                Identity : SERVERNAME\EWS (Default Web Site)
                InternalNLBBypassUrl : https://serverfqdn/ews/exchange.asmx
                InternalUrl : https://serverfqdn/EWS/Exchange.asmx
                ExternalUrl :




                [PS] C:\Users\administrator.LGO\Desktop>Get-owaVirtualDirectory | fl id* , *url*


                Identity : SERVERNAME\owa (Default Web Site)
                Url : {}
                InternalUrl : https://serverfqdn/owa
                ExternalUrl :

                Identity : SERVERNAME\Exchange (Default Web Site)
                Url :
                InternalUrl :
                ExternalUrl :

                Identity : SERVERNAME\Public (Default Web Site)
                Url :
                InternalUrl :
                ExternalUrl :

                Identity : SERVERNAME\Exchweb (Default Web Site)
                Url :
                InternalUrl :
                ExternalUrl :

                Identity : SERVERNAME\Exadmin (Default Web Site)
                Url :
                InternalUrl :
                ExternalUrl :



                [PS] C:\Users\administrator.LGO\Desktop>Get-ClientAccessServer | fl id* , *url*


                Identity : SERVERNAME



                [PS] C:\Users\administrator.LGO\Desktop>Get-OabvirtualDirectory | fl id* , *url*


                Identity : SERVERNAME\OAB (Default Web Site)
                InternalUrl : http://serverfqdn/OAB
                ExternalUrl :

                Comment


                • #9
                  Re: A unique Out Of Office Issue

                  It is the serverfqdn that is the important bit. You will have two, one internal FQDN and one External FQDN, do these look accurate?

                  Shaun

                  Comment


                  • #10
                    Re: A unique Out Of Office Issue

                    they both are, I've checked it thouroughly.

                    Comment


                    • #11
                      Re: A unique Out Of Office Issue

                      Have a read through this post and action anything as necessary:

                      http://www.proexchange.be/blogs/exch...t-s-wrong.aspx

                      Shaun

                      Comment


                      • #12
                        Re: A unique Out Of Office Issue

                        I've also issued a Get-ExchangeCertificate command and got this:

                        Get-ExchangeCertificate | fl


                        AccessRules : {System.Security.AccessControl.CryptoKeyAccessRule , System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
                        CertificateDomains : {servername, serverfqdn}
                        HasPrivateKey : True
                        IsSelfSigned : True
                        Issuer : CN=servername
                        NotAfter : 25/03/2010 20:00:11
                        NotBefore : 25/03/2009 20:00:11
                        PublicKeySize : 2048
                        RootCAType : None
                        SerialNumber :
                        Services : IMAP, POP, IIS, SMTP
                        Status : Valid
                        Subject : CN=servername
                        Thumbprint :

                        AccessRules : {System.Security.AccessControl.CryptoKeyAccessRule , System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
                        CertificateDomains : {WMSvc-SERVERNAME}
                        HasPrivateKey : True
                        IsSelfSigned : True
                        Issuer : CN=WMSvc-SERVERNAME
                        NotAfter : 23/03/2019 12:09:18
                        NotBefore : 25/03/2009 12:09:18
                        PublicKeySize : 2048
                        RootCAType : Registry
                        SerialNumber :
                        Services : None
                        Status : Valid
                        Subject : CN=WMSvc-SERVERNAME
                        Thumbprint :

                        Comment


                        • #13
                          Re: A unique Out Of Office Issue

                          I've seen that link as well, it doesn't seem to apply in this case.

                          Comment


                          • #14
                            Re: A unique Out Of Office Issue

                            Happy to say that I've cracked this issue, it was just a matter of using the Servername in the internal service urls provided by the autodiscover service

                            i.e AutoDiscoverServiceInternalUri : https://servername/Autodiscover/Autodiscover.xml

                            instead of

                            AutoDiscoverServiceInternalUri : https://serverfqdn/Autodiscover/Autodiscover.xml


                            thanks for your time, I really do appreciate it.

                            Comment


                            • #15
                              Re: A unique Out Of Office Issue

                              Glad you got this resolved.

                              Shaun

                              Comment

                              Working...
                              X