Announcement

Collapse
No announcement yet.

LCR option gone?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • LCR option gone?

    I have Exchange 2007 and have been using LCR function to replacate to a spare drive. From time to time the LCR will fail and I have to reboot to get it working again which after the reboot it usualy works fine. I went into the LCR option on the databse to clear out the settings and create a new LCR location and the LCR option is no longe there. Nothing has change and this is a production server. Any idea what could be the problem?

    I also have a second database and the LCR option is there and it works.

  • #2
    Re: LCR option gone?

    Usually, if the LCR option in the navigation pane (for the Storage group) is not there it is because you have more than 1 database file in a storage group and therefore cannot use LCR. What happens if you try to Enable\Disable LCR for the storage group using the Shell commands?

    Enable-StorageGroupCopy <SG Identity>

    Disable-StorageGroupCopy <SG Identity>

    Shaun

    Comment


    • #3
      Re: LCR option gone?

      Originally posted by shauncroucher View Post
      Usually, if the LCR option in the navigation pane (for the Storage group) is not there it is because you have more than 1 database file in a storage group and therefore cannot use LCR. What happens if you try to Enable\Disable LCR for the storage group using the Shell commands?

      Enable-StorageGroupCopy <SG Identity>

      Disable-StorageGroupCopy <SG Identity>

      Shaun

      Haven't tried the command shell as of yet. The strange thing is, though you say you cant do LCR if there is more than one database, I have been doing it for a while now. The other databases have the option to turn on LCR and the one that is missing also did till Friday night when I was doing my network maintenance.

      Comment


      • #4
        Re: LCR option gone?

        What SP level are you using? In any case, if you have somehow managed to get LCR enabled for a Storage Group that has two databases in it, this is definitely not supported. Usually you are not given the option to enable LCR on a Storage group with more than 1 DB.

        Remember LCR is enabled for a 'Storage Group' and not a database, as it is concerned with the logs in the SG, to recreate a DB elsewhere.

        You write "From time to time the LCR will fail and I have to reboot to get it working again which after the reboot it usualy works fine" - if you were running 2 x DB's in the LCR SG, this may be why.

        If you create a new SG with a single DB, do you then have the LCR option (at the SG level).

        Shaun

        Comment


        • #5
          Re: LCR option gone?

          Originally posted by shauncroucher View Post
          What SP level are you using? In any case, if you have somehow managed to get LCR enabled for a Storage Group that has two databases in it, this is definitely not supported. Usually you are not given the option to enable LCR on a Storage group with more than 1 DB.

          Remember LCR is enabled for a 'Storage Group' and not a database, as it is concerned with the logs in the SG, to recreate a DB elsewhere.

          You write "From time to time the LCR will fail and I have to reboot to get it working again which after the reboot it usualy works fine" - if you were running 2 x DB's in the LCR SG, this may be why.

          If you create a new SG with a single DB, do you then have the LCR option (at the SG level).

          Shaun
          I put that wrong so my bad. I have just one storage group for each data store so I have 4 groups.
          Here is how I have my groups laid out each has just one data store in it

          ArchiveSG01
          CorporateSG
          FieldSG
          PublicFoldersSG

          The COrporate store no longer allows me to enable LCR. FOr got to add we are running SP2 on Exchange.

          Comment


          • #6
            Re: LCR option gone?

            Ah, ok that makes more sense. I was wondering how you could have managed to have it running with 2 DB's in a SG.

            Anyhow, when you select the SG, do you get any options in the Action Pane, to create new, or change settings on LCR?

            If you run Get-StorageGroupCopyStatus "CorporateSG" | fl

            What does this return?

            Shaun

            Comment


            • #7
              Re: LCR option gone?

              Well I got the LCR fixed. What I had to do was run the Disable-StorageGroupCopy command, after this completed the option is now there again so Ican do LCR via the GUI. Thanks for all the help.

              Comment


              • #8
                Re: LCR option gone?

                No problem,

                Shaun

                Comment

                Working...
                X