No announcement yet.

CCR Copy Failed

  • Filter
  • Time
  • Show
Clear All
new posts

  • CCR Copy Failed


    I was hoping someone could give me a hand. I'm not that familiar with Exchange 2007.
    Currently running Exchange 2007 Sp1 on Windows Server 2003 R2 Sp 2.
    I have two nodes which are setup with Continous Cluster Replication environment for teh storage groups.
    We were running out of space on F: drive on the passive node due to transaction logs form teh Public Folders willing up. Circular logging is not enabled and this Public Folder database has never been backed up.
    One of my colleagues has moved the transaction logs to another disk which has now provided some free space on F: drive. The Public Folder database resides on drive E: (Has plenty of space) and logs nare now on I: drive.
    The volume are babelled correctly on both nodes and all storage groups are mounted.
    The problem now is that When looking into Server Configuration-Mailbox and looking at the Copy status it shows 'Failed' for the public Folder database.
    The public folder looks to be accessible from Outlook so they appear to be working but I doubt it will when teh node fails over to the other node. All other storage groups are fine.
    When looking at teh Cluster Continous Replication tab it shows that seeding: false and Copy Status: failed with message "The Microsoft Exchange Replication Service encountered an error while inspecting the logs and database for NEXCHANGE\Public Folder SG on startup. The specific error code returned is: Microsoft.Exchange.Cluster.Replay.FileCheckInterna lErrorException: File check failed : Log file consistency check logic experienced an internal error LatestFullBackupTime should be set.
    at Microsoft.Exchange.Cluster.Replay.FileChecker.Inte rnalCheck(Boolean condition, String formatString, Object[] messageArgs)
    at Microsoft.Exchange.Cluster.Replay.FileChecker.GetD atabaseBackupInfo(MJET_DBINFO dbinfo)
    at Microsoft.Exchange.Cluster.Replay.FileChecker.GetD atabaseBackupInfo()
    at Microsoft.Exchange.Cluster.Replay.FileChecker.RunC hecks()
    at Microsoft.Exchange.Cluster.Replay.ReplicaInstance. ConfigurationChecker(Object stateIgnored).
    I also noticed that on the I: drive on both nodes the Public Folder SG storage group is shared out on the Acticve node but not on the passive node. (Not sure if that makes any difference)
    In event viewer on the passive node I get event ID: 2070 Source: MSExchangeRepl.

    Can 'Restore Storage Group Copy' help in this case? Or maybe restarting the passive node server?

    Any assistance will be appreciated.

  • #2
    Re: CCR Copy Failed

    It's ok, I've resolved this.
    For anyone interested, when moving log files you need to make sure the network share is identical on both the passive node and active node and that the volume's are labelled the same. That wasn't only part of my problem though the other was that I needed to re-seed the storage group on the passive node via (Update Storage Group Copy wizard) for replication to occur. This can be done either via the Powershell or the Exchange Management Console.

    Checked replication and all good. Also the event id 2070 with Source: MSExchangeRepl no longer appeared.