Announcement

Collapse
No announcement yet.

Removing a Rogue server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Removing a Rogue server

    I've just completed an install of Exchange 2007 on a 64 bit version of Windows Server 2008, and i've discovered a problem;

    I had believed that this was the 1st time that someone had installed Exchange on the site, however in the EMC i get 2 servers, my new server, and another one...

    And when EMC starts up i get this error:

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    The following error(s) were reported while loading topology information:

    Get-ActiveSyncVirtualDirectory
    Failed
    Error:
    The task was not able to connect to IIS on the server 'XXXXXX.XXXXXX.XXXXXX.XXXXXXXXX.com'. Ensure that the server exists and is reachable from this computer: The RPC server is unavailable.

    Get-OabVirtualDirectory
    Failed
    Error:
    The task was not able to connect to IIS on the server 'XXXXXX.XXXXXX.XXXXXX.XXXXXXXXX.com'. Ensure that the server exists and is reachable from this computer: The RPC server is unavailable.

    Get-OWAVirtualDirectory
    Failed
    Error:
    The task was not able to connect to IIS on the server 'XXXXXX.XXXXXX.XXXXXX.XXXXXXXXX.com'. Ensure that the server exists and is reachable from this computer: The RPC server is unavailable.

    get-PublicFolderDatabase
    Completed

    Warning:
    ERROR: Could not connect to the Microsoft Exchange Information Store service on server 'XXXXXX.XXXXXX.XXXXXX.XXXXXXXXX.com. One of the following problems may be occurring: 1- The Microsoft Exchange Information Store service is not running. 2- There is no network connectivity to server 'XXXXXX.XXXXXX.XXXXXX.XXXXXXXXX.com 3- You do not have sufficient permissions to perform this command. The following permissions are required to perform this command: Exchange View-Only Administrator and local administrators group for the target server. 4- Credentials have been cached for an unpriviledged user. Try removing the entry for this server from Stored User Names and Passwords.

    --------------------------------------------------------
    OK
    --------------------------------------------------------
    However Client acces and Hub transport for the "old" server are blank, and the only entry in mailboxes is the second storage group public folder database,

    When i try to remove the 2nd storage group it says i can't because it's not empty, and i get no option to remove the public folder database, actually i get nothing but properties.....


    This has caused issues in my outlook clients, wherein everytime they start up outlook it asks for a password for the nonexistant exchange server.

    Please can someone help?

  • #2
    Re: Removing a Rogue server

    If you have traces of another server in the domain then those need to be removed. The only supported method is to use add/remove programs. That will mean building a new server with the same name, doing a recoverserver installation of Exchange, then removing it correctly using add/remove programs.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Removing a Rogue server

      I've run NTDSutil - metadata cleanup and removed all traces of the old server from active direcrtory as well.

      And will try this later on today i think!

      Thanks for the advice!
      Last edited by Deathjester; 22nd June 2009, 09:21.

      Comment

      Working...
      X