No announcement yet.

Exchange 2007 Transaction Logs and Backup

  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2007 Transaction Logs and Backup

    Here's my situation: backups (Symantec BE 12.5) of my E2K7 (on Win2K8 Std 64-bit) infostores are failing because I have a few of corrupt transaction logs. The problem is that I don't have a good copy of those 4 logs. So basically I'm looking for a little advice on what to do.

    My thoughts
    1. Delete troublesome logs and then run Full Backup or Enable Circular Logging and perform Full Backup.


    2. Create new Storage Group and Database then move all users to new Infostore.

    We're running E2K7 on ESX 3.5 so I'm able to get VM level backups and take snapshots (if needed). I'm hesitant to move everyone to a new store because of the time involved but I also want to maintain integrity of the end-user mailboxes.

    Any thoughts are welcomed and appreciated.

  • #2
    Re: Exchange 2007 Transaction Logs and Backup

    Interesting -- I am facing the same issue (but all physical servers)
    Moving users seemed the best option (maybe because I am running Enterprise and have spare storage groups

    BackupExec still seems to be a bit iffy with Server 2008
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Re: Exchange 2007 Transaction Logs and Backup

      Oddly enough, running a backup option with AOFO turned off and all of the Exchange options within the job turned off fixed my issue and cleared out the corrupt logs.

      The only weird thing was that I had run this exact same job two times previously and it didn't work either time. I guess the third time's a charm.