Announcement

Collapse
No announcement yet.

enable SourceDeliverAndRedirect (cross forest mailbox migration)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • enable SourceDeliverAndRedirect (cross forest mailbox migration)

    Hi, i am looking at a crossforest mailbox migration, and after doing a test migration i saw following option in the logfile

    SourceDeliverAndRedirect:False

    Now this really seems like the switch i want to use, because users are moved in batches and i want mail that is recieved by their old server to be redirected to the new server in the other forest. I have searched the internet and the help files, but cant seems to find how to enable the switch.
    Last edited by Killerbe; 3rd April 2009, 08:51. Reason: typo's
    [Powershell]
    Start-DayDream
    Set-Location Malibu Beach
    Get-Drink
    Lay-Back
    Start-Sleep
    ....
    Wake-Up!
    Resume-Service
    Write-Warning
    [/Powershell]

    BLOG: Therealshrimp.blogspot.com

  • #2
    Re: enable SourceDeliverAndRedirect (cross forest mailbox migration)

    Nobody?

    "-sourcedeliverandredirect $true?"
    Nope, doesn't work.
    If you check the logfile you'll even find the option TargetDeliverAndRedirect:False
    Last edited by Killerbe; 3rd April 2009, 22:09.
    [Powershell]
    Start-DayDream
    Set-Location Malibu Beach
    Get-Drink
    Lay-Back
    Start-Sleep
    ....
    Wake-Up!
    Resume-Service
    Write-Warning
    [/Powershell]

    BLOG: Therealshrimp.blogspot.com

    Comment


    • #3
      Re: enable SourceDeliverAndRedirect (cross forest mailbox migration)

      I think i figured it out today.
      I took a holiday today, and was thinking about the problem while standing in the shower... Yeah i know, i take my problems everywhere with me

      I came to the conclusion that it will not work. This because Exchnage 2007 needs a way to forward the mail too, and that information is not available.
      When you look at it, you'll see that SMTP is the only posible way in which EXchange 2007 can forward the mail. It can't use RPC, because the other mailbox is in another forest. So using RPC will eventually leed to authentication, which will surely pose a problem.

      So how is exchange going to forward the mail? Well it can't, because it cannot determine a valid SMTP address to forward too. If you want to have it forwarded, you need to configure forwarding on every single mailbox which you migrate.

      The option is enbaled by default when you doing a INTRA forest mailbox move.
      [Powershell]
      Start-DayDream
      Set-Location Malibu Beach
      Get-Drink
      Lay-Back
      Start-Sleep
      ....
      Wake-Up!
      Resume-Service
      Write-Warning
      [/Powershell]

      BLOG: Therealshrimp.blogspot.com

      Comment


      • #4
        Re: enable SourceDeliverAndRedirect (cross forest mailbox migration)

        Hi,

        How do you configure forwarding for mailboxes in this case? I would love to know if you tell me.

        Thanks,
        Anupam

        Comment


        • #5
          Re: enable SourceDeliverAndRedirect (cross forest mailbox migration)

          You would configure the delivery option of the mailbox to forward incomming mail to a SMTP address for that user within the other forrest. This would offcourse require you to create a contact within current forest.

          This can be done when migrating a small group of users (the first test users), but when you start to move the majority, it is best to move them all over the week-end, configure the accepted domains in the new forest and adjust the MX records.
          In this case you will not need to enable the forwarding and the creation of contacts.
          [Powershell]
          Start-DayDream
          Set-Location Malibu Beach
          Get-Drink
          Lay-Back
          Start-Sleep
          ....
          Wake-Up!
          Resume-Service
          Write-Warning
          [/Powershell]

          BLOG: Therealshrimp.blogspot.com

          Comment

          Working...
          X