No announcement yet.

Problems with searching

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with searching

    Hi guys!

    I have this annoying problem, I hope you can help me with it...

    We use Server 2003 Standard x64 and on it there is Exchange 2007 with 30 mailboxes... EDB database has size of 17 GB which is nothing big...

    OK so this is virtual machine, It has 4GB of ram and dedicated RAID 10 pair of disks. It has 1vCPU.

    Server has 2X quad core Xenons @ 2.4 GHz...

    OK so that is server/hardware/software part... Now the problem...

    We use outlook 2007 and have own mailbox + 6 other mailboxes (shared) (look at attached image - MBX.JPG).
    All outlooks are in online mode and NOT cached mode...

    When we search in our own mailboxes all is peachy, searching is super fast, no errors of whatsoever well all is as it suppose to be...

    When we search in other mailboxes, there are problems...

    1. If outlook in cached mode, search freezes outlook (requesting data from server) and it takes about 15-30 seconds to unfreeze and display search results...

    2. If outlook in online mode, search go fast, display searched items, but user cannot open it (look at next attachment - image MBX1.jpg)... When you restart outlook it all works again and after a while same error occurs...
    BUT even without restart, searching in my own mailbox still works like a charm...

    3. If outlook in online mode, sometimes search does not complete (too much results to display I don`t know)

    Exchange shows nothing in event viewer... There seems like there is no errors at all

    OK I tried:
    - deleting full-text search catalog
    - defrag EDB database in offline mode
    - assign diffrent amout of RAM to virtual machine
    - various page-file settings
    - installed Windows desktop search 4.0 (meaningless anyways)

    Have you guys any suggestions or ideas on this one?

    Attached Files
    Last edited by gregaSLO; 10th March 2009, 14:16.

  • #2
    Re: Problems with searching

    OK another thing I will try...

    I will Create 3 different mailbox databases (for Users, System and proccesing)..

    And I will move mailboxes to new databases accordingly... So every database will have around 8 mailboxes in it...

    Maybe my database was corrupted I don`t know, will report back


    • #3
      Re: Problems with searching

      Nope that did not help either...


      • #4
        Re: Problems with searching


        Guys what do you think, can this be problem on CLIENT side?

        On clients there are no errors and event log shows nothing...


        • #5
          Re: Problems with searching

          You can't have a dedicated RAID 10 "pair" of disks, that would be a RAID 1.

          If this server is running Exchange then where is the DC, is that a separate box? Are all servers up to date? Exchange and server OS patches?

          Outlook up to date?
          Any errors anywhere?

          What does the performance look like, cpu/disk etc?

          Does the VM host do anything else?

          Please read this before you post:

          Quis custodiet ipsos custodes?


          • #6
            Re: Problems with searching


            I have 8 disks on esx server... So that makes 4 raid 1 arrays...

            On first array is esx and WSUS... On second is DC on third is Exchange on fourth there are 3 other machines...

            So DC and exchange have disks just for them...

            All servers and clients are up to date, all SPs and patches applied...

            CPU and disk performance are low (this is enviroment of 10 clients)...

            But 3 mailboxes which are shared amongst users are 2GB in size... But that error occurs on every mailbox but not on user mailbox... Only on shared ones...

            There is no errors on client or errors on server itself...

            I tell you, this is most weird problem I had ever


            • #7
              Re: Problems with searching

              OK just for record I paste here event log...

              Error is with activesync heartbeat (firewall) and transport role error which is complaining about TLS certificate...
              I do not think that its important...
              Attached Files


              • #8
                Re: Problems with searching

                I forgot to mention...

                Search catalogs are builded (MSExchange search)...

                And it all works superb fast just this annoying error occurs


                • #9
                  Re: Problems with searching

                  Thanks guys but I just setted up new server, same thing occurs... This is probably by design and we will have to wait for MS to fix this...