Announcement

Collapse
No announcement yet.

problems with oab between exch 2003 & 2007

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • problems with oab between exch 2003 & 2007

    We use public folders extensively and have around 200 setup on a clustered exchange 2003 server.
    I have setup a new virtual exchange 2007 machine with SP1 handling all roles except edge transport (will do that when i disable the old server)
    the problem I have is that new users added to the Active directory server (Win2003) do not appear in outlook 2007's cached directory. they do appear in the owa address book.
    I have replication set up (i think)
    I just dont know where to start diagnosing this one.
    Help

    David Few

  • #2
    Re: problems with oab between exch 2003 & 2007

    If they appear in OWA, then it is the OAB at fault.
    What distribution method did you set in Exchange 2007 for the OAB?
    Have you added the new server to the list of OAB system folder replicas, including all the sub folders?

    -M
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: problems with oab between exch 2003 & 2007

      You are a hero for answering Simon.
      I am not sure just what you mean re "distribution method did you set in Exchange 2007 for the OAB"
      I go back to exchange 5 but this one seems vastly different.
      i have added this server using public folder management console, as a replicant in the list of OAB system folders
      however it wont allow adding it to the OAB root folder - it flags an error as in:-
      --------------------------------------------------------
      Microsoft Exchange Error
      --------------------------------------------------------
      The following error(s) occurred while saving changes:

      set-publicfolder
      Failed
      Error:
      Cannot save the object '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK'. Please make sure that you specified the correct Identity and that you have the necessary permissions to save it.

      MapiExceptionNotFound: Unable to set properties on object. (hr=0x8004010f, ec=-2147221233)
      Diagnostic context:
      Lid: 18969 EcDoRpcExt2 called [length=437]
      Lid: 27161 EcDoRpcExt2 returned [ec=0x0][length=580][latency=15]
      Lid: 23226 --- ROP Parse Start ---
      Lid: 27962 ROP: ropSetProps [10]
      Lid: 17082 ROP Error: 0x8004010F
      Lid: 30561
      Lid: 21921 StoreEc: 0x8004010F
      Lid: 27962 ROP: ropExtendedError [250]
      Lid: 1494 ---- Remote Context Beg ----
      Lid: 1238 Remote Context Overflow
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x668F0040
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x678A0102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x67870102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x678A0102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x668F0040
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x3D210102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x678A0102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x67870102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x678A0102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x678A0102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x67870102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x678A0102
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x668F0040
      Lid: 21970 StoreEc: 0x8004010F PropTag: 0x678D0102
      Lid: 3362 StoreEc: 0x8004010F
      Lid: 9206 StoreEc: 0x8004010F
      Lid: 4559 StoreEc: 0x8004010F
      Lid: 1750 ---- Remote Context End ----
      Lid: 26849
      Lid: 21817 ROP Failure: 0x8004010F
      Lid: 25761
      Lid: 1940 StoreEc: 0x8004010F
      Lid: 25297
      Lid: 21201 StoreEc: 0x8004010F




      --------------------------------------------------------
      OK
      --------------------------------------------------------
      however that sort of seems right.....

      thanks for your help.

      David Few

      Comment


      • #4
        Re: problems with oab between exch 2003 & 2007

        I don't think you can set the root with a replica.
        You can set the sub folders, which should build the hierarchy.

        In Exchange 2007 the OAB can be distributed in two ways - web and public folders.
        It is set in the management console, Org Config, Mailbox, OAB.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment

        Working...
        X