Announcement

Collapse
No announcement yet.

Autodiscovery problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autodiscovery problem

    Hi,

    I have the following problem.

    When i want to use the Out Of Office Assistant it says that the server is unavailable.

    This happens when is use the registered SSL certificate.

    When i turn back to the self signed certificate it works however is get a message stating that the name was not correct with the certificate.

    Is it that when i use the external certificate that the server tries to connect by the outer interface of the firewall (Hardware)?

    That won't work beacuse almost all firewalls wil prevent this from happening.

  • #2
    Re: Autodiscovery problem

    Also when i right click on the Outlook 2007 icon in the tray and choose automatic e-mail configuration test it comes back with the error message Autodiscovery was unable to determine your settings!

    Comment


    • #3
      Re: Autodiscovery problem

      Is the certificate a single name SSL certificate or a SAN/UC certificate with all of the names in the certificate?
      Does autodiscover.domain.com resolve internally or externally?

      If Autodiscover doesn't work, then you will get problems with other parts of Exchange, such as Out of Office.

      Simon.
      --
      Simon Butler
      Exchange MVP

      Blog: http://blog.sembee.co.uk/
      More Exchange Content: http://exchange.sembee.info/
      Exchange Resources List: http://exbpa.com/
      In the UK? Hire me: http://www.sembee.co.uk/

      Sembee is a registered trademark, used here with permission.

      Comment


      • #4
        Re: Autodiscovery problem

        Yes, it's a single name SSL Certificate.

        Now the autodiscovery resolves locally due to an self generated ssl certificate (SBS 200.

        Comment


        • #5
          Re: Autodiscovery problem

          So how are you using two different certificates on the same web site?
          SBS 2008 only creates a single site by default.

          You should really switch to a SAN/UC certificate, or make the DNS changes to allow remote.domain.com to work that is outlined in the SBS configuration guide.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: Autodiscovery problem

            Aha, ok i understand now.

            Thanks for the help....

            Comment


            • #7
              Re: Autodiscovery problem

              Back again.

              Our company was a little bit shocked of the price of these certificates.

              Is there no other solution for it to accomplish this with 1 certificate only?

              I tried the following.

              I edited the host file and put there webmail.sisnl.net <internal IP Address of Server>

              Than it works....

              But this is no option as there are notebook users who use webmail on there machine.

              Comment


              • #8
                Re: Autodiscovery problem

                Originally posted by danny230681 View Post
                Back again.

                Our company was a little bit shocked of the price of these certificates.

                Check out GoDaddy.com -- a SAN certificate is about $100
                I was shocked -- at how low it was
                Tom Jones
                MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                PhD, MSc, FIAP, MIITT
                IT Trainer / Consultant
                Ossian Ltd
                Scotland

                ** Remember to give credit where credit is due and leave reputation points where appropriate **

                Comment


                • #9
                  Re: Autodiscovery problem

                  If you go to Digicert or Verisign then the SAN/UC certificates are expensive.
                  GoDaddy http://DomainsforExchange.net/ are the cheapest - $70/year from memory.

                  You really do need to switch to a commercial SSL certificate, as Exchange 2007 has been built around it.

                  Simon.
                  --
                  Simon Butler
                  Exchange MVP

                  Blog: http://blog.sembee.co.uk/
                  More Exchange Content: http://exchange.sembee.info/
                  Exchange Resources List: http://exbpa.com/
                  In the UK? Hire me: http://www.sembee.co.uk/

                  Sembee is a registered trademark, used here with permission.

                  Comment


                  • #10
                    Re: Autodiscovery problem

                    Ok, i did is another way.

                    I created a new DNS zone and put the webmail record in int with the internal ip-adres of the server.

                    Case can be closed..


                    Thanks all....

                    Comment

                    Working...
                    X