Announcement

Collapse
No announcement yet.

Exchange 2k7 Autodiscover RPC-HTTP Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2k7 Autodiscover RPC-HTTP Problem

    I put the problem lines in bold - we already had a DOMAINNAME.com which is being hosted by an online company so we went with a SAMEDOMAINNAME.netto host our internal stuff and to allow only a few users to take advantage of exchange.

    Everything here SHOULD be domainname.NET and not .COM - can someone tell me how to change the RPC-HTTP service to .NET instead of .COM

    The problem is in Outlook 2007 clients I can manually enter the RPC server address of mail.domainname.net but the autodiscover service goes behind me and changes is to mail.domainname.com then continuously prompts for the username/password. Everything else is working okay.


    Message : About to test AutoDiscover with the e-mail address [email protected].
    Id : 1007
    Type : Information
    Message : Testing server SA-EXCHANGE.DOMAINNAME.local with the published name https://SERVERNAME.DOMAINNAME.local/EWS/Exchange.asmx & https://
    mail.DOMAINNAME.net/EWS/Exchange.asmx.
    Id : 1019
    Type : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://SERVERNAME.DOMAINNAME.local/Autodiscover
    /Autodiscover.xml.
    Id : 1006
    Type : Information
    Message : The Autodiscover service was contacted at https://SERVERNAME.DOMAINNAME.local/...todiscover.xml.
    Id : 1016
    Type : Success
    Message : [EXCH]-Successfully contacted the AS service at https://SERVERNAME.DOMAINNAME.local/EWS/Exchange.asmx. The elapsed time was 967 milliseconds
    .
    Id : 1015
    Type : Success
    Message : [EXCH]-Successfully contacted the OAB service at https://SERVERNAME.DOMAINNAME.local/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.
    Id : 1014
    Type : Success
    Message : [EXCH]-Successfully contacted the UM service at https://SERVERNAME.DOMAINNAME.local/...g/Service.asmx. The elapsed time was 15 m
    illiseconds.
    Id : 1013
    Type : Error
    Message : When contacting https://mail.DOMAINNAME.net/EWS/Exchange.asmx received the error The request failed with HTTP status 401: Unauthorized.
    Id : 1016
    Type : Error
    Message : [EXPR]-Error when contacting the AS service at https://mail.DOMAINNAME.net/EWS/Exchange.asmx. The elapsed time was 15 milliseconds.
    Id : 1015
    Type : Success
    Message : [EXPR]-Successfully contacted the OAB service at https://mail.DOMAINNAME.net/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.
    Id : 1014
    Type : Success
    Message : [EXPR]-Successfully contacted the UM service at https://mail.DOMAINNAME.net/UnifiedM...g/Service.asmx. The elapsed time was 187 milliseco
    nds.
    Id : 1013
    Type : Error
    Message : When contacting
    https://mail.DOMAINNAME.com/Rpc received the error Unable to connect to the remote server
    Id : 1013
    Type : Error
    Message : When contacting
    https://mail.DOMAINNAME.com/Rpc received the error No connection could be made because the target machine actively refused it

    Id : 1017
    Type : Error
    Message : [EXPR]-Error when contacting the RPC/HTTP service at
    https://mail.DOMAINNAME.com/Rpc. The elapsed time was 402 milliseconds.
    Id : 1006
    Type : Success
    Message : The Autodiscover service was tested successfully.
    Id : 1021
    Type : Information
    Message : The following web services generated errors.
    As, in EXPR
    Contacting server in EXPR
    Please use the prior output to diagnose and correct the errors.

    [PS] C:\Windows\System32>

  • #2
    Re: Exchange 2k7 Autodiscover RPC-HTTP Problem

    You simply need to change the external host name setting on the Outlook Anywhere settings within Server Config, Client Access.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Exchange 2k7 Autodiscover RPC-HTTP Problem

      I've made the change, haven't had the opportunity to restart exchange yet but will let you know how it turned out later tonight. Thank you for you help!

      Comment

      Working...
      X