Announcement

Collapse
No announcement yet.

Installing Exch 2007 with Exch 2003

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing Exch 2007 with Exch 2003

    Hi all,
    we have a Windows 2003 with Exch 2003 that acts as mail server and AD controller (also GC).

    We want to trasfer to Exchange 2007 64bit, inside a Windows 2008 server (64bit). I have some problems with prerequisites.
    Windows 2008 is a computer inside domain and i login as domain administrator.

    Following instrutions on http://www.msexchange.org/tutorials/...007-Part1.html i do:

    Setup.COM /PrepareLegacyExchangePermissions complete without errors but when i do a Setup.com /PrepareSchema i got that error:

    [18/12/2008 11.06.50] [0] **************
    [18/12/2008 11.06.50] [0] Setup will run the task 'test-setuphealth'
    [18/12/2008 11.06.50] [1] Setup launched task 'test-setuphealth -DomainController $null -DownloadConfigurationUpdates $true -ExchangeVersion '8.1.240.6' -Roles 'Global' -ScanType 'PrecheckInstall' -SetupRoles 'Global' -PrepareLegacyExchangePermissions $null -PrepareSchema $true -ADInitError 'A problem in the installation program has been taken place during the validation of the state of Active Directory: Impossible to recover from Active Directory the relative information to controller of dominion with role master the outline.''
    [18/12/2008 11.06.51] [1] Beginning processing.
    [18/12/2008 11.06.57] [1] [ERROR] A problem in the installation program has been taken place during the validation of the state of Active Directory: Impossible to recover from Active Directory the relative information to controller of dominion with role master the outline.
    [18/12/2008 11.06.57] [1] [WARNING] If it is continued, the outline of Active Directory will come dawned. In order to verify that l' organization is ready for Exchange 2007, to execute the control of conformity of Exchange 2007, that it is part of Exchange Best Practices Analyzer.
    [18/12/2008 11.06.57] [1] Ending processing.
    [18/12/2008 11.06.57] [0] The Exchange Server Setup operation did not complete. For more information, visit http://support.microsoft.com and enter the Error ID.
    [18/12/2008 11.06.57] [0] End of Setup
    [18/12/2008 11.06.57] [0] **********************************************

    Also if i do normal installation with GUI, i got the same error.

    DNS seems to be ok.

    Any hints ? Thanks, Michele

  • #2
    Re: Installing Exch 2007 with Exch 2003

    Can you confirm you have all current updates on this box for Exchange as well as Server 2003. Do you have any other DCs/Exchange servers, can you run dcdiag, netdiag and the bpa against the 2003 and post any errors (without personally identifiable info).
    I assume you have run this text through a translator as well? Where are you running the preps from?
    cheers
    Andy

    Please read this before you post:


    Quis custodiet ipsos custodes?

    Comment


    • #3
      Re: Installing Exch 2007 with Exch 2003

      Yes, i can confirm that i have updated both servers. I don't have any more DCs/Exchange.

      ================================================== =====================
      DCDIAG:

      Domain Controller Diagnosis

      Performing initial setup:
      Done gathering initial info.

      Doing initial required tests

      Testing server: Nome-predefinito-primo-sito\SABSERVER
      Starting test: Connectivity
      ......................... SABSERVER passed test Connectivity

      Doing primary tests

      Testing server: Nome-predefinito-primo-sito\SABSERVER
      Starting test: Replications
      ......................... SABSERVER passed test Replications
      Starting test: NCSecDesc
      ......................... SABSERVER passed test NCSecDesc
      Starting test: NetLogons
      ......................... SABSERVER passed test NetLogons
      Starting test: Advertising
      ......................... SABSERVER passed test Advertising
      Starting test: KnowsOfRoleHolders
      ......................... SABSERVER passed test KnowsOfRoleHolders
      Starting test: RidManager
      ......................... SABSERVER passed test RidManager
      Starting test: MachineAccount
      ......................... SABSERVER passed test MachineAccount
      Starting test: Services
      ......................... SABSERVER passed test Services
      Starting test: ObjectsReplicated
      ......................... SABSERVER passed test ObjectsReplicated
      Starting test: frssysvol
      ......................... SABSERVER passed test frssysvol
      Starting test: frsevent
      ......................... SABSERVER passed test frsevent
      Starting test: kccevent
      ......................... SABSERVER passed test kccevent
      Starting test: systemlog
      ......................... SABSERVER passed test systemlog
      Starting test: VerifyReferences
      ......................... SABSERVER passed test VerifyReferences

      Running partition tests on : ForestDnsZones
      Starting test: CrossRefValidation
      ......................... ForestDnsZones passed test CrossRefValidation
      Starting test: CheckSDRefDom
      ......................... ForestDnsZones passed test CheckSDRefDom

      Running partition tests on : DomainDnsZones
      Starting test: CrossRefValidation
      ......................... DomainDnsZones passed test CrossRefValidation
      Starting test: CheckSDRefDom
      ......................... DomainDnsZones passed test CheckSDRefDom

      Running partition tests on : Schema
      Starting test: CrossRefValidation
      ......................... Schema passed test CrossRefValidation
      Starting test: CheckSDRefDom
      ......................... Schema passed test CheckSDRefDom

      Running partition tests on : Configuration
      Starting test: CrossRefValidation
      ......................... Configuration passed test CrossRefValidation
      Starting test: CheckSDRefDom
      ......................... Configuration passed test CheckSDRefDom

      Running partition tests on : asb
      Starting test: CrossRefValidation
      ......................... asb passed test CrossRefValidation
      Starting test: CheckSDRefDom
      ......................... asb passed test CheckSDRefDom

      Running enterprise tests on : asb.xxx.it
      Starting test: Intersite
      ......................... asb.unisi.it passed test Intersite
      Starting test: FsmoCheck
      ......................... asb.unisi.it passed test FsmoCheck

      ================================================== =======================
      NETDIAG:

      .....................................

      Computer Name: SABSERVER
      DNS Host Name: sabserver.asb.xxx.it
      System info : Windows 2000 Server (Build 3790)
      Processor : x86 Family 6 Model 8 Stepping 6, GenuineIntel
      List of installed hotfixes :
      KB923810
      KB924667-v2
      KB925398_WMP64
      KB925902-v2
      KB927891
      KB929123
      KB930178
      KB932168
      KB933729
      KB933854
      KB935839
      KB935840
      KB936357
      KB936782
      KB938127
      KB938464
      KB941569
      KB942830
      KB942831
      KB943055
      KB943460
      KB943485
      KB944338-v2
      KB944653
      KB945553
      KB946026
      KB948496
      KB949014
      KB950762
      KB950974
      KB951066
      KB951698
      KB951746
      KB951748
      KB952069
      KB952954
      KB953155
      KB954211
      KB954600
      KB955069
      KB955839
      KB956391
      KB956802
      KB956803
      KB956841
      KB957095
      KB957097
      KB958215
      KB958644
      Q147222


      Netcard queries test . . . . . . . : Passed
      GetStats failed for 'Miniport WAN (PPPOE)'. [ERROR_NOT_SUPPORTED]



      Per interface results:

      Adapter : Connessione alla rete locale (LAN)

      Netcard queries test . . . : Passed

      Host Name. . . . . . . . . : sabserver
      IP Address . . . . . . . . : 10.10.10.5
      Subnet Mask. . . . . . . . : 255.255.255.0
      Default Gateway. . . . . . : 10.10.10.1
      Dns Servers. . . . . . . . : 10.10.10.5


      AutoConfiguration results. . . . . . : Passed

      Default gateway test . . . : Passed

      NetBT name test. . . . . . : Passed
      [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names is missing.

      WINS service test. . . . . : Skipped
      There are no WINS servers configured for this interface.

      Ipx configration
      Network Number . . . . : 00000000
      Node . . . . . . . . . : 0002a5418281
      Frame type . . . . . . : 802.2



      Adapter : IPX Internal Interface

      Netcard queries test . . . : Passed

      Ipx configration
      Network Number . . . . : 00000000
      Node . . . . . . . . . : 000000000001
      Frame type . . . . . . : Ethernet II



      Adapter : IpxLoopbackAdapter

      Netcard queries test . . . : Passed

      Ipx configration
      Network Number . . . . : 1234cdef
      Node . . . . . . . . . : 000000000002
      Frame type . . . . . . : 802.2



      Adapter : NDISWANIPX

      Netcard queries test . . . : Passed

      Ipx configration
      Network Number . . . . : 00000000
      Node . . . . . . . . . : 4cf320524153
      Frame type . . . . . . : Ethernet II




      Global results:


      Domain membership test . . . . . . : Passed


      NetBT transports test. . . . . . . : Passed
      List of NetBt transports currently configured:
      NetBT_Tcpip_{C1B63B82-C450-4F6F-8D0B-4669B8DF3217}
      1 NetBt transport currently configured.


      Autonet address test . . . . . . . : Passed


      IP loopback ping test. . . . . . . : Passed


      Default gateway test . . . . . . . : Passed


      NetBT name test. . . . . . . . . . : Passed
      [WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.


      Winsock test . . . . . . . . . . . : Passed


      DNS test . . . . . . . . . . . . . : Failed
      [WARNING] The DNS entries for this DC are not registered correctly on DNS server '10.10.10.5'. Please wait for 30 minutes for DNS server replication.
      [FATAL] No DNS servers have the DNS records for this DC registered.


      Redir and Browser test . . . . . . : Passed
      List of NetBt transports currently bound to the Redir
      NetBT_Tcpip_{C1B63B82-C450-4F6F-8D0B-4669B8DF3217}
      The redir is bound to 1 NetBt transport.

      List of NetBt transports currently bound to the browser
      NetBT_Tcpip_{C1B63B82-C450-4F6F-8D0B-4669B8DF3217}
      The browser is bound to 1 NetBt transport.


      DC discovery test. . . . . . . . . : Passed


      DC list test . . . . . . . . . . . : Passed


      Trust relationship test. . . . . . : Skipped


      Kerberos test. . . . . . . . . . . : Passed


      LDAP test. . . . . . . . . . . . . : Passed


      Bindings test. . . . . . . . . . . : Passed


      WAN configuration test . . . . . . : Skipped
      No active remote access connections.


      Modem diagnostics test . . . . . . : Passed


      Netware configuration
      You are not logged in to your preferred server .
      Netware User Name. . . . . . . :
      Netware Server Name. . . . . . :
      Netware Tree Name. . . . . . . :
      Netware Workstation Context. . :

      IP Security test . . . . . . . . . : Skipped

      Note: run "netsh ipsec dynamic show /?" for more detailed information


      The command completed successfully

      ================================================== ======================

      The Exchange BPA get no errors. I have traslated errors because they are in italian and i'm running the preps from windows 2008 64bit (the new server that will run Exchange 2007).

      Thanks, Michele

      Comment


      • #4
        Re: Installing Exch 2007 with Exch 2003

        I can see this

        [WARNING] The DNS entries for this DC are not registered correctly on DNS server '10.10.10.5'. Please wait for 30 minutes for DNS server replication.
        [FATAL] No DNS servers have the DNS records for this DC registered.

        Can you run dcdiag /fix and netdiag /fix on them and see if the reports are different afterwards?

        If this is the only server involved then make sure you have the domain/forest set to 2003 and Exchange set to native mode.

        Have a read of this, including some of the caveats

        http://technet.microsoft.com/en-us/l.../bb125224.aspx
        cheers
        Andy

        Please read this before you post:


        Quis custodiet ipsos custodes?

        Comment


        • #5
          Re: Installing Exch 2007 with Exch 2003

          dcdiag /fix and netdiag /fix run without errors. netdiag /fix tell me that have fixed errors but successive run of netdiat show me the same error.

          What i can do ?

          Thanks, Michele

          Comment


          • #6
            Re: Installing Exch 2007 with Exch 2003

            Anyone can help me ?

            Comment


            • #7
              Re: Installing Exch 2007 with Exch 2003

              Sorry O-Zone, I was off on hols.

              Can you run "netdom /query fsmo" to see if your server knows of the role holders as I'm not sure what this bit is referring to "Directory the relative information to controller of dominion with role master the outline.''

              Could you also check "dcdiag /e /c /v > c:\dcdiagecv.txt" just to see what other info is shown.

              It looks to me like there are resolution problems which we need to fix before you can move forward.
              cheers
              Andy

              Please read this before you post:


              Quis custodiet ipsos custodes?

              Comment


              • #8
                Re: Installing Exch 2007 with Exch 2003

                Hi,

                Please run latest Exbpa and check whther your org is ready for E2K7

                Rgds

                Comment


                • #9
                  Re: Installing Exch 2007 with Exch 2003

                  Originally posted by AndyJG247 View Post
                  Sorry O-Zone, I was off on hols.

                  Can you run "netdom /query fsmo" to see if your server knows of the role holders as I'm not sure what this bit is referring to "Directory the relative information to controller of dominion with role master the outline.''

                  On both server that command finisched successfully, recognizing "sabserver" as rome holders for all.

                  Originally posted by AndyJG247 View Post
                  Could you also check "dcdiag /e /c /v > c:\dcdiagecv.txt" just to see what other info is shown.

                  It looks to me like there are resolution problems which we need to fix before you can move forward.
                  On SABSERVER (the role holders) it runs. On EXCH2007 the new machine) it die telling me that the server is not a "directory server".

                  The result on SABSERVER were pasted there: http://pastebin.ca/1302634

                  Thanks ! Michele

                  Comment


                  • #10
                    Re: Installing Exch 2007 with Exch 2003

                    Originally posted by muneer_bom3 View Post
                    Hi,

                    Please run latest Exbpa and check whther your org is ready for E2K7

                    Rgds
                    It ran without errors.

                    I have a problems when doing "setup.com /PrepareSchema" with permissions on AD.

                    Michele

                    Comment


                    • #11
                      Re: Installing Exch 2007 with Exch 2003

                      Not sure about this bit:

                      Just for a laugh, can you try rebooting that Exchange/GC and wait for 5 mins at the desktop. Run netdiag /fix and then try again?

                      Code:
                      1. Starting test: VerifyEnterpriseReferences
                      2. The following problems were found while verifying various important DN
                      3. references. Note, that these problems can be reported because of
                      4. latency in replication. So follow up to resolve the following
                      5. problems, only if the same problem is reported on all DCs for a given
                      6. domain or if the problem persists after replication has had
                      7. reasonable time to replicate changes.
                      8. [1] Problem: Missing Expected Value
                      9. Base Object:
                      10. CN=EXCH2007,CN=Domain System Volume (SYSVOL share),CN=File Replication Service,CN=System,DC=asb,DC=xxx,DC=it
                      11. Base Object Description: "SYSVOL FRS Member Object"
                      12. Value Object Attribute Name: frsComputerReference
                      13. Value Object Description: "DC Account Object"
                      14. Recommended Action: Check if this server is deleted, and if so
                      15. clean up this DCs SYSVOL FRS Member Object. Also see Knowledge
                      16. Base Article: Q312862
                      17. [2] Problem: Missing Expected Value
                      18. Base Object:
                      19. CN=EXCH2007,CN=Domain System Volume (SYSVOL share),CN=File Replication Service,CN=System,DC=asb,DC=xxx,DC=it
                      20. Base Object Description: "SYSVOL FRS Member Object"
                      21. Value Object Attribute Name: serverReference
                      22. Value Object Description: "DSA Object"
                      23. Recommended Action: Check if this server is deleted, and if so
                      24. clean up this DCs SYSVOL FRS Member Object. Also see Knowledge
                      25. Base Article Q312862
                      26. ......................... SABSERVER failed test VerifyEnterpriseReferences
                      cheers
                      Andy

                      Please read this before you post:


                      Quis custodiet ipsos custodes?

                      Comment


                      • #12
                        Re: Installing Exch 2007 with Exch 2003

                        Originally posted by AndyJG247 View Post
                        Not sure about this bit:

                        Just for a laugh, can you try rebooting that Exchange/GC and wait for 5 mins at the desktop. Run netdiag /fix and then try again?
                        On reoply i got this entry FAILED:

                        Code:
                        DNS test . . . . . . . . . . . . . : Failed
                            [FIX] re-register DC DNS entry 'asb.xxx.it.' on DNS server '10.10.10.5' succeed.
                            FIX PASS - netdiag re-registered missing DNS entries for this DC successfully on DNS server '10.10.10.5'.
                            [FATAL] No DNS servers have the DNS records for this DC registered.

                        Comment


                        • #13
                          Re: Installing Exch 2007 with Exch 2003

                          Seems that the problem is that (on W2K and AD):

                          DNS test . . . . . . . . . . . . . : Failed
                          [FIX] re-register DC DNS entry 'asb.xxx.it.' on DNS server '10.10.10.5' succeed.
                          FIX PASS - netdiag re-registered missing DNS entries for this DC successfully on DNS server '10.10.10.5'.
                          [FATAL] No DNS servers have the DNS records for this DC registered.
                          I have tried with netdiag /fix and with dcdiag /fix but no way.

                          The only DNS is itself.

                          Any hints ?

                          Comment


                          • #14
                            Re: Installing Exch 2007 with Exch 2003

                            Can you see any records on that DNS server for this server?
                            Anything odd in the event logs on either?
                            cheers
                            Andy

                            Please read this before you post:


                            Quis custodiet ipsos custodes?

                            Comment


                            • #15
                              Re: Installing Exch 2007 with Exch 2003

                              Hi,

                              i'm not able to find anything odd in DNS server. A doubt: maybe having AD, Exchange and DNS on the same server can cause that problems ?

                              Thanks, Michele

                              Comment

                              Working...
                              X