No announcement yet.

Trying to change EHLO responce

  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to change EHLO responce

    I want to change the EHLO reply from the SMTP connection to other servers. It currently replies with the internal DNS name of the server. What I want it to reply with is When I try to change it I get this error when clicking Apply...

    Microsoft Exchange Error
    The following error(s) occurred while saving changes:

    When the AuthMechanism parameter on a Receive connector is set to the value ExchangeServer, you must set the FQDN parameter on the Receive connector to one of the following values: the FQDN of the transport server "not-sv001.domain.ds", the NetBIOS name of the transport server "NOT-SV001", or $null.
    I'm guessing it is trying to say that the server doesn't have that DNS name configured on itself. Any ideas how to get around this?
    Please remember to leave positive reputation points (The Ying Yang Icon) if someone helps you.

  • #2
    Re: Trying to change EHLO responce

    As a guess you have your connector set to only talk to exchange therefore it needs a certificate for the name you want to use? Does this server have a cert for
    Last edited by AndyJG247; 7th May 2008, 11:24.

    Please read this before you post:

    Quis custodiet ipsos custodes?


    • #3
      Re: Trying to change EHLO responce

      You cannot change the ehlo on the default Receive Connector. Has nothing to do with DNS settings - Microsoft only allow one of three settings - the server's real FQDN, the NETBIOS name or blank - although I don't seem able to get it to set to blank through the GUI.

      Simon Butler
      Exchange MVP

      More Exchange Content:
      Exchange Resources List:
      In the UK? Hire me:

      Sembee is a registered trademark, used here with permission.