Announcement

Collapse
No announcement yet.

Problem in Sending and Receiving Emails!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem in Sending and Receiving Emails!!!

    Hi Guys,

    I have a problem in sending and receiving emails from Internal to External and Receiving from External to Internal.

    Virtual Setup:

    ISP --> ISA Server Enterprise Edition 2006 in NLB --> Internal DNS Server --> Exchange Server 2007.

    I have a Domain that set with Habibalby.local, during the setup of Exchange 2007, it picks this domain as an Authoritative Domain, i have added another domain that called habibalby.dyndns.org where my MX record is set. From the Shall Command Line, i have set the Habibalby.dyndns.org as the Default Domain and Authoritative Domain for this setup.

    The Habibalby.local, i have made it as InternalRelay Domain Only. I have made a Send Connector with Address-Space "*". Also, i have made the Email Address Policy to look for the Habibalby.dyndns.org.

    When I try to send email to outside, the email is bouncing back with originator Address that pointing to [email protected]l [[email protected]]
    Sent: Sunday, March 02, 2008 9:04 PM

    How can I make the Habibalby.dyndns.org as the Default Domain for sending out to the Internet?

    Note:
    Code:
    [MSH] C:\Documents and Settings\Boss>Get-AcceptedDomain
    
    Name                           DomainType               Default
    ----                           ----------               -------
    Habibalby                      Authoritative            True
    Habibalby.local                InternalRelay            False
    When I telnet from outside to habibalby.dyndns.org on port 25, that forward it from the ADSL Router to the Outside Interface of the ISA Server, i got the Responses and i can see my server which is replying the SMTP Protocol.

    am I lacking somewhere else?

    Please help
    Last edited by habibalby; 2nd March 2008, 19:04.
    ================================
    HND: Higher National Diploma in
    Computer Science(IT)


    Passed:
    MCSA+Security 2003, VCP3, VCP4
    Done:VMware DSA
    ================================[/COLOR]

  • #2
    Re: Problem in Sending and Receiving Emails!!!

    habibalby,

    I believe when using Dyndns you need to configure your exchange server to relay through them. You do this by configure one of there mail relays on your exchange server as a smart host.

    http://www.dyndns.com/services/mailhop/relay.html

    I believe this is a paid service.

    Ryan

    Comment


    • #3
      Re: Problem in Sending and Receiving Emails!!!

      Yes, i have done that. I have made 2 HOST (A) records, the other one is having the MX record poiting to it.

      mail-habibalby.dyndns.org = habibalby.dyndns.org

      mx record is configured on mail-habibalby.dyndns.org
      ================================
      HND: Higher National Diploma in
      Computer Science(IT)


      Passed:
      MCSA+Security 2003, VCP3, VCP4
      Done:VMware DSA
      ================================[/COLOR]

      Comment


      • #4
        Re: Problem in Sending and Receiving Emails!!!

        Ok... What is the FQDN of your virtual SMTP server? The link below show how you can setup Domain Masquerading for Exchange 2007.

        http://exchangepedia.com/blog/archiv...1_archive.html

        Ryan

        Comment


        • #5
          Re: Problem in Sending and Receiving Emails!!!

          The FQDN is hmsexch01.habibaby.local, but in the Accepted domain, i have put the habibalby.dyndns.org as an Authoritative Domain and set it as a Default.

          In the Email Accepted Policy, i have selected the Habibalby.dyndns.org.

          The Send Connector, i have made in the Address Space as "*".

          The Receive Connector i didn't touch it and left it as the Default.
          ================================
          HND: Higher National Diploma in
          Computer Science(IT)


          Passed:
          MCSA+Security 2003, VCP3, VCP4
          Done:VMware DSA
          ================================[/COLOR]

          Comment


          • #6
            Re: Problem in Sending and Receiving Emails!!!

            If it is ok with you, may i send a test email to an account that you have in the domain that is having the issue? Or can you send a detail email header from an NDR? I think it would be helpful if I can see it from that perspective.

            Ryan

            Comment

            Working...
            X