Announcement

Collapse
No announcement yet.

OMA not working with SSL enabled

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OMA not working with SSL enabled

    G'day all

    I have a problem with accessing OMA when I've enabled SSL. I enabled 128-bit SSL under default web site and inherited to all sub-folders and now when I'm trying to log on the address https://servername/oma I get the following error "A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.". But if I untic 128-bit SSL under Exchange it works OK.

    I've browsed the web for answers but had no luck so I'm hoping some of you guys can point me in the right direction.

    By the way it's Server 2003 Sp1 R2 and Exchange 2003 Sp1 swedish language.

    Thanks
    Robert

  • #2
    Re: OMA not working with SSL enabled

    You don't set up SSL on the Default Web Site!

    For starters, you need to change that, and only enable SSL on the EXCHANGE and OMA directories.
    Cheers,

    Daniel Petri
    Microsoft Most Valuable Professional - Active Directory Directory Services
    MCSA/E, MCTS, MCITP, MCT

    Comment


    • #3
      Re: OMA not working with SSL enabled

      Thanks for your reply

      As you suggested I removed SSL from the default web site and only enabled it on the Exchange and OMA directories but I still get the sam error.

      If I remove it from the Exchange directory I can access OMA.

      In related articles I've read SSL is applied on the default web site, isn't that the easiest way to apply SSL for all your directories?

      Thanks
      Robert

      Comment


      • #4
        Re: OMA not working with SSL enabled

        This tread may be relevant to your needs.
        http://forums.petri.com/showthread.php?t=8660
        Regards,
        Jeremy

        Network Consultant/Engineer
        Baltimore - Washington area and beyond
        www.gma-cpa.com

        Comment


        • #5
          Re: OMA not working with SSL enabled

          Thanks for your reply.

          The tread was not relevant to the problem I have, I don't know if I didn't explained so it made sence. Why can't we have the forum in swedish instead

          As long as I don't thick the box for SSL security on the exchange directory it works fine and that is what I found a bit strange.

          Thanks
          Robert

          Comment


          • #6
            Re: OMA not working with SSL enabled

            I just thought it might be that your mobile device didn't trust the root CA.
            Regards,
            Jeremy

            Network Consultant/Engineer
            Baltimore - Washington area and beyond
            www.gma-cpa.com

            Comment


            • #7
              Re: OMA not working with SSL enabled

              Thats OK

              Thanks for your time
              Robert

              Comment


              • #8
                Re: OMA not working with SSL enabled

                Don't confuse the requirement for SSL with being able to use SSL.

                If you have require SSL enabled on any of the Exchange directories, but specifically the /exchange or /oma virtual directory then OMA will break. This is because OMA makes an internal call on port 80 to the /exchange virtual directory when you are accessing OMA.

                This doesn't mean that you are not using SSL. What I do is block port 80 access on the firewall - so that only https:// type URLs work.
                If you have some users who moan about not being able to type mail.domain.com (or whatever) in to their browser then simply setup a redirect on your public web site... http://www.domain.com/mail redirects to https://mail.domain.com/

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment


                • #9
                  Re: OMA not working with SSL enabled

                  Thanks for your answer.

                  That explain why it's not working.

                  As you mentioned I've set up the firewall to re-direct only port 443 to exchange server. I was only want to know if I did something wrong, but as it turned out I didn't.

                  Thanks
                  Robert

                  Comment

                  Working...
                  X