Announcement

Collapse
No announcement yet.

no luck on "RPC over HTTPS"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • no luck on "RPC over HTTPS"

    Thx for the great documentation for RPC over HTTPS on Ex2k3.

    Other than once I can able to make OL2k3 work in WAN situation, suddenly it just don't work when I click Send/Receive in OL2K3!
    Then no matter what I try on outlook/rpcdiag or remove and create back the profile, RPC over HTTPS just not work!

    However, my situation seems a bit different as my EX2k3 on Win2k3 are on member server and there're another GC/DC/FSMO hold Win2k3 server internally without any access from WAN.

    I've checked IIS RPC Virtual Directory's log, it got sth like:
    2006-08-11 05:47:56 192.168.0.111 RPC_OUT_DATA /rpc/rpcproxy.dll ex2k3:6004 443 domain\testing 111.222.111.222 MSRPC 200 0 0

    which seems to be correct, and 6001, 6002 and 6004 port are listening on the EX2K3 Server.

    Is there special settings for such environment ?
    Should I set "Not part of an Exchange managed RPC-HTTP topology" or "RPC-HTTP back-end server" in EX2k3's RPC-HTTP tab in System Manager ?

    Thx
    csklho

    P.S. I've found out that when issuing "outlook.exe /rpcdiag", if you input Exchange Server NETBIOS name as , say "ex2k3", then most likely u'll try ur RPC over HTTPS using HTTPS port. If u use internal FQDN like "ex2k3.mycompany.local", it'll just use RPC to connect!
    Last edited by csklho; 11th August 2006, 06:49.

  • #2
    Re: no luck on "RPC over HTTPS"

    Finally get it works after doing this:

    1. Set in System Manager for "RPC-HTTP back-end server"

    2. Modify Registry:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy]
    "ValidPorts" Value data
    from "NetBIOS_ServerName:100-5000"
    to "NETBIOS_ServerName:6001-6004;External_FQDN:6001-6004"

    However, the problem that even I've set to check to use HTTP instead of TCPIP for fast and slow network, it still 1st check for TCPIP(i.e. RPC) as the Exchange Server name is always be seen as ex2k3.mycompany.local. Then after timeout for RPC TCPIP connection, it'll try for HTTPS and that will be ok working.

    Is there any way that must force outlook 2003 using HTTPS only ?

    Thanks
    csklho

    Comment


    • #3
      Re: no luck on "RPC over HTTPS"

      If you set Outlook to use HTTPS for both slow and fast connections then it should go straight to HTTPS. It has done so on my installations.

      The Exchange server being seen as the internal name is normal and to be expected.

      Simon.
      --
      Simon Butler
      Exchange MVP

      Blog: http://blog.sembee.co.uk/
      More Exchange Content: http://exchange.sembee.info/
      Exchange Resources List: http://exbpa.com/
      In the UK? Hire me: http://www.sembee.co.uk/

      Sembee is a registered trademark, used here with permission.

      Comment


      • #4
        Re: no luck on "RPC over HTTPS"

        Originally posted by Sembee
        If you set Outlook to use HTTPS for both slow and fast connections then it should go straight to HTTPS. It has done so on my installations.

        The Exchange server being seen as the internal name is normal and to be expected.

        Simon.
        Thx for reply...
        After I've added the "msstd:external.myexchange.fqdn" in the SSL Mutual Auth/Trust setting in Outlook 2003 HTTP connection part, it's ok, thx
        Last edited by csklho; 20th August 2006, 11:25.

        Comment

        Working...
        X