Announcement

Collapse
No announcement yet.

Front-end SMTP Fails to send external mail to back-end server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Front-end SMTP Fails to send external mail to back-end server

    I am running into an almost "impossible to diagnose" issue with my front-end server. I have no problems sending and receiving email internally between sites and have no problem sending email to the internet from any site. I do however have a problem receiving external email on a newly installed back-end server. External mail comes in to the front-end server and is routed to the proper queue for delivery but is never sent.

    Here is what I have in place: 1 - Front-end server and 5 - Back-end servers. All servers in the domain are connected via a Cisco IPSec VPN tunnel. All servers are running Exchange 2003 SP2 on top of Windows Server 2003 Enterprise SP1.

    Using Netmon2 to view the packets between the front-end and back-end servers I find the following errors:

    SMTP: Rsp: Requested action aborted: local error in processing, 38 bytes
    SMTP: Response = 451 Timeout waiting for client input


    I have enabled maximum logging on both Exchange servers and see 0 related errors in the event logs on either machine.

    Any troubleshooting help would be appreciated.

  • #2
    Re: Front-end SMTP Fails to send external mail to back-end server

    Please review:

    http://www.microsoft.com/technet/pro...b228ab826.mspx

    You may didnt setup correct ports etc.
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Front-end SMTP Fails to send external mail to back-end server

      Thanks for the reply but this isn't the case. All other Exchange servers in the domain are working perfectly and the server that is having an issue is configured exactly as the others.

      On the affected server POP3, OWA, RPC over HTTP and the standard Outlook client all work perfectly. The only problem is emails that are sent from the internet addressed to mailboxes that reside on the new server are accepted by the front-end server, routed and queued for delivery to the new server but are never delivered. They do however remain in the outgoing server queue on the front-end server with multiple retries.

      I am beginning the think this could be a Cisco PIX issue and not Exchange related.

      I have attached a screenshot of what WinRoute returned when I ran it against the new server.
      Attached Files
      Last edited by marcola; 27th July 2006, 16:50.

      Comment


      • #4
        Re: Front-end SMTP Fails to send external mail to back-end server

        Please disable SMTP filter on the PIX:

        http://support.microsoft.com/?kbid=895857

        and consider to use a real firewall and not a toy like PIX
        Best Regards,

        Yuval Sinay

        LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

        Comment

        Working...
        X