Announcement

Collapse
No announcement yet.

Problem telnetting to exchange? SMTP fails inbound

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem telnetting to exchange? SMTP fails inbound

    Hello

    I have set myself up an exchange 2003 server at home, on a single processor Intel based SUN server(2.8ghz 8gb ram). I have a similar problem to another thread recently posted on these forums. my setup so far is as follows

    Installed windows 2003+sp1+hot fixes
    setup DNS and made sure it functions
    ran dcpromo
    installed AD and checked all the components are there in DNS

    installed asp, smtp,nntp, iis as shown on the exchange install window. checked settings using dcdiag and netdiag, no problems shown

    ran forestprep/domainprep and then the setup of exchange...all went smoothly as I would have expected. (installed exchange sp2 but not sp1 first) Mail flows internally between clients and out to the internet....

    now heres the problem, inbound mail , I know all the other settings on my network are ok as I have mail coming in to a different email server(non microsoft-which I am replacing with e2k3)

    I have no firewall enabled on the server and the second nic was disabled so it did not add 169.x.x ip addresses into dns. my doamin names are all correct and everything else looks as it should. but I cannot open a connection to port 25 which is where the problem lies.

    I ran the server role wizard as in the other thread but it did nothing except install pop3. I also checked on the server console and I can get a connection to port 25 locally within itself, but not from anything on the network, which to me looks like a firewall thing, but its not running.

    Come on I know someone knows the answer. this is basically out the box w2k3 and e2k3(+sp's) the server is the only one in its own domain,hosting its own DNS, I know not the best was to do it, but it is only for my home business..


    Could it be hardware related? looking at the box it is basically an intel P4 motherboard with a couple of scsi disks the only unusal feature is it has a remote admin port that w2k picked up during install and asked if I want to use the remote port or local screen for installation...


    Wow,,,Long post, but I wanted to get as much info down as I could

    thanks

    Mikie

  • #2
    Re: Problem telnetting to exchange? SMTP fails inbound

    If your mail is coming in to a different server, presumably it has a different IP address to the Exchange server.

    Have you confirmed your router is forwarding TCP/IP port 25 traffic to the IP address of the Exchange box?

    OK -- re-read your post and you are not able to hit port 25 on your Exchange server from elsewhere in the LAN so this is probably not the answer.


    Tom
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Problem telnetting to exchange? SMTP fails inbound

      Hello

      Ok what I am doing for testing is to remove the other server currently hosting my mail server and then fire up the e2k3 box in its place, so that gets me round the IP issues, its very weird... I have checked and rebuilt the box with the same results,,, I am now tempted to try different hardware as this is annoying the Cr*p out of me.


      Mikie

      Comment


      • #4
        Re: Problem telnetting to exchange? SMTP fails inbound

        Just found out that my sun server is a 64bit AMD chip on an intel board.
        Now I have installed 32bit windows....Could this be the problem????


        Mikie

        Comment


        • #5
          Re: Problem telnetting to exchange? SMTP fails inbound

          Ok looks like its not hardware as I have just built a laptop with w2k3 and e2k3 and I get the exact same results.

          I have tried portqry and advanced port scanner and both show nothing for port 25 across the network ,,,although telnet on the server to port 25 (telnet localhost 25) connects nice..

          Am I looking for the wrong problem here? should I be able to telnet to port 25 from across the network? and should port scanners show it as listening?


          thanks

          Mikie

          Comment


          • #6
            Re: Problem telnetting to exchange? SMTP fails inbound

            just for me;

            What's te current problem?
            What have you done so far? (any kb's?)
            Marcel
            Technical Consultant
            Netherlands
            http://www.phetios.com
            http://blog.nessus.nl

            MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
            "No matter how secure, there is always the human factor."

            "Enjoy life today, tomorrow may never come."
            "If you're going through hell, keep going. ~Winston Churchill"

            Comment


            • #7
              Re: Problem telnetting to exchange? SMTP fails inbound

              Not found any useful KB documents, SMTP should just work, if the service is installed and running the port should be open..

              We have come to the conclusion that is could be a problem with the install media (clutching at straws here) that has been the only common thing between all the installs



              Mikie

              Comment


              • #8
                Re: Problem telnetting to exchange? SMTP fails inbound

                Ok Please ignore all my last posts,,,,I have found the problem...the server is fine, the laptop built as a server is fine......

                its Bl*ody windows xp service pack2 (on my clients laptop) that stops me from telnetting to port 25, even with the firewall off....

                one to watch for!

                thanks for the input from you all



                Mikie

                Comment


                • #9
                  Re: Problem telnetting to exchange? SMTP fails inbound

                  I bet that annoyed you big style!! Glad it is all working again!
                  Server 2000 MCP
                  Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

                  ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                  Comment

                  Working...
                  X