Announcement

Collapse
No announcement yet.

Enable OMA on Windows 2000 sp4 server and exchange 2003

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Enable OMA on Windows 2000 sp4 server and exchange 2003

    Hi Guys:

    I have been trying to enable OMA on my Windows 2000 sp4 server and exchange 2003 for the past few weeks with no avail. When I log in I receive the security credentials but then receive the dreded “A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator” message. According to Microsoft I needed to add and additional host header that uses the NetBIOS name of the Exchange 2003 computer to the OMA Web site which I did but didn’t work.

    Other forums suggest creating a second virtual directory without SSL but those instructions relate to Windows Server 2003 as I do not have the option to “save my configuration to a file.” Is there anyway I can get this to work?

  • #2
    Re: Enable OMA on Windows 2000 sp4 server and exchange 2003

    Please review:

    http://www.msexchange.org/tutorials/...rver_2003.html

    Did you use any antivirus/url filtere etc.? This can also create this problem...
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Enable OMA on Windows 2000 sp4 server and exchange 2003

      Hi - I read the artical and confirmed that all of my settings were identical but no luck. Also this article was based on Windows 2003 Enterprise Edition which I do not have. I have Windows 2000.

      Comment


      • #4
        Re: Enable OMA on Windows 2000 sp4 server and exchange 2003

        Hello all,

        It's bumpalump time!

        I also have the Single (back end and no front end) Server on Windows 2000 Server SP4 and Exchange Server 2003 SP2
        I don't have the ability to save my configuration file.
        You would think that good old Microsoft could put a little blurb in
        http://support.microsoft.com/default...b;en-us;817379
        to say this, even though they don't really support 2000 server anymore.

        It looks like the necessary SSL enabling on the exchange virtual directory (using with OWA currently), is making it impossible for the exchange activesync directory to talk to it.

        Thanks for the help in advance if anyone has gotten through this

        Comment


        • #5
          Re: Enable OMA on Windows 2000 sp4 server and exchange 2003

          Try this one - one week ago:
          http://forums.petri.com/showthread.php?t=11300
          CNE 5, CCA, MCSE NT4.0-2003, MCSE 2003 messaging, Exchange Server MVP.
          Tzahi Kolber - IT Supervisor
          Polycom Israel.

          Comment


          • #6
            Re: Enable OMA on Windows 2000 sp4 server and exchange 2003

            That unfortunately only works for Server 2003

            I did dig up the following (sorry if it's a little long, no good link)
            It's close to those instructions, but looks to be more for 2000 server
            Now I'm getting "Your account in ....does not have permission" 0x85010004
            though I've got the certs I need on my device. Closer....but...

            Activate SSL or Forms Based Authentication on front-end Exchange servers only.
            Follow these steps to activate SSL or Forms Based Authentication on back-end Exchange servers:
            Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
            Locate the Servers/ServerName/Protocols/HTTP/Exchange Virtual Server folder.
            Right-click Exchange Virtual Server, click New, and then click Virtual Directory.
            Type the name of the new virtual directory that Server ActiveSync and Outlook Mobile Access will use. For example, type /Exchange-oma.

            Note The name that you type is not the name of the virtual directory that OWA clients connect to.
            In the Exchange Path section, click Mailboxes for SMTP domain, and then make sure that the correct SMTP domain is listed.
            Click OK to return to Exchange System Manager.
            Click Start, click Run, type regedit, and then click OK.
            Locate and then click the following registry key:
            HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\MasSync\Parameters
            Click the Parameters key.
            On the Edit menu, point to New, and then click String Value.
            Name the new key that you created in step 10 "ExchangeVDir".
            Double-click the ExchangeVDir key, and then type name of the virtual server that you created in step 4 in the Value Data box.

            For this example, type /Exchange-oma.
            Click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
            Right-click the virtual directory that you created in step 4, and then click Properties.

            In this example, the virtual directory is named /Exchange-oma.
            Click the Directory Security tab.
            Under IP address and domain name restrictions, click Edit.
            Click Denied access, and then click Add.
            Click Single computer.
            Type the IP address of the server that you are configuring in the IP address box, and then click OK.
            Click OK to return to the Directory Security tab of the virtual directory properties page.
            Under Anyonymous access and authentication control, click Edit.
            Verify that the Integrated Authentication check box is selected. If the Integrated Authentication check box is not selected, click to select this check box.
            Click OK.
            Under Secure communications, click Edit. Make sure that Require secure channel (SSL) is not selected.
            Click OK to close the remaining dialog boxes.
            Repeat steps 3 to 20 for each of the back-end servers where SSL is required for the Exchange virtual directory or where Forms Based Authentication is activated on the Exchange virtual directory.
            Click Start, point to Programs, point to Administrative Tools, and then click Services.
            Stop and restart the World Wide Web Publishing service.

            Comment


            • #7
              Re: Enable OMA on Windows 2000 sp4 server and exchange 2003

              Hi,

              have you managed to resolve this?

              I have about the same issue here.

              One windows 2000 server with Exchange 2k3.
              I wanted to use SSLand forms based auth. , but unfortunately after enabling this i cannot sync mobile devices using server active sync.

              The export to file menu is not available under w2k.

              Has anyone managed to enable fba and ssl on w2k/exchage 2k3 and use server ActiveSync?

              Help is appreciated.


              regards,

              harry

              Comment


              • #8
                Re: Enable OMA on Windows 2000 sp4 server and exchange 2003

                I have just resolved the issue discussed in this posting.
                Basically, the fixes from Microsoft work, but what I found was that on Windows 2000, ActiveSync does not look the the registry key "ExchangeVDir".

                http://support.microsoft.com/kb/330463

                Therefore, my solution was to use "/exchange" as the folder for the ActiveSync activity and a copy "/mail" for the actual web access activity.

                Comment

                Working...
                X