No announcement yet.

problem with rpc over https

  • Filter
  • Time
  • Show
Clear All
new posts

  • problem with rpc over https


    i have two questions:


    I have one exch 2003(without sp1) server which is also the dc (2003 server+sp1).
    client: xp+sp1 outlook 2003

    I followed the articles:

    Configure SSL on OWA
    Configure RPC over HTTP/S on a Single Server
    Configure SSL on Your Website with IIS
    Configure Outlook 2003 to use RPC over HTTP/S
    Testing RPC over HTTP/S Connection

    I've already implemented ssl with owa ( i used 3rd party ca but which is unknown to the clients, until i had it myself)


    Configured Exchange to use RPC over HTTP/S.

    Configured the RPC virtual directory in Internet Information Services.

    Configured the RPC proxy server to use specific ports.

    Configured the client computers to use RPC over HTTP/S

    I'm trying to access from the lan
    outlook.exe /rpcdiag

    i see it still uses the tcp/ip
    i tried to do it by force (only caused troubles, the esm didn't run)

    when trying to connect through wan i get the logon box(where i need to enter the user/password)

    and i get a message that the exchange server is unavailable(while i know it is up)

    kill me i dono i followed all the steps carefully.

    2. one more problem is when i'm trying to connect simply by outlook from the wan(without using ssl and all that stuff) to my exch server i'm entering my exch server(external fqdn) on the profile configuration and it doesn't work , only ip but when i use owa from wan there is no problem in resolving names(dns seems to work fine)
    furthermore, when i complete the profile wizard i'm trying to connect and i get the user/password box(because im entering from a computer which is not part of the domain) and everytime i insert the cardentials, the box jump back like if there is a problem with the input.
    I'm sure my user / password is correct


  • #2
    Re: problem with rpc over https

    1. First of all, upgrade all the OS and office to the latest service pack and hotfix.

    2. Please review guides on how to use RPC over HTTP.


    Best Regards,

    Yuval Sinay

    LinkedIn:, Blog:


    • #3
      Re: problem with rpc over https


      this is the same problem i am facing i read all the articles and i am still geting the same error i.e when from WAN i use outlook express through pop3 and smtp it works perfectly but when i connect outlook with exchange cache mode it always gives me a popup window to enter password when i enter username and password it again popup the same window to enter password, this continues and i cant able to authenticate aur retreive mail box what shuld i do i m all blank now i real all the articles check configuration 5 times carefully and still not able to authenticate while from accessing from web http: & https: both are working fine what to do i am all blank and frustrated now


      • #4
        Re: problem with rpc over https

        Moshin, it might be useful to try to properly write your post. Start by putting some full stops, periods and commas where required. Reading it like it is now is very confusing.

        Daniel Petri
        Microsoft Most Valuable Professional - Active Directory Directory Services


        • #5
          Re: problem with rpc over https

          hi yuval,

          I'm afraid of upgrading.

          My computers are big carriage carts
          Last time i've upgrade the exchange(with sp1 llast week) it got stuck.

          I'f there will be no choice i will do it. office i will.

          1) Do you think sp can increase the load on the system?
          2) Do you think the authentication problem has something to do with sp's.


          If it's possible,
          I would like to hear some comments from you

          Last edited by kopal; 3rd July 2006, 13:11.