No announcement yet.

OMA Application Security Exception

  • Filter
  • Time
  • Show
Clear All
new posts

  • OMA Application Security Exception

    hi all

    im am having the most frustrating time with OMA.


    * Windows 2003 Server SP1 (domain controller, its only exchange server)
    * MS Exchange 2003 SP2
    * no Forms Based Authentication or SSL for OMA or OWA
    * OWA works flawlessly

    OMA was running perfectly until ASP 2.0 was updated. The reboot is now giving me this error when attempting to browse to http://server/oma from the local server where Exchange is installed

    Server Error in '/OMA' Application.

    Security Exception
    Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

    Exception Details: System.Security.SecurityException: Request for the permission of type System.Security.Permissions.RegistryPermission, mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 failed.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [SecurityException: Request for the permission of type System.Security.Permissions.RegistryPermission, mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 failed.]
    System.Security.CodeAccessSecurityEngine.CheckHelp er(PermissionSet grantedSet, PermissionSet deniedSet, CodeAccessPermission demand, PermissionToken permToken) +675
    System.Security.CodeAccessSecurityEngine.Check(Per missionToken permToken, CodeAccessPermission demand, StackCrawlMark& stackMark, Int32 checkFrames, Int32 unrestrictedOverride) +0
    System.Security.CodeAccessSecurityEngine.Check(Cod eAccessPermission cap, StackCrawlMark& stackMark) +88
    System.Security.CodeAccessPermission.Demand() +62
    Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable) +159
    Microsoft.Win32.RegistryKey.OpenSubKey(String name) +27
    Microsoft.Exchange.OMA.UserInterface.Global..cctor () +48

    Version Information: Microsoft .NET Framework Version:1.1.4322.2300; ASP.NET Version:1.1.4322.2300

    I have tried the following:

    * re installed v1.1 .net framework, didnt work (as per c:\windows\Microsoft.NET\Framework\vX.X.XXXX\aspne t_regiis.exe -i
    * re installed v2.0 .net framework and tried running OMA with it (thru the ASP.NET property page of OMA), same thing
    * re created the virtual folders in ISS in compliance with MS KB article, same error
    * changed the exchangemobilebrowseapplicationpool from network service to local system
    * allowed OMA default website to run anonymously, still the security message.
    * modified permissions on the website (thru IIS manager and direct to the folder) to allow EVERYONE full control, same error
    * copied another instance of \exchsrvr\oma\browse from a machine working to this server, didnt work
    * combination of everything above at different times and in different configurations.


    * there is no useful information in the event logs
    * i get the dreaded 0x85010014 error code syncing from my PDA
    * im going nuts

    i have read every single relevant KB article, every other reported incident, tried methods suggest by other people and it still does not work and is driving me INSANE!

    can someone please help??
    Last edited by decksla; 13th June 2006, 05:32.

  • #2
    Re: OMA Application Security Exception

    Make sure that the OMA virtual directory is set to use version 1.1. The two versions are basically two different applications - version 2.0 does not contain the same components as version 1.1

    I have also heard of issues with 2.0 causing problems with the device update and that it needs to be reinstalled.

    Finally, make sure that oma is running in the correct application pool.
    It should be ExchangeMobileBrowseApplicationPool

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.