Announcement

Collapse
No announcement yet.

Exchange are not communicating internally

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange are not communicating internally

    Hi Guys

    Great site! I've been using the info for a long while but have never registered.

    I have an issue with my exchange environment. I'll try and out line as best as possible.

    I have a single node exchange cluster that I have inherited. I have had some serious problems with this server.
    I have installed a new 2003 Exchange server and plan on migrating users from the old to the new server. I had a few problems on the way mainly relating to ADC (even though there are no Ex 5.5 servers in the domain). I have resolved this issue.

    I now have the old Exchange Single node cluster and the new Exchange 2003 ent server working.
    I created a new user and set the mailbox to reside on the new Exchange server.
    I have tested checking this account using OWA.
    I sent a test email using telnet from inside my network and this email shows up in OWA.
    I have setup the SMTP and I am able to send emails to external accounts.

    The problem I have is that I am unable to receive mails from the old server or from external accounts.


    I suspect the internal routing is where I have a problem and would appreciate any help.

    Thanks All...

    Zaidk
    Last edited by zaidk; 11th June 2006, 18:29.

  • #2
    Re: Exchange are not communicating internally

    Hi zaidk,

    Emails from old server are stucked on the queue of that server ?
    What error message do you receive?.
    I suspect that may be also a DNS problem, and for external mails do they now what is your MX server ?
    Regards,

    Calin
    Regards,
    Calin Irimies

    Comment


    • #3
      Re: Exchange are not communicating internally

      Hi Calin

      Thanks for the post...
      The messages are in the queue on the respective servers.
      It like the 2 server don't know about each other?
      I have tried to ping the servers from each other and that works fine... I pinged the full names.
      You mentioned the MX record. - The way it's currently working is our mail is point to the MX of the old server and I won't be able to change it to point both (lower priority on 1) any time very soon.
      I would like the mail to come in as it is, and for exchange to check if the mailbox is on it's self(the old server) if not to pass it on to the new server else to fail.
      I would have expected this to be the normal for a 2 exchange server setup. Should I
      Setup up 2 routing pairs - 1 for each direction between the servers? If so what is the best way to do this?

      Thanks again - I am really in a bind

      Zeek

      Comment


      • #4
        Re: Exchange are not communicating internally

        You don't need an MX record for internal servers. Exchange will route the email itself.
        If the servers are on the same network then you don't need a routing group either.

        Make sure that the servers can see each other...
        Telnet to port 25 of the other server using all three methods...

        telnet ip.ad.re.ss 25
        telnet servername 25
        telnet servername.domain.com 25

        Any of those fail it would indicate a problem with DNS or connectivity.

        However the most common reason for a new server failing to talk to the old servers correctly is a smart host configured on the SMTP VS of the old servers.
        ESM, Servers, <your server>, Protocols, SMTP. Right click on the SMTP VS and choose Properties. Click on the tab Delivery and then Advanced. Ensure that there is no smart host configured.
        If you need to use a smart host, then use an SMTP Connector instead. (http://www.amset.info/exchange/smtp-connector.asp).

        The second most common reason is restrictions on the SMTP VS. IF you are using any kind of outsourced spam or virus protection, then they often recommend that the SMTP VS is restricted so that only their servers can connect. Check for the restrictions to ensure that there are none, or that the new Exchange server can communicate on the SMTP port.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Exchange are not communicating internally

          Hi zaidk,

          You could set up a routing group connector between the two.
          But as those are from the same Exchange organization the dns routing for email should be enough for internal routing between the two.

          So if the MX is pointing to the old server all external emails are coming to it and if they are for the other one they should be routed to the new exchange.
          What error does it show on the queue ?

          Regards,
          Calin
          Last edited by calinx; 11th June 2006, 18:57.
          Regards,
          Calin Irimies

          Comment


          • #6
            Re: Exchange are not communicating internally

            Hi Sembee/Calinx

            I have test Dns and all is fine... I was able to telnet using all the methods.

            The SMTP VS on both the servers have the same setting and both are using smart hosts.
            I am going to remove the smart host setting from both (???) and create new SMTP connectors. Should I then create new connectors on both of the servers or could I set just the New server to send externally?

            Thanks for the info, it's very helpful and appreciated!

            Zeek...

            Comment


            • #7
              Re: Exchange are not communicating internally

              SMTP Connectors are not server specific.
              Therefore you can create a single SMTP Connector and use it for the entire site.
              SMTP Connectors have two scopes - routing group wide or org wide. It is up to you which you use, depending on your topology.

              Do you have a frontend server? If so, you could create a Exchange org wide SMTP Connector, then list JUST the frontend server in as a bridgehead. That would mean that all servers in the org would send their outbound email via the frontend server.

              Simon.
              --
              Simon Butler
              Exchange MVP

              Blog: http://blog.sembee.co.uk/
              More Exchange Content: http://exchange.sembee.info/
              Exchange Resources List: http://exbpa.com/
              In the UK? Hire me: http://www.sembee.co.uk/

              Sembee is a registered trademark, used here with permission.

              Comment


              • #8
                Re: Exchange are not communicating internally

                Thanks guys.

                Got it working...
                I created 1 SMTP Connector to route for the entire routing group and removed the smart host settings from the default SMTP VS.
                I then restarted the services and ran a few tests..
                I can send mail internally to the other server and can recieve mail from external...

                now all i have to do is start mailbox migration.

                Any idea how long 570Gb of mail will take to migrate accross..?

                Zeek

                Comment


                • #9
                  Re: Exchange are not communicating internally

                  You need to get the public and system folders replicated first. If you don't, then come tomorrow morning you will have a lot of unhappy users.

                  Simon.
                  --
                  Simon Butler
                  Exchange MVP

                  Blog: http://blog.sembee.co.uk/
                  More Exchange Content: http://exchange.sembee.info/
                  Exchange Resources List: http://exbpa.com/
                  In the UK? Hire me: http://www.sembee.co.uk/

                  Sembee is a registered trademark, used here with permission.

                  Comment


                  • #10
                    Re: Exchange are not communicating internally

                    Is that the case even if we don't have and info in the public area?

                    Zeek

                    Comment


                    • #11
                      Re: Exchange are not communicating internally

                      Yes.
                      System Folders contain your Offline Address Books, Free Busy information and other key Exchange data.

                      This article from MS KB is about how to remove the first Exchange server. What I tend to suggest is that the folders indicated in this article should be replicated to the other servers as well.
                      http://support.microsoft.com/default.aspx?kbid=822931

                      Simon.
                      --
                      Simon Butler
                      Exchange MVP

                      Blog: http://blog.sembee.co.uk/
                      More Exchange Content: http://exchange.sembee.info/
                      Exchange Resources List: http://exbpa.com/
                      In the UK? Hire me: http://www.sembee.co.uk/

                      Sembee is a registered trademark, used here with permission.

                      Comment

                      Working...
                      X