Announcement

Collapse
No announcement yet.

Directory Issue between Ek5.5 & Ek23

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Directory Issue between Ek5.5 & Ek23

    I have a strange issue in that my existing 5.5 server and the new ek23 server are not coexisting the way they should. From Ek23 System Mgr I can see both servers and the tree properly. From 5.5 Admin I only see the old server and not both. I can connect to the new server from 5.5 admin, but they only see themselves. According to MS this is why I cannot receive messages after moving a test mailbox to the new server.

    A little history: I found out that the 5.5 server had its site display name changed a few years back. When I connect ek23 server from 5.5 admin, it is the old site name that is displayed, not the current one. I see the same thing from AD when running the ldp utility and checking on servers. The site name displays the old name and not the current name that I see in the Exch Sys Mgr.

    My question is are there any pitfalls in renaming the site display back to its original name? I ask because of the co-existince between the two servers. Will it adversely affect the ek23 server?

    After turning on maximum logging and replicating the config_ca, the following entries are listed in the application log:

    Source: MSADC
    Category: LDAP Operations
    Event ID: 8020
    LDAP Search of directory <5.5 servername> at base 'cn=Microsoft DMD,ou=SWM,o=SWM' using filter '(USN-Changed>=597456)' was unsuccessful. Directory returned the LDAP error:[0xc] Unavailable Critical Extension. (Connection Agreement 'LocalRecipientCA' #2104)

    Again, the Site Display name was changed a few years back. What would happen to my configuration agreement if I changed it back to its original name on the 5.5 side? I do not want to break anything in the new setup on 2003.


    Thanks for the help.
    Last edited by dlove106; 10th March 2006, 22:00. Reason: Additional Info at bottom of post.

  • #2
    Re: Directory Issue between Ek5.5 &amp; Ek23

    Did you setup ADC to each site? How many accounts/mailboxes use Exchange 5.5? In some cases its more easy to export via exmerge users account and then import them into new mailbox on the Exchange 2003.
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Directory Issue between Ek5.5 &amp; Ek23

      I did configure the ADC and have successfully replicated user accounts into a mixed mode domain (disabled accounts). I am able to create a user on the 5.5 admin and user and mailbox will show up on the ek23 sys mgr.

      The problem, it seems is that the server object cannot be replicated, even though the system knows that its there. It just thinks that it is still using the original site name instead of the current one.

      So, I was wondering if renaming the site name back to its original name might help solve the problem. My concern is will that invalidate the config_ca agreement which was auto-created?

      Thanks for any input. I have had a difficult time finding anyone who has even had this problem.

      DLove

      Comment


      • #4
        Re: Directory Issue between Ek5.5 &amp; Ek23

        Its a tricky question

        1. First backup the system (system state + Full backup & mailboxes).
        2. Stop ADC replications and then rename the site.
        3. Start ADC again.

        In case of duplicate entries try to use "Active Directory Account Cleanup Wizard" to merge them & in rare cases you may need to re-configure the ADC settings.

        If you have a time, please try to make this changes of virtual system so you will not getting surprise other wise, I recommanded to contact local Microsoft PSS team.

        Also, please review:

        http://support.microsoft.com/?kbid=837968

        http://support.microsoft.com/?id=899385


        Yuval
        Best Regards,

        Yuval Sinay

        LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

        Comment


        • #5
          Re: Directory Issue between Ek5.5 &amp; Ek23

          Thank you for your reply. It has been difficult getting any information concerning this issue. I will call Microsoft and pose the question to them. Also, I appreciate the steps you outlined and will mention them as well.

          DLove

          Comment

          Working...
          X