Announcement

Collapse
No announcement yet.

"you do not have permission to send as"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "you do not have permission to send as"

    "you do not have permission to send as" Hi all - first post, need some help

    I have two registered domains, 123.com & abc.com. I have a w2k3EE Domain Controller also running Exchange 2k3 SP2.

    123.com is my domain name and my exchange domain. i have configured the MX and A records appropriately to send and receive inside and outside the domain. this has been tested and is working. By the way i am behind a router using tcp forwarding on port 25.

    i have also configured the MX and A records for abc.com so that mail sent to @abc.com will go to my 123.com exchange server.

    example: mail message from [email protected] sent to [email protected] will enter the inbox of [email protected].

    this is all fine and good.

    the only thing i want to change is:

    I want to be able to use the send as feature in outlook to "appear" that i am sending from my abc.com domain.

    in other words, if a customer sends to abc.com i want them to get a reply from abc.com not 123.com. Is this a possible set up or do i need to install and configure and additional exchange server?

    currently when trying to use the send as feature in outlook i get the subject error message

    i have changed the "advanced permissions" to allow send as on user objects - no change

    i have tried to add abc.com as an x.400 under the defaul recipient policy but my actual domain name is too long to enter in the Private/Administrative management domain name - the field will accept 16 characters - my total domain name is 21 characters

    sorry for the long post

    JL

  • #2
    Re: "you do not have permission to send as"

    Hello,
    I have some questions:

    1. Do your all users expect to receive emails sent to abc.com or there are only a few email addresses like [email protected], [email protected] available in abc.com ?
    2. Did you set both email addresses for your users?

    If you set up more than one SMTP email address, Outlook MAPI client uses that one that is marked as default.

    As a quick solution, you can configure an IMAP or POP3 client for your users. Here you can set [email protected] as email address. Use this client to replay to messages sent to abc.com domain.
    Regards,
    Csaba Papp
    MCSA+messaging, MCSE, CCNA
    ...............................
    Remember to give credit where credit is due and leave reputation points where appropriate
    .................................

    Comment


    • #3
      Re: "you do not have permission to send as"

      answer to 1 is yes

      my primary domain is 123.com

      the other domain name we have purchased is abc.com

      all user/email accounts have been created on 123.com

      currently there are no abc.com servers

      if i send an email from a hotmail account to [email protected] it will enter the email inbox of [email protected]

      this is the same for every user. i would like to have the option to reply as littlja @ either 123.com or abc.com without having to setup additional mailboxes or a completely different DC.

      thx for help

      Comment


      • #4
        Re: "you do not have permission to send as"

        Based on the following facts:
        - two internet domains are hosted by the same exchange server;
        - all users have 2 email addresses: one in 123.com and one in abc.com (abc.com is probably the default email address);
        - time by time users have to replay to messages sent to 123.com with there 123.com domain SMTP address;
        -outlook 2003 let us to use several email account for the same profile. (but only one MAPI account).
        we can accomplish this task in the following way:
        -enable IMAP on your Exchange server;
        -for each user configure an IMAP account linked to his exchange mail box; (in this way, there profile will have 2 email accounts. By default IMAP will only download the headers)
        Having this configuration replay to an email, click to “Accounts” tab and choose from witch account to replay.
        If you choose abc .com IMAP account, the message will have your abc account as the sender.
        If you choose your 123.com default MAPI account the message will be sent from the 123.com default email address.

        Let me know if you still have concerns. Unfortunately screen captures cold not be inserted here.

        Csaba
        Last edited by netxt; 19th January 2006, 20:43.
        Regards,
        Csaba Papp
        MCSA+messaging, MCSE, CCNA
        ...............................
        Remember to give credit where credit is due and leave reputation points where appropriate
        .................................

        Comment


        • #5
          Re: "you do not have permission to send as"

          sounds good - i will give it a shot - thx for the reply

          btw - sorry for stupid question but how do i enable IMAP on the exchange server?

          when i go to the :
          Exchange System Manager>Servers>ServerName>Protocols>IMAP4


          i attempt to start the IMAP4 virtual server and get a stop error stating:

          the service did not respond in a timely fashion check event viewer

          however, there is nothing in event viewer relating to the imap service

          Comment


          • #6
            Re: "you do not have permission to send as"

            disregard - i'm stupid

            imap service was disabled in Services

            Comment


            • #7
              Re: "you do not have permission to send as"

              Originally posted by littlja
              disregard - i'm stupid

              imap service was disabled in Services
              Not so stupid. It took you less than 5 minutes to realise what the problem was and post back with an answer to that problem. Well done and thanks for posting back with the answer. It is appreciated.
              1 1 was a racehorse.
              2 2 was 1 2.
              1 1 1 1 race 1 day,
              2 2 1 1 2

              Comment


              • #8
                Re: "you do not have permission to send as"

                QUOTE:
                for each user configure an IMAP account linked to his exchange mail box; (in this way, there profile will have 2 email accounts. By default IMAP will only download the headers)


                can u expand on this

                how do i do this?

                thx

                Comment


                • #9
                  Re: "you do not have permission to send as"

                  Sure, I will try explaining it better.
                  Configuring a second account for each user a new button named Accounts will be available when you start a new email.
                  This button let you to choose witch account to be used to send the email.
                  Since your IMAP account was configured with [email protected], this will appear as the sender email address. If you choose the MAPI account, Exchange will use your default email address, more exactly [email protected] and this one will appear as the sender email address.
                  Practically the IMP account will be used only to send emails.

                  Regards,
                  Csaba
                  Regards,
                  Csaba Papp
                  MCSA+messaging, MCSE, CCNA
                  ...............................
                  Remember to give credit where credit is due and leave reputation points where appropriate
                  .................................

                  Comment


                  • #10
                    Re: "you do not have permission to send as"

                    Along these same lines I am trying to find a similar solution. As more and more businesses, such as mine, have users with multiple external POP accounts that they check and accumulate messages from in their Exchange accounts, they similarly want to be able to appear to send from them when sending those messages through their Exchange accounts.

                    Netxt, your solution seems to be best suited when two or just as few accounts (domains) are involved. Is there a solution whereby user(s) have say maybe 7 or more accounts, whether they're covering just a few domains or all 7 (or more) totally different domains?? It appears that regardless of the solution, Exchange needs to authenticate (in some of the more secure scenarios) the address (user) being inputted in the From field when manually filled in using such mail clients such as Outlook. Perhaps that is where investigation for a solution needs to begin (authenticating the user based on the From field input) or am I wrong?!?!? Is there a way to use aliasing (address aliases) or configure relaying -- while continuing to keep relaying secure -- just right to accomplish all of this??

                    To repeat the need, I use a POP connector that pulls emails for users from multiple ISP accounts and use a single smart host to send Exchange emails out. When users reply to messages, they want to be able to change the From field to equal the original address the email was received for. Subsequently, users want to be able to create new emails and change the From field to match an address of one of their multiple ISP email accounts. However, when this is currently done, users get this error:

                    Your message did not reach some or all of the intended recipients.

                    Subject: XXXXXX
                    Sent: mm/dd/yyyy 1:00 PM

                    The following recipient(s) could not be reached:

                    [email protected] on mm/dd/yyyy 1:00 PM
                    You do not have permission to send to this recipient. For assistance, contact your system administrator.
                    MSEXCH:MSExchangeIS:/DC=local/DC=domain:SERVERNAME


                    Sending emails using the default Exchange account is no problem whatsoever. As a solution for the above, I would like to avoid creating separate mailboxes for each of the accounts or alternatively create IMAP accounts as suggested below.
                    Last edited by gheatly; 25th February 2006, 16:09.

                    Comment


                    • #11
                      Re: "you do not have permission to send as"

                      I've got to say setting this up 'properly' in Exchange is an absolute mission.

                      Like many others I had a few users who needed to send mail 'from' more than just their default domain exchange name.

                      I would idealy just like to create totally separate AD user accounts for these other users so the mail being delievered to them goes into it's on set of Exchange folders, and the most important part is so they can access the account through web access.

                      I nearly got it set up, and it seemed to be working but threw the main domain off course and noone there could receive email any more - think I must have messed the receipient policies up?

                      Comment


                      • #12
                        Re: "you do not have permission to send as"

                        Hi Meza,

                        What version of Windows is your server, what version of Exhange are you using?? Are you using direct SMTP/POP or are you using a smarthost (i.e. running your mail through an ISP)??

                        Comment


                        • #13
                          Re: "you do not have permission to send as"

                          Hi there,

                          It's Exchange 2003 on SBS 2003
                          I'm downloading mail using EFS (downloads mail from POP and forwards it locally to the SMTP server)

                          I'm sending mail via my ISP's SMTP server (smarthost?)

                          ta
                          Meza

                          Comment


                          • #14
                            Re: "you do not have permission to send as"

                            Hi Meza and everyone else,

                            I have solved my own problem and perhaps this will help you in your situation Meza.

                            I am interested in providing my users access to their own external POP boxes (personal ISP accounts, etc.) associated to domains other than the one being managed/assigned to my Exchange server. I would also like to allow those users to have the choice of changing the reply address in their email messages matching the addresses of the aforementioned POP accounts.

                            So what did I do to accomplish this?? In bullet form I configured Exchange and users' Outlook clients as follows:

                            My setup:
                            • Windows 2003 Enterprise
                            • Exchange 2003 Enterprise
                            • Outlook 2003 on each user's machine
                            • Using smarthost (all emails to be sent externally are forwarded through my ISP)


                            Reply Address Option Configuration:
                            • Added a "Contact" per email address in Active Directory entering the desired email address (each user's requested email address) in most all fields (Full Name, Display Name, Alias, E-mail (SMTP)). This allows for not having to create mailboxes for all of these additionally requested email addresses. You can accomplish the same by adding a new "User" per email address but I did not want to have to manage additional mailboxes.
                            • Give it a day for the addresses to appear in the Global Address List

                            You now have addresses available for users to choose from that will authenticate in order for them to be able to type into Outlook's from field. This will allow users to create email messages and have the reply-to address be different than the Exchange domain address as needed.

                            If you need to segregate addresses to give users access only to assigned addresses, you can create additional Address Lists in Exchange and set the permission levels on those lists accordingly. If you choose that option, best practice is to then change which address list appears first (the new reply-to address list) in users' address books in their Outlook in order to allow for ease of calling up addresses when typing in the From field.

                            One caveat to this set up: When replying to emails that come in to an address not associated with the Exchange domain address, users will have to manually input the From address when replying to those messages. Exchange always defaults to the Exchange domain address or primary address setup for users (usually dictated by the recipient policy) in their Active Directory accounts.

                            Meza, as to your issue with throwing your main domain off, this may be an issue with what SMTP addresses are now set up for each user. Yes, recipient policies are a powerful thing, especially when you have "Automatically update email addresses based on recipient policy" enabled. To reset all the users, you can either check the accuracy of and apply the default recipient policy to ensure all the addresses are in order and the proper one (your exchange domain name in this format "@somename.com") is set as primary OR you can go to each user's account in Active Directory under the email address tab and check email addresses there. Be sure the proper one is set to primary. [email protected] must be in there somewhere to allow for internal routing of mail (in your situation of using a smarthost) but not as the primary one. Hope this helps.
                            Last edited by gheatly; 10th March 2006, 16:01.

                            Comment


                            • #15
                              Re: "you do not have permission to send as"

                              Hi Casual, ta for the detailed reply! Sounds like it might work. I'm on holiday for a couple of weeks but with give that a try when I get back and let you know how I get on.

                              By the way, what do you mean by a 'contact' in the active directory?

                              Meza

                              Comment

                              Working...
                              X