Announcement

Collapse
No announcement yet.

Intelligent Message Filter not shown in Exchange Managent Tool

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intelligent Message Filter not shown in Exchange Managent Tool

    Hi all, (sorry for the long post)

    I'm having a problem with one of the new functions in exchange, to be more correct -> enabling IMF

    My server is W2k standard | SP4 installed
    Exchange is Exch03 srv | SP2 installed

    This is the only server on the network - So this one is acting as a gateway server and a mailbox server at the same time.

    Besides that I'm running PopCon to trigger my external mailbox to fetch the mails to my server. This also has a anti-spam filter.


    Now comming to the problem!

    I did install SP2 on the exchange server and no errors have been shown. After a reboot over night I waited for 2 days to make further changes to the server. After that period I did try to alter the IMF settings on my server. I could change the gateway settings and also the client side/store settings.

    Then going to the next step I tried to enable IMF on my virtual servers but I did not have the extra node that would be generated after SP2 (with IMF) is installed. ( ESM > Administrative groups > First admini... > servers > servername > protocols > smtp > )

    Also looked to the registry. I did notice there where only 2 keys next to CONTENTFILTER
    * Standard which was empty
    * Signature which was filled in.

    I cant believe these are the only 2 keys that should be in here.

    So.

    My Q is: can anyone provide me a screen shot of his/her registry settings of the contentfilter key so that I can alter mine and provide some help with this?
    Last edited by rikke_vp; 29th November 2005, 00:43. Reason: Changing title - shorter Question

  • #2
    Re: Intelligent Message Filter not shown in Exchange Managent Tool

    Please review:

    http://download.microsoft.com/downlo...2_RelNotes.htm

    Because Intelligent Message Filter is included in Exchange Server 2003 SP2, it is no longer an add-on and, therefore, a container must be created within Active Directory® directory service as follows:

    Cn=UCE Content Filter,cn=Message Delivery,cn=Global Settings,cn=<ORG NAME>cn=Microsoft Exchange,cn=Services,cn=configuration,dc=<root domain>

    You must have elevated rights to create this container — either Exchange Full Administrator or Exchange Administrator role at the organization level. The first time that you try to upgrade to a released or SP1 version of Exchange Server 2003, your permissions will be checked and a warning displayed if you do not have the correct rights level.

    After the first upgrade is completed successfully, the system checks for the container and allows you to proceed with a more restricted permission set, such as Exchange Administrator role at the administrative group or higher.

    For information about how to deploy Exchange Server 2003, see the Exchange Server 2003 Deployment Guide.
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Intelligent Message Filter not shown in Exchange Managent Tool

      Hi,

      thx for the reply and sorry for my late answer... Its pretty busy at the job for the moment

      I will try to make that container into AD. But I first going to try to alter my registry to replicate the registry on a server where IMF is enbled in the ESM console.

      But its indeed correct that the container should exist, which I will check also.

      Thx again and I keep you posted.
      R

      Comment


      • #4
        Re: Intelligent Message Filter not shown in Exchange Managent Tool

        Hi Everyone,

        I have a similar problem.
        The IMF Node does not appear in ESM under Protocols-SMTP

        I am running Windows 2003 Server with SP1 and Exchange 2003 with SP2.
        There are two Exchange Servers in our Organisation that both function as Front end\Backend. They are connected over a WAN.
        I previously install IMF before Exch SP2 was available. I have removed IMF and re-installed Exch03 SP2 with no success.

        The UCE Content Filter entry exists in Active Directory.

        I have checked the registry and the HKLM\software\microsoft\exchange\ContentFilter entry is there.
        There are only 2 entries under this however. They are signature and default.

        I am also missing the UCEArchive folder that should appear in <root>\Program Files\Exchsrvr\Mailroot\vsi n\UCEArchive.
        I have enabled IMF under the properties of my default smtp virtual server.

        Everything else appears to be as it should be.

        I would appreciate any guidance that anyone can offer.

        Best regards
        Peter Calder
        Last edited by Peterc; 21st December 2005, 06:07.
        Best Regards

        Peter C
        MCSE

        Comment


        • #5
          Re: Intelligent Message Filter not shown in Exchange Managent Tool

          Similar problem encountered on a Win2K3 SBS SP1 with Exchange 2003 SP2. No errors encountered during EX2K3SP2 install.

          From the Exchange System Manager, I'm missing the Intelligent Message Filtering component under Protocols/SMTP. However, the IMF tab exists in Message Delivery. Other items missing include:
          1. Registry - HKLM\software\microsoft\exchange\ContentFilter
          2. The UCEArchive folder that should appear in <root>\Program Files\Exchsrvr\Mailroot\vsi n\UCEArchive.
          3. The UCE Content Filter entry in Active Directory.

          I've encountered this issue on two different Win2K3 SBS's this week.

          Comment


          • #6
            Re: Intelligent Message Filter not shown in Exchange Managent Tool

            Well I had the same problem where the IMF appeared at the Global Setting/Mail Delivery but not a the Server/Protocols/SMTP at first. What I had to do was, uninstall IMF then install again, and reboot.

            That worked for me.

            Comment


            • #7
              Re: Intelligent Message Filter not shown in Exchange Managent Tool

              Hi,

              Thanks to everyone for your help.

              My IMF has started working on both servers after a re-boot.
              The IMF node still doesnt appear under protocols-SMTP but the UCE Folder has appeared under Mailroot\vsi1.
              The IMF is catching spam so I am pretty happy with the result.

              My guess is that the IMF node no longer appears under SMTP when you are using Exchange 2003 SP2 because it is now integrated into Exchange.

              Regards
              PeterC
              Best Regards

              Peter C
              MCSE

              Comment


              • #8
                Re: Intelligent Message Filter not shown in Exchange Managent Tool

                Uninstalling and re-installing the IMF resolved the issue.

                Comment


                • #9
                  Re: Intelligent Message Filter not shown in Exchange Managent Tool

                  I'm missing some of the registry entries for IMF and the UCE folder.

                  I would like to uninstall and reinstall IMF but I'm not really sure where to do this on Small Business Edition?

                  Thanks in advance for your help

                  Comment


                  • #10
                    Re: Intelligent Message Filter not shown in Exchange Managent Tool

                    Hi,

                    It was mentioned that "a container must be created within Active Directory® directory service as follows:

                    Cn=UCE Content Filter,cn=Message Delivery,cn=Global Settings,cn=<ORG NAME>cn=Microsoft Exchange,cn=Services,cn=configuration,dc=<root domain>"

                    May I know how do I create a container? I am logging in the server as the administrator. When I right click New in the ADUC, it does not have an option call container.

                    Any help is appreciated.

                    Thank you.

                    Comment


                    • #11
                      Re: Intelligent Message Filter not shown in Exchange Managent Tool

                      Originally posted by mousehunt
                      Hi,

                      It was mentioned that "a container must be created within Active Directory® directory service as follows:

                      Cn=UCE Content Filter,cn=Message Delivery,cn=Global Settings,cn=<ORG NAME>cn=Microsoft Exchange,cn=Services,cn=configuration,dc=<root domain>"

                      May I know how do I create a container? I am logging in the server as the administrator. When I right click New in the ADUC, it does not have an option call container.

                      Any help is appreciated.

                      Thank you.

                      Read this...

                      http://forums.petri.com/showthread.php?t=6129
                      Andrew

                      ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                      Comment

                      Working...
                      X