Announcement

Collapse
No announcement yet.

Not receiving incoming SMTP internet mail

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not receiving incoming SMTP internet mail

    Hi,

    I must be doing something wrong and maby somebody can give some direction?

    I installed Exchange 2k3 on a win 2k3 std server and working behind a NAT firewall. ISP changed my A and MX records to point to my firewall adress.

    Internal mail routing (in local domain) = no problem
    Sending mail to other domains (internet outgoing mail) = no problem

    Receiving internet mail is a problem nothing is coming in.
    I setup the MX records in my DNS like described on the site but this has no effect.
    What am I doing wrong?????
    THANKS in advance.

    Marcel

  • #2
    Re: Not receiving incoming SMTP internet mail

    Have you got entries in firewall to point your public to private ip for your email server?

    Do a dnscheck by going to http://www.dnsreport.com/tools/mail.ch?domain=put your smtp email address here+

    This should ping your server and check wether your mx records are pointing to the right ip and stuff.

    Let me know what happens.

    Chan Weng Lou
    Mozambique

    Comment


    • #3
      Re: Not receiving incoming SMTP internet mail

      Hi,
      thanks for the quick reply.
      The firewall points from the internet ip adress to the internal ip adress. Ports Open: 80 and 25.

      I checked your link and the mx file shows the correct data. Ping to the adres works.
      Any hints / tips?

      Thanks
      Marcel

      Originally posted by MVP wanna be
      Have you got entries in firewall to point your public to private ip for your email server?

      Do a dnscheck by going to http://www.dnsreport.com/tools/mail.ch?domain=put your smtp email address here+

      This should ping your server and check wether your mx records are pointing to the right ip and stuff.

      Let me know what happens.

      Comment


      • #4
        Re: Not receiving incoming SMTP internet mail

        Hi,

        Have you tried running telnet from another location to your exchange server?
        telnet servername/ip 25
        This should result in a answer from your mailserver.

        Can you see any incoming messages in your queues?

        What happens to messages sent to you? I mean, do the sender receive any kind of respons? And how long does it take?

        Give us more configuration settings for further troubleshooting.

        //M

        Comment


        • #5
          Re: Not receiving incoming SMTP internet mail

          Does external DNS know where your mail server is??

          Do you have an MX record, typically on your ISP's DNS server, that point to your external IP address for your server??

          Can you telnet externally to the exchange box??

          Is your exchange server configured to accept mail for the domain name that is used??

          Comment


          • #6
            Re: Not receiving incoming SMTP internet mail

            Hi,

            Some more details:
            Server: mail.bitcs.nl (ip: 84.104.219.250)
            I have opend port 25 on the firewall to enable smtp. I believe I can connect using Telnet. (it opens but that is it)

            Some anwsers:
            1) users get a mail back that the delivery is delayed
            2) I see no incoming messages in qeues
            3) mx record seems oke to me
            4) In Exchange I have added the @bitcs.nl domain. (also shows in user accounts)
            5) In my DNS server I have added the MX and A record.
            6) SMT virtual server is running (named it: mail.bitcs.nl)

            Does this give some additional insights?
            Thanks!
            Marcel

            Comment


            • #7
              Re: Not receiving incoming SMTP internet mail

              Tell us what you did to open port 25 on the firewall.
              1 1 was a racehorse.
              2 2 was 1 2.
              1 1 1 1 race 1 day,
              2 2 1 1 2

              Comment


              • #8
                Re: Not receiving incoming SMTP internet mail

                Open port 25 and forward to internal ip adress used by server using same port.

                Comment


                • #9
                  Re: Not receiving incoming SMTP internet mail

                  That's the inbound connection, what about outbound?
                  1 1 was a racehorse.
                  2 2 was 1 2.
                  1 1 1 1 race 1 day,
                  2 2 1 1 2

                  Comment


                  • #10
                    Re: Not receiving incoming SMTP internet mail

                    outbound connection ???

                    Are the inbound and outbound connections using different ports?
                    I can send mail to other domains without a problem so I was guessing that the outbound connection was not a problem.

                    I have moved the server to DMZ for a wile and in this setting the server did also not receive any mail. My guess is that it is a DNS/Exchange error or are you thinking that it is something else like the firewall?

                    Comment


                    • #11
                      Re: Not receiving incoming SMTP internet mail

                      Hi mtwarmen,

                      Are you by chance using a PIX firewall? I am unble to get anything intelligent when I telnet to your server on port 25 (IP 84.104.219.250). If you are using a PIX I think we have the problem solved. If not I would look at why I can't get anything back from a ehlo or helo command when I telnet in.

                      Thanks

                      CW
                      "This comment is composed of 100% recycled spam"

                      Comment


                      • #12
                        Re: Not receiving incoming SMTP internet mail

                        As soon as you can get an external connection to the exchange box try typing the following commands.

                        1. Open a command prompt and type Telnet Server_IP_Address 25
                        2. You should be greeted by a 220 message.
                        3. HELO <DOMAIN-NAME>
                        4. MAIL FROM: <your e-mail address>
                        5. RCPT TO: <recipients e-mail address>
                        6. DATA
                        7. Subject: Type a message subject e.g. Test
                        8. Press Enter twice
                        9. Type your message e.g. test
                        10. Press enter again
                        11. Type a full stop (.), just the dot.
                        12. You should see a 250 message come up on screen.
                        13. Type quit and press enter.
                        14. Wait on the message arriving @ your mailbox.
                        Last edited by wullieb1; 22nd November 2005, 19:18.

                        Comment


                        • #13
                          Re: Not receiving incoming SMTP internet mail

                          Originally posted by wullieb1
                          As soon as you can get an external connection to the exchange box try typing the following commands.

                          1. Open a command prompt and type Telnet Server_IP_Address 25
                          2. You should be greeted by a 220 message.
                          3. HELO heatandcontrol.co.uk
                          4. MAIL FROM: <your e-mail address>
                          5. RCPT TO: <recipients e-mail address>
                          6. DATA
                          7. Subject: Type a message subject e.g. Test
                          8. Press Enter twice
                          9. Type your message e.g. test
                          10. Press enter again
                          11. Type a full stop (.), just the dot.
                          12. You should see a 250 message come up on screen.
                          13. Type quit and press enter.
                          14. Wait on the message arriving @ your mailbox.
                          Exactly What we should be getting... Did you try this Wullieb1? I got jibberish, which is why I was suspecting a PIX firewall with SMTP fixup protocol enabled or the mailguard enabled. That would explain why it can send out, but the inbound gets mangled. Just a random stab in the dark though.

                          CW
                          "This comment is composed of 100% recycled spam"

                          Comment


                          • #14
                            Re: Not receiving incoming SMTP internet mail

                            What do you mean you got jibberish??

                            I use this everytime i need to check mail flow in my organisation so it is used alot by me and all the other folks i work with, actually i scripted it and use that.

                            You won't actually see anything on the screen when typing these commands in.

                            BTW if he can connect to his mail server on port 25 from external he should in thoery be able to send and receive mail.

                            Comment


                            • #15
                              Re: Not receiving incoming SMTP internet mail

                              I got jibberish... non sensical characters. I didn't get the anticipated replies from my commands. I have used the telnet command for de-bugging for years as well, my point was that for me, in that case I couldn't telnet in. I asked you if you tried it to see if I just had a bad conenction or if there was a problem. You can see the results of the telnet sesssion if you use a thrid party client and / or use the set local_echo (or localecho if using XP). you are right in theroy if he can send mail externally he should be able to recieve, but this is why I brought up the point of the PIX. It is well documented that it can interfere with the SMTP protocol when the fixup / mailguard is enabled.
                              "This comment is composed of 100% recycled spam"

                              Comment

                              Working...
                              X