Announcement

Collapse
No announcement yet.

Exchange Losing active sync

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange Losing active sync

    Hello

    We are running Exchange 2003 server. We have started to get these errors, when this happens we lose web mail? Did notice that in system logs I get warning ID 1013 Aprocess serving application pool exchnageappliocationpool exceeded time limits during shut down The porcess id was 6388.

    Event Type: Warning
    Event Source: Server ActiveSync
    Event Category: None
    Event ID: 3007
    Date: 07/09/2011
    Time: 14:46:58
    User:
    Computer: exchange
    Description:
    Exchange mailbox Server response timeout: Server: [dc,exchange.local] User:
    Exchange ActiveSync Server
    failed to communicate with the Exchange mailbox server in a timely manner.
    Verify that the Exchange mailbox Server is working correctly
    and is not overloaded.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/

  • #2
    Re: Exchange Losing active sync

    Assuming it worked correct for some time what changed since then?

    What steps have you done so far? Searching this error with google comes up with some suggestions, have you tried any of them?

    Comment


    • #3
      Re: Exchange Losing active sync

      It start last week, nothing changed , I have Changed The min/max heartbeat regedit keys on the server

      Maxheartbeatinterval 3500 (1356 in brackets what does that mean?
      Minheartbeatintervbal 60 (96)

      Running II6

      Comment


      • #4
        Re: Exchange Losing active sync

        Hello

        Just found this, on exchangeapplicationpool we have a tick recycle worker in minutes 1740?

        shouldn't be recycled, if it is configured to then OWA can become unreliable.
        In a default install of Exchange 2003 on Windows 2003 it looks like this:
        Recycling Tab
        • Everything Unchecked
        Performance Tab
        • Shutdown worker processes after being idele for (unchecked)
        • Limit the kernel request queue (checked - 1000 Requests)
        • Enable CPU Monitoring (unchecked)
        • Maximum number of worked processes (1)
        Health Tab
        • Enable pinging (Checked 30 seconds)
        • Enable rapid-fail protection (Checked)
          • Failures (5)
          • Time Period (5)
        • Startup time limit (90)
        • Shutdown time limit (90)
        Identity Tab
        • Varies depending on options

        Comment


        • #5
          Re: Exchange Losing active sync

          Enlcosed screen shots of exchangeapplicationpool
          Attached Files

          Comment


          • #6
            Re: Exchange Losing active sync

            Originally posted by jwc1972 View Post
            It start last week, nothing changed , I have Changed The min/max heartbeat regedit keys on the server

            Maxheartbeatinterval 3500 (1356 in brackets what does that mean?
            Minheartbeatintervbal 60 (96)

            Running II6
            Can you provide us some information from the recent HTTPERR logs as well please?

            Location: Start --> Run-->Logfiles-->HTTPERR--> open most recent logfile and please check for anything like "Connection_Refused" or "Connection_Dropped" entries, please advise if you have any of these entries present in the recent log file.


            Cheers
            Technical Director
            www.tecguruz.com
            Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

            Comment


            • #7
              Re: Exchange Losing active sync

              Hello

              Sorry about late response the website seem to busy. Wow running that tools we do get connection_dropped exchangeapplicationpool

              xchange-oma/@domain.org/NON_IPM_SUBT...ppl880508G9A4S - 1 Connection_Dropped ExchangeApplicationPool
              2011-09-04 22:45:22 212.183.128.34 6724 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -
              2011-09-04 22:45:57 212.183.128.34 41903 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -
              2011-09-04 22:46:05 192.168.1.8 54325 192.168.1.8 80 HTTP/1.1 PROPFIND /exchange-oma/@domain.org/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/iPhone/Appl880508G9A4S - 1 Connection_Dropped ExchangeApplicationPool
              2011-09-04 22:46:27 212.183.128.34 34542 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -
              2011-09-04 22:46:35 192.168.1.8 54332 192.168.1.8 80 HTTP/1.1 PROPFIND /exchange-oma/@domain.org/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/iPhone/Appl880508G9A4S - 1 Connection_Dropped ExchangeApplicationPool
              2011-09-04 22:47:02 212.183.128.34 3132 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -

              Comment


              • #8
                Re: Exchange Losing active sync

                Originally posted by jwc1972 View Post
                Hello

                Sorry about late response the website seem to busy. Wow running that tools we do get connection_dropped exchangeapplicationpool

                xchange-oma/@domain.org/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/iPhone/Appl880508G9A4S - 1 Connection_Dropped ExchangeApplicationPool
                2011-09-04 22:45:22 212.183.128.34 6724 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -
                2011-09-04 22:45:57 212.183.128.34 41903 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -
                2011-09-04 22:46:05 192.168.1.8 54325 192.168.1.8 80 HTTP/1.1 PROPFIND /exchange-oma/@domain.org/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/iPhone/Appl880508G9A4S - 1 Connection_Dropped ExchangeApplicationPool
                2011-09-04 22:46:27 212.183.128.34 34542 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -
                2011-09-04 22:46:35 192.168.1.8 54332 192.168.1.8 80 HTTP/1.1 PROPFIND /exchange-oma/@domain.org/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/iPhone/Appl880508G9A4S - 1 Connection_Dropped ExchangeApplicationPool
                2011-09-04 22:47:02 212.183.128.34 3132 192.168.1.8 80 - - - - - Timer_MinBytesPerSecond -
                Hi,

                Thanks for the reply, now lets do one step at a time.

                1. Could you please confirm what antivirus you are running and is it scanning exchange store?
                2. If yes, then can we enable Backgroupnd scanning on Exchange 2003?

                Steps to follow would be:

                Start Registry Editor (Regedt32.exe).
                1. Locate the BackgroundScanning value under the following key in the registry:
                2. If you don't see VirusScan key then create a Key called "VirusScan" under MSEXCHANGEIS and then you will have to create a DWORD "BackgroundScanning" without quotes under VirusScan.
                3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\MSExchangeIS\VirusScan
                4. If the value is set to 0, change the value to 1; double-click the entry and change the value to 1 Binary.
                5. Quit Registry Editor.
                Reference Articles: http://support.microsoft.com/?id=264731
                http://support.microsoft.com/kb/827615

                Do let me know if ActiveSync works and it does not drops intermittently? If the above does not fixes the issue then please revert back all the changes.

                By the way, you were talking about some tool you have run, whats that?


                Regards
                Last edited by jedi001; 9th September 2011, 12:28. Reason: add more info
                Technical Director
                www.tecguruz.com
                Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

                Comment

                Working...
                X