Announcement

Collapse
No announcement yet.

SMTP 550 error after adding new domain

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SMTP 550 error after adding new domain

    Hi all, can you help me with this please?

    I have added a new domain "@newdomain.com" in Exchange 2003 in the default recipient policy.

    I have updated the MX records of "mail.newdomain.com" to the IP address of the Exchange server. Our current MX record is "mailgate.currentdomain.com" and has the same IP record.

    I have set this new email as primary to a test user. I can send to other users on the network and recieve from external locations (I tested with gmail)

    However, I can't send mail to external addresses. I get the following error:

    There was a SMTP communication problem with the recipient's email server. Please contact your system administrator.
    **<mailgate.currentdomain.com #5.5.0 smtp;550 Not permitted >

    It seems that it's possible I need to add a specific SMPT record to the new domain, as you can see the error highlights the current MX in the error.

    Can anyone tell me where I can do this if this is indeed the problem?

    [EDIT] I have discovered that the SMTP connector is set to "mail.isp.com" which isn't how we send mail. I'm wondering why it is set to to that and wether that could be adding to the problem
    Last edited by mrca; 27th July 2011, 13:13. Reason: Added more infomation

  • #2
    Re: SMTP 550 error after adding new domain

    If the SMTP connector has your ISPs SMTP server listed, and the address space is *, then it is attempting to send email via your ISP. It doesn't matter whether you think you are sending email in a different way, that is how it is happening now.

    If the address space is not *, then only certainly email is going via that route.

    You should also check the properties of the SMTP virtual server to ensure that there isn't a smart host configured on that place as well. If there is, then remove it. Smart hosts should always be configured on SMTP connectors.

    The error message that you have posted almost certainly means that the ISP is rejecting the message because it doesn't recognise the sending domain as a domain it should allow through its servers. In some cases the ISP has to be told what domain you are sending email as, and this is added to their list of acceptable domains to go through their servers.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: SMTP 550 error after adding new domain

      Hi Simon,

      I have checked SMTP connecter and the address space is * with a cost of 1, connector scope is entire organisation.

      The virtual SMTP doesn't have any smart hosts listed. However, I have discovered that the relay access is set to 'only from the list below' that has granted access set for the server IP, 127.0.0.1 and a network IP I can't track down right at the moment. Could this be causing a problem?

      Does this shed any more light on the the issue?

      I also can't send to external address when I am off the network via IMAP.

      *EDIT* It seems that the IP I can't find in the relay list isn't actually in the scope. It's 192.168.16.1 scope is set to 192.168.1.x
      Last edited by mrca; 1st August 2011, 10:09. Reason: added IP info

      Comment


      • #4
        Re: SMTP 550 error after adding new domain

        It would have helped if you indicated that it wasn't an Outlook RPC client that was giving the error.

        If you are using Outlook, then you should be using RPC over HTTPS, not IMAP.

        If you want to use SMTP/POP3/IMAP to send email then you need to set the relaying settings carefully.

        Personally I don't like to allow relaying by IP address, as it can be abused. If it must be set, then it is specific servers, not IP address range.

        For users, configure authentication on the sending section. You can't use the setting for the same as inbound email, you must choose the specific option and enter the username in the format of domain\username. Exchange will then allow relaying for authenticated users.
        Although even that I would lock down so that only specific users can relay through the server. You want to set it so that the Administrator account cannot be used for authenticated relaying as that increases the attack surface of the server.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: SMTP 550 error after adding new domain

          Just to clarify, I'm not using outlook at all and therefore must use IMAP (Mail.app OSX)

          The original error is not specific to client, AFAIK.

          The actual server network IP is in the relay list, it's not set to a range. I mentioned that the unusual IP address is out of the range, that's all.

          I'm not too sure what you mean in the last paragraph, so you may have to spell it out to me. I'm a design manager, not a sysadmin (unfortunately) so all I can do is report and follow instruction as it's given.

          Comment


          • #6
            Re: SMTP 550 error after adding new domain

            Hi Simon, I apologise profusely. What you said about client got me thinking, had I actually tested? So I did.

            Via a Outlook client on the network the change to the domain works without any problems.

            However, it seems the MY client won't be able to take the change when it comes, so that will still need addressing. If you can help me with that I would be very grateful.

            Comment

            Working...
            X