No announcement yet.

SBS 2003/Exchange - iPhone 4

  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2003/Exchange - iPhone 4

    Should be easy - but something's wrong.

    Phone connects to Server, and search for mail witout errors.
    However no mail is received or sent.

    IF the user has his Outlook 2007 open, and mail is received in there, THEN the iPhone can receive the mails.

    It used to work with iPhone 3 and Exchange SP1.
    The problem came after updating to SP2.

    We have a selfissued Web Certificate reflecting the FQDN.
    We tried deleting/creating the account
    The issue is the same on all 3 iPhone 4

    Yeah - tried a lot of other common stuff.

    Especially that it is working with Outlook open makes me think IIS - but I don't know enough about it.
    Any brilliant ideas ??

    Peter HO

  • #2
    Re: SBS 2003/Exchange - iPhone 4

    Really - no good ideas ??

    Does anyone actually have pushmail to iPhone4 working (without having to open Outlook on a client PC) ?

    Peter HO


    • #3
      Re: SBS 2003/Exchange - iPhone 4

      Maybe you can tell us how the phone is connecting to the Exchange server? RPC over HTTP, POP, IMAP, etc.?


      • #4
        Re: SBS 2003/Exchange - iPhone 4

        Personally, I have never had a problem connecting an iPhone (certainly a 3 or 4) using the dedicated Exchange connector with a public certificate on the server.

        IMAP or POP, of course, is a different story....
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd

        ** Remember to give credit where credit is due and leave reputation points where appropriate **


        • #5
          Re: SBS 2003/Exchange - iPhone 4

          how did you connect the iphone initially ..?
          Please do show your appreciation to those who assist you by leaving Rep Point


          • #6
            Re: SBS 2003/Exchange - iPhone 4

            Hello There,

            Could you please confirm below details for us:

            1. Have you installed the self signed cert on to iPhone4?
            2. If not, could you please confirm whether you have tried turning off SSL on iPhone 4 (Account Info-->Advanced) and then tried syncing it?
            3. Can you also confirm whether ActiveSync still works on any other phone like HTC/Nokia etc or not?
            4. Can you also confirm whether Form Based Authentication enabled or disabled under Exchange Virtual Server (ESM-->Server-->Protocols-->HTTP)?
            5. If turning off SSL does not fixes the issue then can you post IIS logs for us (you should always amend the IP address & Server name information before posting logs publicly), please ONLY post the section of the logs when you were trying to Sync emails to iPhone 4 not all of it?
            Last edited by jedi001; 9th August 2011, 23:40. Reason: adding more info
            Technical Director
            Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified