No announcement yet.

SSL on virtual SMTP and Apple

  • Filter
  • Time
  • Show
Clear All
new posts

  • SSL on virtual SMTP and Apple

    Dear all,

    I'm running an Exchange 2003 with a virtual SMTP server listening on port 465 behind a firewall with a chained SSL certificate from Comodo. With "Require secure channel" un-checked (not using SSL), I am able to send out emails using Apple Mail 4.0 on port 465 but with it checked, the process just times out. However, I can send out emails with "Required secure channel" turned on using Thunderbird.

    I also generated a self-signed certificate using the server's internal name and attached it to the virtual SMTP server and still would just time out but no problem with Thunderbird.

    Hope you can help me troubleshoot this issue.

  • #2
    Re: SSL on virtual SMTP and Apple

    I would troubleshoot the issue this way:

    I would try an application other than AppleMail or whatever it's called.
    If I found the oither application worked as expected, I would have found the cause of my problem.

    You state that Thunderbird works appropriately.
    Therefore, applemail is your problem. Use a fully compliant product ?
    Please do show your appreciation to those who assist you by leaving Rep Point


    • #3
      Re: SSL on virtual SMTP and Apple

      Was able to "fix" it by using port 587 instead of 465. Somehow, Apple's and Microsoft's Exchange client doesn't issue a STARTTLS command (which the Exchange SMTP server requires) if it's not 587.