Announcement

Collapse
No announcement yet.

Exchange Server 2003 and Sending External Mail Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange Server 2003 and Sending External Mail Issues

    Hi all,

    This is my first post here, but have loved this website for a few years.

    We recently changed hosting providers (web & email) and we started having issues sending mail to recipients outside of our office. It seems as though the problems began when we switched our web/email hosting and the new hosting requires authentication, but I don't know how to provide that for all users or what on earth I need to do to get this right.


    Our setup:
    1 exchange server box in our office (only for sending email and not receiving)
    Email provider (Arvixe) with accounts created for all users

    In outlook for all users:
    Exchange Account
    Arvixe account (pop & SMTP) (Send and receive mail)

    Mail sent to Domain users gets sent to and received through Exchange just fine. We receive external mail through another account configured in Outlook for Arvixe and this gets saved into the Exchange Account inbox.


    Goal
    This is what we want to do (how it was working with our old provider):
    Use Exchange Server as our default account to send email and it gets sent internally and externally.

    Internal domain users get mail just fine. Anything that is sent to external domains does not go through.


    Error Messages:
    We get the following error messages in the Event log of the Exchange Server:

    Event ID 7004
    Category SMTP Protocol
    Event ID 7004

    This is an SMTP protocol error log for virtual server ID 1, connection #1. The remote host "<IP Address>", responded to the SMTP command "rcpt" with "530 SMTP authentication is required. ". The full command sent was "RCPT TO:<emailaddress> ". This will probably cause the connection to fail.

    The Non delivery receipt looks like this:

    There was a SMTP communication problem with the recipient's email server. Please contact your system administrator.
    <<ExchangeServerComputerName>.<domain>.local #5.5.0 smtp;530 SMTP authentication is required.>


    What We Have Done To Fix
    In the Outlook clients, we had our Exchange Server account set as default. Changed it yesterday when the issues started coming up so that it's our email provider account that is the default. Mail works fine when sent to outside recipients through the Arvixe account. But if it's sent through Exchange, then we have the errors.

    In Exchange, I created a SMTP connector to forward mail using DNS (have email provider dns servers as forwarders) and I enabled basic authentication with TLS using the username and password of an email account with our new email provider. I thought this worked as I didn't get an almost instantaneous DNR.

    I did however, get a delayed message, then just before completing this post, I got the NDR with the 'could not deliver in the time specified' error.

    So I really don't know what to do here. I don't mind starting over and changing our configuration as this is driving me bonkers!

    Update:
    I changed the authentication to basic and unchecked TLS. It may have worked now, but still, if this is not the way to do this, I want to know and want to fix it right. - Thanks!

    Any help would greatly be appreciated!
    Thanks much!
    JB
    Last edited by JazzBass; 19th May 2011, 17:56. Reason: Unchecked TLS in SMTP Connector

  • #2
    Re: Exchange Server 2003 and Sending External Mail Issues

    Unfortunately cannot help, but Rep++ for an excellent post -- an example to a lot of people
    Last edited by Ossian; 19th May 2011, 20:32.
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Exchange Server 2003 and Sending External Mail Issues

      Originally posted by Ossian View Post
      Unfortunately cannot help, but Rep++ for an excellent post -- an example to a lot people
      Thanks!

      Shows I read the posting instructions, eh?

      JB

      Comment


      • #4
        Re: Exchange Server 2003 and Sending External Mail Issues

        sounds like, when your exchange server is trying to relay mail to the upstream provider,

        that your upstream provider requires that your server authenticates before you can send mail
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Exchange Server 2003 and Sending External Mail Issues

          Originally posted by tehcamel View Post
          sounds like, when your exchange server is trying to relay mail to the upstream provider,

          that your upstream provider requires that your server authenticates before you can send mail
          Thanks tehcamel,

          (love the screen name)

          Yeah, that sounds right. What I don't understand is the following:

          Is there an account or username/password that my email provider has to give me to relay mail? Or by doing what I did (using a email account username/password) satisfy the requirement for authentication (I know it did, but not sure if that was the proper way to do it)

          Also, is there a way to not relay and just send out email from Exchange on it's own without relaying? Pros/Cons of doing that?

          Thanks,
          JB

          Comment


          • #6
            Re: Exchange Server 2003 and Sending External Mail Issues

            you can not relay if you want

            check your send-connector, and remove the Smarthost entry
            Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

            Comment


            • #7
              Re: Exchange Server 2003 and Sending External Mail Issues

              Originally posted by tehcamel View Post
              you can not relay if you want

              check your send-connector, and remove the Smarthost entry
              OK. Perfect.

              So I removed the smarthost entry and selected use DNS.

              I also went to the SMTP Virtual Server and configured DNS and I noticed that it did not have itself listed in the dns forwarder list, so I added 127.0.0.1 as the first entry, then our ISP (not email provider) dns servers. Not sure if that was needed or not, but it seems to be ok. I got a test message.

              My error may have been including the DNS servers for our email provider, so I deleted them out and only left the localhost and our ISP dns servers.

              Did I do that correctly, or can I remove the 127.0.0.1 from the dns forwarder list?

              Thanks ever so much! Looks like I just needed a connector, but I didn't have it configured correctly.

              JB

              Comment


              • #8
                Re: Exchange Server 2003 and Sending External Mail Issues

                not sure on where the DNS comes into it off the top of my head, and can't jump on something to look
                glad it seems to be working though !"
                Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

                Comment


                • #9
                  Re: Exchange Server 2003 and Sending External Mail Issues

                  Originally posted by tehcamel View Post
                  not sure on where the DNS comes into it off the top of my head, and can't jump on something to look
                  glad it seems to be working though !"
                  Thanks!

                  Well, I know I don't understand all the particulars as to how email works, but I tried removing the basic authentication from the SMTP connector and sending an email and it failed. It could not delivered because the receiptients SMTP server requires authentication (same error message as before)

                  I thought that if I was not relaying, recipient's servers do not need authentication? Shows how much I know.

                  So I added the smarthost back and authentication and it seems to be working again.

                  Anyone have thoughts? Or how I can make sure I'm not relaying? I guess maybe I do need to. I don't know. I'm so lost at this point.

                  Thanks again!
                  JB
                  Last edited by JazzBass; 20th May 2011, 17:38.

                  Comment


                  • #10
                    Re: Exchange Server 2003 and Sending External Mail Issues

                    www.exrca.com should check if you are an open relay.

                    Are you using SBS at all ?
                    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

                    Comment


                    • #11
                      Re: Exchange Server 2003 and Sending External Mail Issues

                      Originally posted by tehcamel View Post
                      www.exrca.com should check if you are an open relay.

                      Are you using SBS at all ?
                      No, we bought Exchange and installed after purchasing our server with Windows Server 2003.
                      (Though I was thinking of running the Internet Email wizard in it to see if that makes a difference)

                      Thanks for the link.

                      I ran the SMTP test via the link you gave me and all tests passed except this one:

                      Attempting to find the SPF record using a DNS TEXT record query.
                      ExRCA wasn't able to find the SPF record.

                      Additional Details
                      No records were found.

                      Do I need to add a SPF record with our hosting company, even though our server is not opened to the internet for incoming mail?

                      More Details:
                      I went back through our setup info with our old web/email provider and I found an entry showing our old static IP address for our web router and the following record:

                      Source TTL Type Destination
                      internetdomainname.com 14400 TXT v=spf1ptr ip4:<ipaddress> ip4:<differentipaddress> mx:mail.internetdomainname.com ~all

                      Do I need to add that record to our new hosting/email provider?

                      Thanks,
                      JB
                      Last edited by JazzBass; 20th May 2011, 18:55.

                      Comment


                      • #12
                        Re: Exchange Server 2003 and Sending External Mail Issues

                        An SPF record is not something that is required. All it does is stop other sites from spoofing your email, but the use is so low that it is close to useless. I don't have that setting on any domain that I manage.

                        Simon.
                        --
                        Simon Butler
                        Exchange MVP

                        Blog: http://blog.sembee.co.uk/
                        More Exchange Content: http://exchange.sembee.info/
                        Exchange Resources List: http://exbpa.com/
                        In the UK? Hire me: http://www.sembee.co.uk/

                        Sembee is a registered trademark, used here with permission.

                        Comment


                        • #13
                          Re: Exchange Server 2003 and Sending External Mail Issues

                          Originally posted by Sembee View Post
                          An SPF record is not something that is required. All it does is stop other sites from spoofing your email, but the use is so low that it is close to useless. I don't have that setting on any domain that I manage.

                          Simon.
                          Thanks Simon for the response. Good to know.

                          JB

                          Comment

                          Working...
                          X