No announcement yet.

Restoring a Public Folder does not work. Still empty.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Restoring a Public Folder does not work. Still empty.

    I have a customer who has an Exchange 2003 server (SBS) that has a Public Folder with Shared Contacts in it. I got a call from them earlier saying that the contacts were gone. The Public Folders are really only used for these Public Contacts which there are around 4000 of.

    I have restored several iterations of the pub1.edb and pub1.stm to no avail. Still no contacts. I've even gone back several months without any luck. These contacts change but only slightly from time to time when something changes on an individual contact. I went all the way back to a file from February and the file is the exact same size on EVERY version. Even if I restore from February, it still is empty.

    Is there some other issue that could cause the contacts in this folder to disappear? Because it seems weird that they were there this morning and now they are gone - plus the edb & stm files are the same size even from 2 months ago...

    I have logged on as Administrator and I still cannot see the contacts so I dont feel like it's a permissions issue.

    Is there some other place these contacts might be stored other than PUB1? That is the only Public Folder repository on the entire box.

  • #2
    Re: Restoring a Public Folder does not work. Still empty.

    How exactly are you restoring the data? Exchange gets a little upset if you just restore content.

    Furthermore, if deleted item retention is enabled, you shouldn't have to restore anything. Just find the user who deleted the content and restore it. Data doesn't delete on its own.

    Could also be a view, or the content has been simply moved.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.


    • #3
      Re: Restoring a Public Folder does not work. Still empty.

      It's funny, I just fixed it and was about to post what I did...

      I restored both the EDB and STR file from yesterday's 3pm backup to a different location. Then I ran ESEUTIL /p on the EDB and then I shut down the Public Info store. I renamed the existing files. I copied the ESEUTIL-ed files to the original location (D:\Program Files\Exchsrv\mdbdata) and started the Information Store and it mounted and my contacts were back!

      Gotta love when users delete stuff and say they didn't....


      • #4
        Re: Restoring a Public Folder does not work. Still empty.

        As Sembee said you didn't need to go through all that trouble. PFDAVADMIN could have done that for you in a couple of clicks literally. It can restore PF content back to the PF in question providing you have retention enabled on the DB. This includes ANY type of PF content.