Announcement

Collapse
No announcement yet.

Trouble with iPhone and Exchange setup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with iPhone and Exchange setup

    Hello,
    I was wondering if somebody could provide help (not links) on how to configure iPhone iOS 4.1 to work with my exchange server 2003.

    So far I have a domain www.n3wuk.co.uk when you goto this you are presented
    with the OWA logon page which uses SSL (certificate not verified)

    On system manager for exchange i have been on mobile services and enabled activesync and OMA.

    I can access OWA on safari by going to that URL, but when I try to configure the mail app to work it doesnt want to have any of it!

    I input the data after a short wait it asks for the server, i put that URL and have tried the URL that the link above redirects to, one stage it said cannot verify certificate authority or somethink I clicked continue anyways, it then proceeded to the annoying message I get everytime ' Unable to verify account information'

    Any clues? really bugging me that I can't get my mail to work on my iPhone and i'm out of options =/

    Thanks,
    Ryan.

  • #2
    Re: Trouble with iPhone and Exchange setup

    Do you have any other users who are working? If not, use testexchangeconnectivity.com to ensure that all is well with ActiveSync. Make sure you tell it to ignore the SSL trust. You should also install the root cert of your internal CA on the iPhone so that it trusts your ActiveSync website, or purchase a trusted cert from Comodo or GoDaddy or whoever.
    BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
    sigpic
    Cruachan's Blog

    Comment


    • #3
      Re: Trouble with iPhone and Exchange setup

      Originally posted by cruachan View Post
      Do you have any other users who are working? If not, use testexchangeconnectivity.com to ensure that all is well with ActiveSync. Make sure you tell it to ignore the SSL trust. You should also install the root cert of your internal CA on the iPhone so that it trusts your ActiveSync website, or purchase a trusted cert from Comodo or GoDaddy or whoever.
      Thanks for the reply!

      I managed to get it working by altering DNS settings on my domain host.

      It connected fine and required a passcode before it would download data, reluctantly i set one and it sync'd fine.

      I then googled to see if there was a way of removing the passcode they said to go on the system manager in exchange and right click mobile services and properties and then on device security untick require passcode.

      I did this and now i cannot connect to the exchange on the phone again grr!

      Tried putting the settings back and it doesn't wanna no!

      Any ideas?

      Comment


      • #4
        Re: Trouble with iPhone and Exchange setup

        You'll probably need to delete and re-create the account now. The passcode on the phone is an ActiveSync policy and is required before you can connect to Exchange. I'd leave it as is personally, not having a passcoded phone with corporate email on it is a big security no-no.
        BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
        sigpic
        Cruachan's Blog

        Comment


        • #5
          Re: Trouble with iPhone and Exchange setup

          Sidenote for people reading this thread:
          http://www.apple.com/support/iphone/enterprise/

          and iPhone Configuration Utility 3.3 for Windows - great little app. Used it to set up a strong password for an iPad last week. Couldn't type some of the characters on the iPad keyboard. Could help you later on when locking down iPhones.
          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment

          Working...
          X