Announcement

Collapse
No announcement yet.

Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

    Hello!

    I have a big problem. This morning I have installed service pack 2 for Exchange 2003. I am getting error HTTP_500 when mobile devices try to connect.
    - Outlooks are working
    - OWA is working
    - Outlooks connected via - RPC over HTTP are working
    - Mobile devices with (crtcheck set to off) not working disconnected with error HTTP_500
    - OMA is not working any more (using without SSL - http://domain/oma) error: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.

    On server I have this errors on server event viewer:
    No Basic credentials were found in the HTTP request. To fix this problem, verify that Basic authentication is turned on and all other authentication methods are turned off on the Outlook(R) Mobile Access virtual directory.
    -
    An unknown error occurred while processing the current request:
    Message: Object reference not set to an instance of an object.
    Source: Microsoft.Exchange.OMA.UserInterface
    Stack trace: at Microsoft.Exchange.OMA.UserInterface.Global.Applic ation_PreRequestHandlerExecute(Object sender, EventArgs e) at system.Web.SyncEventExecutionStep.System.Web.HttpA pplication+IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean& completedSynchronously)


    I think SP2 changed some security settings. Any ideas?

    Thank you for your help,
    Luka

  • #2
    Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

    Please enable Basic authntication of the default web site. Please enable SSL on this site and restart the IIS.


    http://www.microsoft.com/technet/pro...3/top10kb.mspx

    http://www.petri.com/problems_with_f...activesync.htm
    Last edited by yuval14; 28th October 2005, 23:47.
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

      I did that and now I am able to authenticate but I get a strange page where no icons are loaded. It is something like OWA but the icons are not shown - as they are missing. Mobile device still geting error HTTP_500. (testing with internet explorer - http://domain/exchange-oma) Before service pack 2 I was able to get to the oma page (with the warning that my client is not compactible but it worked...)

      Can you tell me if I am forced to have the server certificate on my PDA? Even if I am using crtcheck.exe set to off? (I had that before.) And should I use SSL connection on my Mobile?

      Comment


      • #4
        Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

        vagant,

        I had the same problem this morning. However, I had to fix OWA as it appears the service pack 2 wrote over the logon.asp. I was receiving the "domain/user" instead of just user again on my form based login page. Fortuanetly, I backed up the server and restored the logon.asp and that problem was resolved.

        For the issue of receiving the HTTP_500 error:

        In the IIS, Directory Security I choose Edit "Authentication and access control"
        and checked the box next to: Integrated Windows Authentication, Digest authentication for windows servers (optional) and Basic authentication. Default domain: \

        I am concerned about the "Basic Authentication" because of the password is sent in clear text. I am not sure of the settings before this upgrade to sp2. Try this and post back your results. Also, if you know of a way to get around checking the Basic authentication or the fix you found.

        --Mark

        Comment


        • #5
          Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

          I had the same problem this morning. However, I had to fix OWA as it appears the service pack 2 wrote over the logon.asp. I was receiving the "domain/user" instead of just user again on my form based login page. Fortuanetly, I backed up the server and restored the logon.asp and that problem was resolved.

          I did not have souch problem. My OWA is working as before. Strange...

          For the issue of receiving the HTTP_500 error:

          In the IIS, Directory Security I choose Edit "Authentication and access control"
          and checked the box next to: Integrated Windows Authentication, Digest authentication for windows servers (optional) and Basic authentication. Default domain: \

          When I did Digest authentication my OWA, Outlooks and stuff stopped to work. I had to remove this option.

          I am concerned about the "Basic Authentication" because of the password is sent in clear text. I am not sure of the settings before this upgrade to sp2. Try this and post back your results. Also, if you know of a way to get around checking the Basic authentication or the fix you found.

          I was able to make OMA working again (using basic authentication / I had that before (and it is set as default on let say Windows 2003 SBS)) but I have still problems with my mobile devices. Still HTTP_500.

          OMA Config:
          Right click on OMA in Default Web Site
          Properties
          Directory security
          Authentication and access control / Edit
          DISABLE anonymus access
          ENABLE Basic authentication
          Default domain: \
          Realm: EMPTY

          It woks now.
          Any ideas about my mobile settings? As I have said. On my mobile devices I have the server certificate and I am connecting using SSL on my MOBILE. I used certchk to disable certificate checking.

          Log on my device shows:

          Client
          Microsoft-server active synch user...
          MS-ASProtocolVersion: 2.0

          Server response:
          HTTP/1.1 200 OK
          MS-ASProtocol commands:
          Sync, SendMail, SmartForward...
          MS-ASProtocol Version: 1.0.2.0.2.1...

          Client request:
          POST
          Microsoft-Server-ActiveSync?User=username&Device...

          Server response:
          HTTP/1.1 500 Internal server error

          Comment


          • #6
            Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

            I suppose I am not too sure on this. We do not have any users using the OMA feature on the exchange activesync. I am not familiar with this setup, but you might try enabling anonymous access...I came across an artcle about enabling this.

            Comment


            • #7
              Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

              Not working... I am without ideas...

              Comment


              • #8
                Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                Folow this: http://support.microsoft.com/default.aspx?kbid=817379

                And wait a minute or two after restarting IIS. If you will try to start synchronization to quick you will get the same old error (500 on 403)

                Comment


                • #9
                  Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                  I'm having the same issue as well. Everthing else works fine - OWA, Outlook, etc., but when trying to use EAS on my device I get the "Error 500: Internal Server error". It's driving me nuts!!!!!

                  Comment


                  • #10
                    Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                    Just try using the MS article I have posted in my recent post.

                    Vagant

                    Comment


                    • #11
                      Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                      I have the same problem. OMA was working fine until I applied SP2, now my devices get htpp_500 error. owa is fine.

                      I looked at the article vagant referred to, but I don't think it applies. I don't have a front-end/back-end configuration, SSL is not required for any of the virtual roots, and forms-based auth is not enabled.

                      Anyone solve this problem yet?
                      Thanks.
                      -jpr

                      Comment


                      • #12
                        Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                        Did you have SP1 on that machine before installing SP2?
                        Cheers,

                        Daniel Petri
                        Microsoft Most Valuable Professional - Active Directory Directory Services
                        MCSA/E, MCTS, MCITP, MCT

                        Comment


                        • #13
                          Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                          Hi,

                          This is my first message in this forum, but I am kind of engaged in the PocketPC business as well; my name is Helio Diamant and I am the editor of PocketPCFreak.com .

                          Daniel and myself have been working for the last days on a similar problem with my server and PPC (everything works, including OMA, except for Sync with SSL activated). It seems that today we have found the reason and the workaround.

                          The reason: I only had the Certificate for the Default Web Site installed in my PPC.

                          The solution: Install the Root CA Certificate in the PPC as well

                          How to do it:

                          1. With the computer browser go to http://servername/certsrv
                          2. Login as necessary
                          3. Click on Download a CA certificate, certificate chain, or CRL
                          4. Click on Download CA certificate
                          5. Save the file. Take note on where it was saved.
                          6. Copy the file to your device's memory or storage card.
                          7. With File Explorer in the device, find the file and click on it to execute.
                          8. Accept the certificate.

                          After that, sync began to work on my PPC. I hope it will help some of you guys.

                          Best regards,

                          Helio

                          Comment


                          • #14
                            Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                            Exchange 2003 SP2
                            We have error HTTP_500 from Pocket device with WM3 and WM5.

                            Resolved................

                            It's only an IIS configuration problem.
                            On front-end and back-end, set proper permissions at "Default Web Site", "Exchange Virtual Server" and "Exchangeweb and subfolder Bin" levels

                            Back-end:
                            • Exchange Virtual Server --> Integrated + Basic + default domain
                            • VD Exchange --> Integrated + Basic + default domain
                            • VD ExchangeWeb --> Enable Anonymous ONLY
                            • Bin under ExchangeWeb --> Integrated + Basic + default domain


                            Front-end
                            • Default Web Site --> Enable Anonymous + Integrated + Basic + default domain
                            • VD Exchange --> ONLY Basic + default domain
                            • VD ExchangeWeb --> ONLY Enable Anonymous
                            • Bin under ExchangeWeb --> ONLY Basic + default domain

                            Comment


                            • #15
                              Re: Exchange 2003 after upgrading to SP2 - error http_500 on mobile devices

                              Setting integrated authentication on the /exchange virtual directory fixes this problem, until an update for Exchange removes the setting.

                              I discovered this fix months ago and have used it myself, but for some reason Microsoft do not want you to use that as the fix and will remove the integrated authentication option almost at random on the /exchange virtual folder.

                              Simon.
                              --
                              Simon Butler
                              Exchange MVP

                              Blog: http://blog.sembee.co.uk/
                              More Exchange Content: http://exchange.sembee.info/
                              Exchange Resources List: http://exbpa.com/
                              In the UK? Hire me: http://www.sembee.co.uk/

                              Sembee is a registered trademark, used here with permission.

                              Comment

                              Working...
                              X