Announcement

Collapse
No announcement yet.

Authentication with ISP Smarthost

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Authentication with ISP Smarthost

    Hi all,

    I have a problem sending out mail from my exchange server through a smarthost at my ISP. Let me give you some details:
    • the server is a Windows SBS 2003 server with Exchange 2003 and patched to the latest patchlevels.
    • the smarthost is at the ISP and uses port 26 for SMTP transport and requires authentication. (port 25 is a non flyzone on my internet connection)
    • I have reconfigured the default virtual smtp service to use port 26 and have provided the username and password to connect to the smarthost
    • also I have entered the needed information in the smtp connector.
    When I try to send mail I get a message that I am not allowed to relay:

    You do not have permission to send to this recipient. For assistance, contact your system administrator. <[fqdn] #5.7.1 smtp;550 5.7.1 <[external email address]>... Relaying denied. Proper authentication required.>

    I have tried to telnet into the smarthost on port 26 and that is successful. I also can AUTH login using the BASE-64 encoded username and password. When after authenticating I try to send a message trhough the telnet session all works as expected.

    Somehow my settings on the exchange server are not correct. Now I just need to find out what is wrong.

    Any help/advise is welcome

  • #2
    Re: Authentication with ISP Smarthost

    Have you asked your ISP support team for help -- they should be familiar with Exchange and be able to help you with the precise configuration
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Authentication with ISP Smarthost

      I have been in contact with the supportteam of the ISP. they only provide support on email clients and not for server email programs like exchange.

      Comment


      • #4
        Re: Authentication with ISP Smarthost

        It is not clear to me wether to set the properties for the default SMTP virtual server, the SmallBusiness SMTP connector or both.

        in the SmallBusiness SMTP connector I have the following settings:
        • general:
          Forward all mail through this connector to the following smart hosts (entered the fqdn for the email domain at the ISP)
        • advanced:
          Outbound security (entered username and password provided by ISP)
          Do not send ETRN/TURN
        in the Default SMTP Virtual Server I have the following settings:
        • Delivery:
          Outbound security:
          Basic Authentication (entered username and password provided by ISP)
          Outbound Connections: TCP port 26
          Advanced: Fully Qualified domein name and Smart host( entered the fqdn of the email domain at the ISP)
        Recieving mail is not a problem since we use the POP3 Connector Manager for that.

        Comment


        • #5
          Re: Authentication with ISP Smarthost

          You shouldn't set the smart host on the SMTP virtual server. It should only be set on the SMTP Connector. Furthermore, I believe the Internet Email wizard (or whatever it is called) will ask you if the outbound server requires configuration.

          Therefore I would suggest that you run the wizard, enter the username and password given to you by the ISP when prompted.

          @Ossian - an ISP familiar with Exchange. That would be a first. They can't support Outlook Express properly let alone anything else. Remember ISP tech support only have one goal - to wait for you to mention a product they don't support (so pretty much anything other than IE and Outlook Express) so they can go "not supported" and close the call in their stats.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: Authentication with ISP Smarthost

            I dunno -- I use PlusNet in the UK and they are very happy to talk about all sorts of things, including Exchange, with some degree of familiarity and understanding. They even know what a "port" is
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd
            Scotland

            ** Remember to give credit where credit is due and leave reputation points where appropriate **

            Comment


            • #7
              Re: Authentication with ISP Smarthost

              Have run the configure email wizard, but still no luck. I enabled logging on the Exchange Transport SMTP and get the following error in the event log:


              This is an SMTP protocol error log for virtual server ID 1, connection #1. The remote host "[ip-address of ISP SMTP smarthost]", responded to the SMTP command "rcpt" with "550 5.7.1 <[external email address]>... Relaying denied. Proper authentication required. ". The full command sent was "RCPT TO:<[external email address]> ". This will probably cause the connection to fail.

              Seems like exchange is not authenticating against the smarthost with the provided username and password provided in the properties of the SmallBusiness SMTP connector, because sending mail from the commandprompt in the telnet session works. At least after an AUTH login and providing BASE-64 encoded credentials

              You would guess that if it works through a telnet session it should work from exchange, but it doesn't.

              Erik




              Comment


              • #8
                Re: Authentication with ISP Smarthost

                Originally posted by Ossian View Post
                I dunno -- I use PlusNet in the UK and they are very happy to talk about all sorts of things, including Exchange, with some degree of familiarity and understanding. They even know what a "port" is
                You're lucky, most BT "support" staff don't know what a smarthost is.
                BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
                sigpic
                Cruachan's Blog

                Comment


                • #9
                  Re: Authentication with ISP Smarthost

                  Most BT "support" staff do not know what "support" is, or even where "Britain" is
                  Tom Jones
                  MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                  PhD, MSc, FIAP, MIITT
                  IT Trainer / Consultant
                  Ossian Ltd
                  Scotland

                  ** Remember to give credit where credit is due and leave reputation points where appropriate **

                  Comment

                  Working...
                  X