No announcement yet.

Exchange 2003: No access from second subnet

  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2003: No access from second subnet

    Hello all, I need help once again

    I have two subnets that connected via VPN (site to site cisco).
    Any machine on the same subnet as the exchange server works fine, OWA from any machine (either subnet and obviously public IPs) works fine.

    If I try to connect from a machine on the secondary subnet the system appears to get stuck in the authentication phase. It keeps asking me to supply credentials and then eventually it fails with "The connection to Microsoft Exchange is unavailable". (I thought maybe AD issue, but I can login to this site's terminal environment and open email with outlook there)

    I have looked via good old google and found several fixes, but none of them work for me.

    What I have done so far:
    Telnet: Originally I had the 220 ****************
    Solution: I ran "no fixup protocol smtp 25" on both routers and rebooted them

    I looked in global filtering and could locate anything to prevent outside subnets from working.

    I can ping from both sides (exchange to desktop, desktop to exchange) and I can run nslookup from both sides.

    My environment
    Dual site (ADSS) (I posted previously with replication issues, but they are resolved now) and the exchange is in the Second site (desktop is in primary).

    The exchange server is sitting on subnet 1.1.222.x and the desktops are on 1.1.111.x and are connected via VPN tunnels on two cisco asa devices.


  • #2
    Re: Exchange 2003: No access from second subnet

    Some additional information:

    The exchange server is a VM inside VMWare, I moved the exchange server to a datacenter and changed the IP address of the exchange server.

    As stated above I think DNS is fine as nslookup works from all my DNS servers.

    The move process was pretty smooth, The VM sits on an EMC device that is replicated to another site (datacenter). I turned off the VM and waited for replication to finish. I switched the replication and mounted the NFS to my Datacenter VMs. I then added the VM and booted it up. The machines are identical that the system runs on and I only have to fix the IP settings and adjust DNS.

    Outside email works fine, but vpn email is the challenge.



    • #3
      Re: Exchange 2003: No access from second subnet

      Some additional information:
      If I go into Control Panel, Mail and setup the exchange account the following happens.
      FQDN = a popup asking to login into "username" (IE: login into Hobie) and eventually fails
      IP = a popup again, but once I enter the information it replaces the IP with FQDN name. It says everything is successful, but when I open outlook it never connects.

      I tried to bypass DNS by placing the exchange FQDN in my Hosts. file but still did not work.

      Thanks again!


      • #4
        Re: Exchange 2003: No access from second subnet

        Got it working..

        Turns out my replication issues where not 100% solved.

        Once I fixed replication (I could not figure it out quickly so demoted and promoted the servers back) exchange worked again.

        let me know what you would have done to troubleshoot.