No announcement yet.

Activesync fails with OPTION command fail and HTTP 500 error

  • Filter
  • Time
  • Show
Clear All
new posts

  • Activesync fails with OPTION command fail and HTTP 500 error

    I am trying to configure activesync on Exchange 2003 sp2 server.

    It is a single server environment. I also have Exchange over RPC running fine on site. Exchange web access ok, along with oma access.

    The error I get on the remote connectivity tester is at the bottom of this lot.

    ExRCA is testing Exchange ActiveSync.
    The Exchange ActiveSync test failed.
    Test Steps
    Attempting to resolve the host name in DNS.
    Host successfully resolved
    Additional Details
    IP(s) returned: xxxx

    Testing TCP Port 443 on host to ensure it is listening and open.
    The port was opened successfully.
    ExRCA is testing the SSL certificate to make sure it's valid.
    The certificate passed all validation requirements.
    Test Steps
    The certificate name is being validated.
    Successfully validated the certificate name
    Additional Details
    Found hostname in Certificate Subject Common name

    The certificate date is being confirmed to ensure the certificate is valid.
    Date validation passed. The certificate hasn't expired.
    Additional Details
    Certificate is valid: NotBefore = 6/4/2009 11:38:16 AM, NotAfter = 6/4/2011 11:38:16 AM"

    The IIS configuration is being checked for client certificate authentication.
    Client certificate authentication wasn't detected.
    Additional Details
    Accept/Require Client Certificates not configured.

    Testing Http Authentication Methods for URL https : // mail . xxx .co . uk // microsoft-server-activesync/
    The HTTP authentication methods are correct.
    Additional Details
    Found all expected authentication methods and no disallowed methods. Methods Found: Basic

    An ActiveSync session is being attempted with the server.
    Errors were encountered while testing the ActiveSync session
    Test Steps
    ExRCA is attempting to send the OPTIONS command to the server.
    Testing of the OPTIONS command failed. For more information, see Additional Details.
    Additional Details
    An HTTP 500 response was returned from Unknown

    So far I have tried:

    Rebuilding the virtual directories, adding the exchange-oma directory, testing with different account.

    I have compared to other working implementations of activesync I have at other sites and can see no obvious difference. Form based authentication is off.

    I have happily got outlook over https working here, along with web access and OMA so right ports are open etc.

    I have a godaddy cert on this server.

    Any suggestions most welcome.



  • #2
    Re: Activesync fails with OPTION command fail and HTTP 500 error

    Have just checked the connectivity again and all is fine this morning. Bit odd but assume a maintenance procedure must have run overnight and made one of my settings changes 'stick'.

    Remote Connectivity Analyzer now completes fine, and emails now arriving to my test account on my iphone.

    Peculiar but it is solved, so on to today's next challenge.,...